Enable mongodb for ppc64el

Bug #1288633 reported by James Page
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mongodb (Ubuntu)
High
James Page
Trusty
High
James Page

Bug Description

libv8 is available now - we should enable mongodb for this arch as well.

James Page (james-page)
Changed in mongodb (Ubuntu Trusty):
importance: Undecided → High
assignee: nobody → James Page (james-page)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mongodb - 1:2.4.9-1ubuntu1

---------------
mongodb (1:2.4.9-1ubuntu1) trusty; urgency=medium

  * Enable ppc64el build (LP: #1288633):
    - d/control: Add ppc64el to target architectures.
    - d/control: Use google-perftools on ppc64el.
    - d/p/0004-Support-ppc64el-builds.patch: Detect ppc64 as 64 bit platform.
  * Enable javascript-less arm64 build (LP: #1288634):
    - d/control: Add arm64 to target architectures, ignore libv8-dev for arm64.
    - d/p/0002-SERVER-12065-Support-ARM-and-AArch64-builds.patch: Add support
      for arm64.
    - d/p/0001-Add-option-to-disable-javascript.patch: Add option to disable
      javascript engine.
    - d/rules: Disable scripting and drop mongo binary for arm64.
  * General non-x86 enablement:
    - d/p/0005-ARM-support-for-ASM-operations-in-MongoDB.patch: dropped in
      preference to upstream accepted patch from Robie Basak:
    - d/p/0001-SERVER-12064-Atomic-operations-for-gcc-non-Intel-arc.patch: Use
      gcc provided atomic operations for non-Intel archs.
  * d/mongodb-server.mongodb.upstart: Bump nofile limit to 64000 (LP: #1283007).
  * d/control: Use google-perftools on armhf.
 -- James Page <email address hidden> Thu, 06 Mar 2014 11:08:10 +0000

Changed in mongodb (Ubuntu Trusty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers