Modprobe passes 11n_disable=1 option to iwl3945 which doesn't support the option

Bug #747025 reported by Bilal Akhtar on 2011-04-01
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
module-init-tools (Ubuntu)
High
Tim Gardner
Natty
High
Tim Gardner

Bug Description

Binary package hint: module-init-tools

Module-init-tools 3.12-1ubuntu5 introduced a change which automatically passed the 11n_disable=1 option to iwl3945. The iwl3945 module doesn't support this option (as 802.11n is disabled by default). Hence iwl3945 fails to load with a simple message:

iwl3945: Unknown option: 11n_disable

A temporary workaround is to remove /etc/modprobe.d/intel-3945-iwlagn-disable11n.conf file and then run sudo modprobe iwl3945 .

Bilal Akhtar (bilalakhtar) wrote :

Confirmed by multiple people on #ubuntu+1. Importance is high since it breaks up WiFi for users.

Changed in module-init-tools (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Bilal Akhtar (bilalakhtar)
milestone: none → ubuntu-11.04-beta-2
status: Triaged → In Progress
Bilal Akhtar (bilalakhtar) wrote :

This is the debdiff. I have confirmed the fix to be working well locally.

Changed in module-init-tools (Ubuntu):
assignee: Bilal Akhtar (bilalakhtar) → nobody
status: In Progress → Triaged
Martin Pitt (pitti) on 2011-04-01
Changed in module-init-tools (Ubuntu Natty):
assignee: nobody → Tim Gardner (timg-tpi)
Tim Gardner (timg-tpi) on 2011-04-01
Changed in module-init-tools (Ubuntu Natty):
status: Triaged → In Progress
Vladimir Scherbaev (zemik) wrote :

user@user-laptop:~$ modinfo iwl3945
filename: /lib/modules/2.6.38-7-generic/kernel/drivers/net/wireless/iwlwifi/iwl3945.ko
firmware: iwlwifi-3945-2.ucode
license: GPL
author: Copyright(c) 2003-2010 Intel Corporation <email address hidden>
version: in-tree:s
description: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux
srcversion: 08BA403405B97DE1DE3DA90
alias: pci:v00008086d00004227sv*sd*bc*sc*i*
alias: pci:v00008086d00004222sv*sd*bc*sc*i*
alias: pci:v00008086d00004227sv*sd00001014bc*sc*i*
alias: pci:v00008086d00004222sv*sd00001044bc*sc*i*
alias: pci:v00008086d00004222sv*sd00001034bc*sc*i*
alias: pci:v00008086d00004222sv*sd00001005bc*sc*i*
depends: iwlcore,cfg80211,mac80211
vermagic: 2.6.38-7-generic SMP mod_unload modversions 686
parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
parm: swcrypto:using software crypto (default 1 [software])
 (int)
parm: disable_hw_scan:disable hardware scanning (default 0) (deprecated) (int)
parm: fw_restart3945:restart firmware in case of error (int)

cat intel-3945-iwlagn-disable11n.conf
options iwl3945 11n_disable=1

user@user-laptop:/etc/modprobe.d# modprobe iwl3945
FATAL: Error inserting iwl3945 (/lib/modules/2.6.38-7-generic/kernel/drivers/net/wireless/iwlwifi/iwl3945.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Vladimir Scherbaev (zemik) wrote :

Work with:

user@user-laptop:~$ cat /etc/modprobe.d/intel-3945-iwlagn-disable11n.conf
options iwl3945

Tim Gardner (timg-tpi) wrote :

Ah, crud! I somehow thought that module parameter was still valid for iwl3945. Attached is a bit simpler patch that just removes the conf file. It was never valid, and is unlikely to ever be used again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package module-init-tools - 3.12-1ubuntu6

---------------
module-init-tools (3.12-1ubuntu6) natty; urgency=low

  * Remove intel-3945-iwlagn-disable11n.conf completely as it has an
    erroneous module parameter. (LP: #747025)
 -- Tim Gardner <email address hidden> Fri, 01 Apr 2011 07:19:50 -0600

Changed in module-init-tools (Ubuntu Natty):
status: In Progress → Fix Released
Pablo Antonio (crazy2k) wrote :

That was fast. Thanks!

Baditaflorin (baditaflorin) wrote :

I don`t know if is the same bug, but because of this 11n_disable=1 my internet was working like crap. Ubuntu 12.04, upgrade, i tried fresh install and the same stuff.

I found a solution on the forum : My modem is diferent, but i see that most of the laptops that have iwl4965 are afected bt this.

Hi,
To disable 802.11n on this card create /edit your /etc/modprobe.d/options.conf file like this.
Code:
Code:

gksu gedit /etc/modprobe.d/options.conf

And add the following to it:
Code:

options iwl4965 11n_disable=1

proof read then save and exit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers