depmod fails if /lib/modules/$KVER is a file

Bug #366694 reported by ath on 2009-04-25
68
This bug affects 6 people
Affects Status Importance Assigned to Milestone
module-init-tools (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: module-init-tools

the needed directory /lib/modules/<prev-version> was a file, I had to remove the file and mkdir the directory, to progress with upgrade. after that run dpkg --configure module-init-tools and dpkg --configure -a. then system became normally bootable.

ProblemType: Package
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu4
 libc6 2.9-4ubuntu6
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: subprocess post-installation script returned error exit status 1
Package: module-init-tools 3.7~pre9-2
SourcePackage: module-init-tools
Title: package module-init-tools 3.7~pre9-2 failed to install/upgrade:
Uname: Linux 2.6.28-11-generic i686

ath (ath-embiq) wrote :
summary: - dist upgrade failed on the package uprgade
+ depmod fails if /lib/modules/$KVER is a file
Changed in module-init-tools (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Thomas Randall (trandall21) wrote :

this is affecting my computer

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers