modem-manager crashed with SIGSEGV in internal_queue_command()

Bug #963102 reported by Pete Goodall on 2012-03-23
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Medium
Unassigned

Bug Description

This may be the same as bug #915460, but it isn't (afaik) triggered the same way on my system. I get a modem-manager crash on login. This happens consistently every time I login.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: modemmanager 0.5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Tue Mar 20 09:44:33 2012
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/sbin/modem-manager
ProcCmdline: /usr/sbin/modem-manager
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: modemmanager
StacktraceTop:
 ?? ()
 ?? ()
 mm_serial_port_queue_command ()
 ?? ()
 ?? ()
Title: modem-manager crashed with SIGSEGV in mm_serial_port_queue_command()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Revision history for this message
Pete Goodall (pgoodall) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? ()
 internal_queue_command (self=0x1755500, command=<optimized out>, take_command=1, cached=0, timeout_seconds=3, callback=0, user_data=0x0) at mm-serial-port.c:965
 mm_serial_port_queue_command (self=<optimized out>, command=<optimized out>, take_command=<optimized out>, timeout_seconds=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at mm-serial-port.c:1007
 disable_flash_done (port=0x1755500, error=<optimized out>, user_data=0x1794b70) at mm-generic-gsm.c:2081
 callback_info_done (user_data=0x178d770) at mm-callback-info.c:79

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in modemmanager (Ubuntu):
importance: Undecided → Medium
summary: - modem-manager crashed with SIGSEGV in mm_serial_port_queue_command()
+ modem-manager crashed with SIGSEGV in internal_queue_command()
tags: removed: need-amd64-retrace
visibility: private → public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Fix is in the Precise queue, waiting to be reviewed (or will be released once Beta2 is released)

Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.5.2.0-0ubuntu2

---------------
modemmanager (0.5.2.0-0ubuntu2) precise; urgency=low

  * debian/patches/git_serial_command_on_closed_port_d41d62f.patch: avoid crash
    because of commands being set on a closed port when the command's callback
    is NULL. (LP: #963102)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 23 Mar 2012 14:35:38 -0400

Changed in modemmanager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers