Ubuntu

3G modem Device 1d09:1010 TechFaith Wireless Technology Limited not detected

Reported by Laudeci Oliveira on 2012-03-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
modemmanager (Ubuntu)
Medium
Unassigned

Bug Description

it recognize the device using the following commands:

modprobe -v option
echo '1d09 4000' > /sys/bus/usb-serial/drivers/option1/new_id

The result is :

Mar 19 21:58:53 localhost kernel: [ 5442.775419] sr: Sense Key : Hardware Error [current]
Mar 19 21:58:53 localhost kernel: [ 5442.775429] sr: Add. Sense: No additional sense information
Mar 19 21:58:53 localhost kernel: [ 5442.888143] usb 6-1: reset full-speed USB device number 6 using uhci_hcd
Mar 19 21:58:54 localhost kernel: [ 5443.148119] usb 6-1: reset full-speed USB device number 6 using uhci_hcd
Mar 19 21:58:54 localhost kernel: [ 5443.412067] usb 6-1: reset full-speed USB device number 6 using uhci_hcd
Mar 19 21:58:54 localhost kernel: [ 5443.700118] usb 6-1: reset full-speed USB device number 6 using uhci_hcd
Mar 19 21:58:55 localhost kernel: [ 5444.308087] usb 6-1: USB disconnect, device number 6
Mar 19 21:58:58 localhost kernel: [ 5447.080098] usb 6-1: new full-speed USB device number 7 using uhci_hcd
Mar 19 21:58:58 localhost mtp-probe: checking bus 6, device 7: "/sys/devices/pci0000:00/0000:00:1d.0/usb6/6-1"
Mar 19 21:58:58 localhost kernel: [ 5447.250241] usbserial_generic 6-1:1.0: GSM modem (1-port) converter detected
Mar 19 21:58:58 localhost kernel: [ 5447.250519] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB0
Mar 19 21:58:58 localhost kernel: [ 5447.252419] usbserial_generic 6-1:1.1: GSM modem (1-port) converter detected
Mar 19 21:58:58 localhost kernel: [ 5447.252680] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB1
Mar 19 21:58:58 localhost kernel: [ 5447.254182] usbserial_generic 6-1:1.2: GSM modem (1-port) converter detected
Mar 19 21:58:58 localhost kernel: [ 5447.254385] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB2
Mar 19 21:58:58 localhost mtp-probe: bus: 6, device: 7 was not an MTP device

It list all /dev/ttyUSB[n] but NM didnt show it to create a new mobile broadband device

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.3.995+git201203152001.04b2a74-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CheckboxSubmission: 681590ec7a5236cfda19918622455e82
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Mon Mar 19 22:20:02 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IpRoute:
 default via 192.168.8.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 172.16.108.0/24 dev vmnet1 proto kernel scope link src 172.16.108.1
 192.168.8.0/24 dev wlan0 proto kernel scope link src 192.168.8.31 metric 2
 192.168.217.0/24 dev vmnet8 proto kernel scope link src 192.168.217.1
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: Upgraded to precise on 2012-03-18 (1 days ago)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2012-02-06T10:03:43.549680
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.3.995 connected enabled enabled enabled enabled disabled

Laudeci Oliveira (laudeci) wrote :

From here, the best guess is that ModemManager doesn't see the modem. Normally we should be seeing traces of it being detected in the WifiSyslog file (which is actually just a snapshot of a grep of /var/log/syslog).

Please follow the steps in https://wiki.ubuntu.com/DebuggingNetworkManager#Getting_debug_logs to get debug logs for NetworkManager and ModemManager. For this, what you'll want to do is to enable debugging mode as per the steps in that wiki page when the modem is disconnected; connect the modem, then wait a bit and take a copy of /var/log/syslog to attach to this bug report.

Also, if you've found the command for the option driver on the Internet, have you also tried to connect with that modem using wvdial? Getting the right wvdial settings may help in figuring out important information for ModemManager, such as at least the right ttyUSB port to use.

Reassigning to modemmanager since right now there is no indication that it's detecting the device at all; I'm also opening a 'linux' task since there's an extra ID needed in the option driver, if that's the right driver for that device.

affects: network-manager (Ubuntu) → modemmanager (Ubuntu)
Changed in modemmanager (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.31
Laudeci Oliveira (laudeci) wrote :

Sending the results in the attachment.
The modem still as reported above.

Laudeci Oliveira (laudeci) wrote :

Setting back to Confirmed for the kernel test with 3.2.0-19.31; from what I see in the debug log the ID is indeed still missing from the option driver.

To continue debugging this in parallel: could you also provide debug logs from ModemManager as it behaves after you've done the new_id command?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
Laudeci Oliveira (laudeci) wrote :

All information as requested. Same proposed kernel and still not working

So it indeed looks like that modem is also not currently supported at all from what is in the debug logs for MM: it's getting claimed by the generic plugin.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing

The fix is definitely not upstream; it's easy enough to verify in the code, so I'm adding the kernel-bug-exists-upstream tag and setting back to Confirmed.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in modemmanager (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged

Laudeci Oliveira, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-upstream-testing
removed: kernel-request-3.2.0-19.31 kernel-request-3.2.0-22.35
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers