Ubuntu

DUN reconnection fails with Nokia C7

Reported by Václav Šmilauer on 2012-01-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ModemManager
Fix Released
Medium
modemmanager (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

Modem-manager fails when estalishing connection through a Nokia C7 phone after the first time; the first time connection (after phone fresh reboot) works fine.

This bug is analogous to #769497, but for a different device. I reported it upstream at https://bugzilla.gnome.org/show_bug.cgi?id=667869 and put it here for the record.

Changed in modemmanager:
importance: Unknown → Medium
status: Unknown → New
Václav Šmilauer (eudoxos) wrote :

Upstream bug has link to a work-around patch; patched version of modemmanager for oneiric available in my ppa:
https://launchpad.net/~eudoxos/+archive/ppa

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed

Next stable MM 0.5 release will come with the patch.

Changed in modemmanager:
status: New → Fix Released

I'll upload 0.5.1.97 shortly, it includes that fix.

Changed in modemmanager (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.5.1.97-0ubuntu1

---------------
modemmanager (0.5.1.97-0ubuntu1) precise; urgency=low

  * New upstream bugfix release.
    - release: update NEWS
    - cdma: fix crash on NULL error (bgo #670145)
    - Revert "huawei: rework probing and detection" (LP: #868034)
    - core: fix loop limits in echo removal
    - at-serial-port: implement built-in echo/garbage removal (LP: #916038)
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 07 Mar 2012 16:22:00 -0500

Changed in modemmanager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.