Add ignore rule for Arduino to udev blacklist

Bug #910736 reported by Artem Popov on 2012-01-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

When connecting an Arduino or any Arduino-based device (like monome) modemmanager immediately starts exchanging data with the device, causing problems for software that works with these devices, namely serialosc and the Arduino IDE.

Blacklisting the affected devices currently seems the best way to solve the problem, as found by doing a search for simular bugs, e.g. bug 842702, bug 807889 and bug 490194.

Artem Popov (artfwo) on 2012-01-02
Changed in modemmanager (Ubuntu):
status: New → In Progress
assignee: nobody → Artem Popov (artfwo)
Artem Popov (artfwo) wrote :

Attaching a debdiff too.

Changed in modemmanager (Ubuntu):
status: In Progress → Confirmed
assignee: Artem Popov (artfwo) → nobody
Artem Popov (artfwo) wrote :

debdiff updated against the updated branch.

Artem Popov (artfwo) on 2012-01-02
description: updated
description: updated

Thanks for doing this!

It looks fine, but could you please re-do the merge proposal against lp:~modemmanager/modemmanager/ubuntu, which is the correct branch for packaging modemmanager used by both Debian and Ubuntu?

I think this also deserves being forwarded upstream, if it hasn't been done already.

Artem Popov (artfwo) wrote :

Attaching old-style simple debdiff, because of the messed up merge proposal.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.5+git.20111231t174444.1e332ab-0ubuntu1

---------------
modemmanager (0.5+git.20111231t174444.1e332ab-0ubuntu1) precise; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * upstream snapshot 2011-12-31 17:44:44 (GMT)
    + 1e332abc957d7eea4521c95d1e28b097de5427e5

  [ Artem Popov ]
  * debian/patches/arduino-blacklist.patch: add Arduino devices to blacklist
    to prevent managing Arduino devices. (LP: #910736)
    - [0403:6001] FT232 USB-Serial (UART) IC.
    - [03eb:204b] Atmel Corp. LUFA USB to Serial Adapter Project.
    - Anything with the Arduino VID (2341).
 -- Artem Popov <email address hidden> Mon, 02 Jan 2012 13:32:18 +0700

Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Released
Mace (xmacex) wrote :

My Arduino LilyPad USB is not ignored.

ATTRS{idVendor}=="1b4f", ATTRS{idProduct}=="9208", ENV{ID_MM_DEVICE_IGNORE}="1"

Gaël Ecorchard (galou-breizh) wrote :

The Makey Makey (as far as I know, based on Leonardo) is also not blacklisted (on Fedora 18 as of 2013-10-24).

ATTRS{idVendor}=="1b4f", ATTRS{idProduct}=="2b74", ENV{ID_MM_DEVICE_IGNORE}="1"

An ignore should probably be added for Arduino.org devices too (there's two competing Arduino companies now, don't ask):

ATTRS{idVendor}=="2a03", ENV{ID_MM_DEVICE_IGNORE}="1"

And, while we are here, perhaps also ignore the Pinoccio Scout (arduino-like device):

ATTRS{idVendor}=="1d50", ATTRS{idProduct}=="6051", ENV{ID_MM_DEVICE_IGNORE}="1"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers