"Enable mobile broadband" option gets unchecked

Bug #874900 reported by Toni Lahnalampi on 2011-10-15
178
This bug affects 37 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Medium
Unassigned

Bug Description

I could not configure nw-manager to autoconnect with mobile broadband. I'm not sure if uncheking of "Enable mobile broadband" is the key issue here, but after cheking "Enable mobile broadband", mobile broadband starts connecting.

System information:
Ubuntu 11.10
network-manager (0.9.1.90-0ubuntu3) oneiric;
Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270 HSDPA/HSUPA Modem

Steps to reproduce:
1. Plug usb device
2. Click nv-manager icon, check "Enable mobile broadband"
3. Unplug and plug usb device

Result:
"Enable mobile broadband" option is unchecked.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Peter-Alexander (pp78) wrote :

Any known workaround?

Can you connect to the internet? Check this bug too.
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/868034

Peter-Alexander (pp78) wrote :

Same as OP but I want to mention that "Enable mobile broadband" is also disabled/unchecked by default after every system restart too. After cheking "Enable mobile broadband", mobile broadband starts connecting.

My system information:
Ubuntu 11.10 (same as above)
Option GT MAX GX301 (0af0:7011)

Peter-Alexander (pp78) wrote :

Yes, I can connect to the internet after I have checked "Enable mobile broadband". It also starts connecting itself after checking if the connection is configured to auto-connect.

Peter-Alexander (pp78) wrote :

I wanted a very quick solution. Thinking of finding a configuration file or something to edit I came across this command:

nmcli nm wwan on

This does the same as checking the "Enable mobile broadband" in nm-applet and doesn't solve the bug. But when run at system startup the mobile broadband connection will be established. If the device is removed and reinserted the "Enable mobile broadband" option is unchecked again. So this doesn't solve the bug but makes life a bit easier for me and maybe for some others until this is fixed so I thought I'll share it here.

Has anybody reported this to gnome's bugzilla?

Peter-Alexander (pp78) wrote :

Thought I have found a solution but I don't. But I tell you.

Goto "system settings" then "network" and under "mobile broadband" there is in the lower right corner an option "airplane mode". It was aktivated. I thought deactivating could solve the problem but it doesn't.

But what in the world should this function do? It's activated and I can connect - not automatically but...

Maybe someone can help?

Reassigning to modemmanager and setting priority to Medium, this appears to be relatively frequent/caught by many users.

Much of the issue comes from the fact that this particular device doesn't get powered on when connected; IIRC there has been some slight changes in powering methods for some devices, so maybe this got affected by these changes. It's just a side effect (fortunately) that "Enable broadband" happens to work to bring up the modem properly.

affects: network-manager (Ubuntu) → modemmanager (Ubuntu)
Changed in modemmanager (Ubuntu):
importance: Undecided → Medium
Peter-Alexander (pp78) wrote :

I have a Option GT MAX an the OP has a Huawei. So what particular device? Mobile broadband modems in general?

Mine worked in Ubuntu 9.04, 9.10 and 10.04 without that issue.

I have a Huawei E1550 and I have the same issue. The Mobile Broadband connection *never* automatically connects, though the button is checked. Sometimes - and that is far worse - I cannot even select my Mobile connection in the panel-dropdown list. That's presumably because the Mobile Broadband is disabled -- extremely annoying!! I have to play around with NetworkManager to get the Mobile Broadband back and I have not figured out yet what re-enables the Mobile Broadband.
Also, like many others I rely on Mobile Broadband and this is just not tolerable....

Everything worked fine in 11.04.

webdeveloper (gregorgr) wrote :

The same problem here with huawei modem!

rpr nospam (rpr-nospam) wrote :

Here is a workaround to auto start a mobile broadband connection after user login:

In the command line list the configured connections in your Network Manager:
$ nmcli con list
NAME UUID TYPE TIMESTAMP-REAL
Tele2 Default 1 93c93207-adce-40e4-beb5-d9f9c830d474 gsm Sat 25 Feb 2012 01:27:42 PM CET
Vipnet connection 1 054bdd1f-34e3-4db1-b18b-d38e885276c8 gsm never

The first item in a row is the connection name.
Now, create a command script that starts one of your connections after a delay of e.g. 10 seconds (maybe you'll need a longer delay if your broadband device needs more time to initialize):

#!/bin/sh
sleep 10
nmcli nm wwan on
nmcli con up id "Tele2 Default 1"

If the connection is used by multiple users on your Ubuntu, you can put the lines in a file accessible to all users, e.g.
 /usr/local/bin/start_my_connection
and set the file permissions as follows:

$ sudo chmod 775 /usr/local/bin/start_my_connection

Finally, configure starting the script after login: in Startup Applications Preferences add an item and enter the script path (/usr/local/bin/start_my_connection) as the program command.

brianM (brian-openitca) wrote :

Still not fixed in u12.04!

BuMS (by-myself-j) wrote :

I made a workaround based on rpr-nospam's(#12) post.

It's a bash script for detecting the modem and then connecting it.

#---------------------------------------
#!/bin/bash
wwanstatus=`nmcli nm wwan`
wwadevnstatus=`nmcli dev`

until [[ $wwadevnstatus == *ttyUSB2* ]]; do
 sleep 5
 wwadevnstatus=`nmcli dev`
done
sleep 5
until [[ $wwanstatus != *deaktiveret* ]]; do
 nmcli nm wwan on
 nmcli con up id "CBB Mobil Standard"
 sleep 2
 wwanstatus=`nmcli nm wwan`
done
#---------------------------------------

Note 1: "CBB Mobil Standard" is my connection's name.

Note 2: You can use the modem's device name as I did or just use "gsm".
Use "$ nmcli dev" to find out what the modem is called.
Then replace "ttyUSB2" with the correct name or just "gsm"

Note 3: Replace "deaktiveret" (Danish for disabled) with what your translation of "disabled".
Find it by entering: "$ nmcli nm wwan"

same issue here with 12.04 and ZTE MF180 3G modem. :(

@bums: i tried your script and it basically works, but i get some error messages after some time and the connection is lost:

** (process:3786): WARNING **: Could not initialize NMActiveConnection /org/freedesktop/NetworkManager/ActiveConnection/13: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

status of active connection:unknown
path of active connection: /org/freedesktop/NetworkManager/ActiveConnection/13

** (process:3786): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/13: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

** (process:3786): WARNING **: Could not initialize NMActiveConnection /org/freedesktop/NetworkManager/ActiveConnection/13: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

error: time limit of 90 seconds is over

seems like there is some sort oft report to NM missing...

Marius B. Kotsbak (mariusko) wrote :

Duplicate of bug #848164.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers