Ubuntu

HP hs2340 HSPA+ Mobile Broadband Modem does not work

Reported by Eero Aaltonen on 2011-09-01
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
modemmanager (Debian)
New
Unknown
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 10.04.3 LTS
Release: 10.04
network-manager:
  Installed: 0.8-0ubuntu3.2

I have installed Ubuntu 10.04.2 on HP Probook 6560b. The internal Mobile Broadband Modem is HP hs2340, which is correctly identified.

In neither the LTS release or the live CD of Oneiric Ocelot Alpha 3 release does Mobile Broadband work 'out of the box'

After fiddling around, I finally got the modem working. The missing bit was to do a hard shutdown from Windows, leaving the modem to an enabled state. After that, the connection worked instantly.

Some remarks:
=========
- network-manager should really provide more information to what it is doing. In all previous attempts, network-manager would be doing something for a while with no result or error message

- rfkill always listed the hp-wwan as 'not blocked'

This modem is special as it's Gobi-based and requires firmware to be installed. If NM tried to initialize the device before firmware has been loaded, this tends to break firmware loading until the system is restarted.

There's a fix in Oneiric now for this, so marking as Fix Released.

Changed in network-manager (Ubuntu):
status: New → Fix Released

dah, maybe I'm actually getting mixed up here by trying to go too fast.

Could you please report here with the USB ID for the device? You should be able to get this with the 'lsusb' command.

Thanks!

Changed in network-manager (Ubuntu):
status: Fix Released → Incomplete
affects: network-manager (Ubuntu) → modemmanager (Ubuntu)
Eero Aaltonen (ejn) wrote :

Here's the output (rather short)

~$ lsusb
Bus 002 Device 004: ID 1bcf:2805 Sunplus Innovation Technology Inc.
Bus 002 Device 002: ID 8087:0024
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 03f0:3a1d Hewlett-Packard
Bus 001 Device 003: ID 138a:003c DigitalPersona, Inc
Bus 001 Device 002: ID 8087:0024
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Eero Aaltonen (ejn) wrote :

Btw, in Windows the Mobile Broadband Modem is identified to be occupying the serial port COM5.

Ok so this appears to be the same thing as a bug in Debian; could you please try the steps outlined there and see if that works?

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=629950

Just omit the part about using a different kernel; adding the udev rule might be sufficient.

tags: added: lucid
Changed in modemmanager (Debian):
status: Unknown → New
Eero Aaltonen (ejn) wrote :

I added the udev rule, so the bottom of /lib/udev/rules.d/77-mm-ericsson-mbm.rules is now

# HP hs2340 HSPA+ MobileBroadband
# 03f0:3a1d Hewlett-Packard
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="3a1d", ENV{ID_MM_ERICSSON_MBM}="1"

LABEL="mm_mbm_end"

However, no success yet.
https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/792301 says module usb_ncm is needed. Where is it supposed to be?

It would be shipped with the kernel, however I don't think it's available in Lucid.

Eero Aaltonen (ejn) wrote :

Hmm. Should this be working in Oneiric live CD?

Eero Aaltonen (ejn) wrote :

I tried to test with the 2.6.38 kernel by upgrading with

sudo apt-get install linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty

unfortunately I get a garbled mess of colors instead of a login screen.

AFAIK you'll need at least 2.6.39, according to the debian bug linked.

It probably should work in Oneiric, provided you still add the udev rules. This will also probably mean a run of udevadm trigger / settle to make sure the rules are read.

Tiago Ramos (tiagolramos) wrote :

it doesn't work with version 11.04 with kernel 2.6.38 with altered udev.

Changed in modemmanager (Ubuntu):
status: Incomplete → Confirmed
Eero Aaltonen (ejn) wrote :

Using Ubuntu 12.04 now.

The missing functionality seems to be power management. I can use the modem just fine by doing the following:

- power it on in windows (HP connection manager)
- change preferences so that the modem is not powered down on exit.

Then I can do a normal reboot and the modem is powered on, everything else working fine.

Ringelkrat (ringelkrat) wrote :

I am using an ProBook 6460b with Ubuntu 11.04 and HP hs2340 HSPA+ Mobile Broadband Modem. I am also affected by this bug. The workarround described before [1] works for me as well.

[1] https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/838757/comments/12

DrKolossos (roth-simon) wrote :

Using Ubuntu 12.04 the modem was recognized here but no connection was possible. I had no windows installed for performing the workaround but here it helped simply to activate the modem via bios.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.