can't establish a mobile broadband connection using an n900 connected over USB

Bug #765516 reported by Philip Muškovac on 2011-04-19
120
This bug affects 23 people
Affects Status Importance Assigned to Milestone
ModemManager
New
Undecided
Unassigned
modemmanager (Debian)
Fix Released
Unknown
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

When I try to connect it seem like it can't open the modem:
Apr 19 07:35:46 localhost modem-manager[1119]: <info> (ttyACM0) opening serial port...
Apr 19 07:35:46 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
Apr 19 07:35:49 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) closing serial port...
Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) serial port closed

I can establish a connection with wvdial though so it does work.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: network-manager 0.8.4~git.20110319t175609.d14809b-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: eee
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Tue Apr 19 07:36:00 2011
Gconf:

InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
IpRoute:

Keyfiles: Error: [Errno 2] No such file or directory
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Philip Muškovac (yofel) wrote :
David Talmage (talmage-acm) wrote :

This has been broken since 10.10. It worked perfectly in 10.04. How can I help to fix it?

Could you share your wvdial configuration? That could help figuring out what's wrong with MM?

Changed in network-manager (Ubuntu):
status: New → Incomplete
affects: network-manager (Ubuntu) → modemmanager (Ubuntu)
Philip Muškovac (yofel) wrote :

Not much besides the defaults, here's the wvdial.conf:

[Dialer Defaults]
New PPPD = yes
Phone = *99#
Modem = /dev/ttyACM0
Username = simply
Password = 0000

I'll post a connection log tomorrow.

Philip Muškovac (yofel) wrote :

wvdial:
$ sudo wvdial
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> PPP negotiation detected.
--> Starting pppd at Wed May 18 07:55:05 2011
--> Pid of pppd: 20218
--> Using interface ppp0
--> pppd: �F[1d]
--> pppd: �F[1d]
--> pppd: �F[1d]
--> local IP address 10.45.39.123
--> pppd: �F[1d]
--> remote IP address 10.6.6.6
--> pppd: �F[1d]
--> primary DNS address 193.189.244.225
--> pppd: �F[1d]
--> secondary DNS address 193.189.244.206
--> pppd: �F[1d]

syslog shows:
May 18 07:55:05 yofel-1000H pppd[20218]: pppd 2.4.5 started by root, uid 0
May 18 07:55:05 yofel-1000H NetworkManager[687]: SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
May 18 07:55:05 yofel-1000H NetworkManager[687]: SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
May 18 07:55:05 yofel-1000H NetworkManager[687]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring...
May 18 07:55:05 yofel-1000H pppd[20218]: Using interface ppp0
May 18 07:55:05 yofel-1000H pppd[20218]: Connect: ppp0 <--> /dev/ttyACM0
May 18 07:55:05 yofel-1000H pppd[20218]: PAP authentication succeeded
May 18 07:55:07 yofel-1000H pppd[20218]: local IP address 10.45.39.123
May 18 07:55:07 yofel-1000H pppd[20218]: remote IP address 10.6.6.6
May 18 07:55:07 yofel-1000H pppd[20218]: primary DNS address 193.189.244.225
May 18 07:55:07 yofel-1000H pppd[20218]: secondary DNS address 193.189.244.206

Same;

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyACM0
ISDN = 0
Phone = *99#
Password = guest
Username = guest
~

Simon Vass
Managing Director
E-Tech Uganda Ltd

http://www.etech.ug
Tel: +256 (0) 312260620 or (0) 312260621
email: <email address hidden>
skype: e-techservicedesk

----- Original Message -----
From: "Mathieu Trudel-Lapierre" <email address hidden>
To: <email address hidden>
Sent: Tuesday, 17 May, 2011 9:43:03 PM
Subject: [Bug 765516] Re: can't establish a mobile broadband connection using an n900 connected over USB

Could you share your wvdial configuration? That could help figuring out
what's wrong with MM?

** Changed in: network-manager (Ubuntu)
       Status: New => Incomplete

** Package changed: network-manager (Ubuntu) => modemmanager (Ubuntu)

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (782609).
https://bugs.launchpad.net/bugs/765516

Title:
  can't establish a mobile broadband connection using an n900 connected
  over USB

Status in “modemmanager” package in Ubuntu:
  Incomplete

Bug description:
  Binary package hint: network-manager

  When I try to connect it seem like it can't open the modem:
  Apr 19 07:35:46 localhost modem-manager[1119]: <info> (ttyACM0) opening serial port...
  Apr 19 07:35:46 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) closing serial port...
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) serial port closed

  I can establish a connection with wvdial though so it does work.

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: network-manager 0.8.4~git.20110319t175609.d14809b-0ubuntu3
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic i686
  NonfreeKernelModules: eee
  Architecture: i386
  CRDA: Error: [Errno 2] No such file or directory
  Date: Tue Apr 19 07:36:00 2011
  Gconf:

  InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
  IpRoute:

  Keyfiles: Error: [Errno 2] No such file or directory
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   LANGUAGE=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/765516/+subscribe

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Marius Gedminas (mgedmin) wrote :

I can't figure out how to link this LP bug with the relevant upstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=583691

Quoting Dan Williams:

> Actually a modem-manager issue, N900 appears to require a bit more
> inter-character time on the serial port. Upstream MM fix is:
>
> 56665c19af431234ebe1b22cff9f0f9b9fb3d02f

which you can find at http://cgit.freedesktop.org/ModemManager/ModemManager/commit/?id=56665c19af431234ebe1b22cff9f0f9b9fb3d02f

A backport of that fix to Natty's ModemManager would be appreciated.

Changed in modemmanager (Ubuntu):
status: Incomplete → Confirmed
Marius Gedminas (mgedmin) wrote :

I was wrong: the natty version of modemmanager has that fix already applied, yet it still fails to talk to my N900.

Mikael Nordfeldth (mmn) wrote :

At the gentoo bug forums, this is discussed too: http://bugs.gentoo.org/show_bug.cgi?id=348849

I quote Alexander E. Patrakov 2011-02-17:
> This may be because Nokia N900 eats the first character of the commands if they
are issued immediately after opening /dev/ttyACM0. Here is how to demonstrate
the bug without modemmanager:
>
> chat -V "" +++AT OK </dev/ttyACM0 >/dev/ttyACM0
>
> Try this command several times. Many times you will have only two plusses out
of three echoed back.

Mikael Nordfeldth (mmn) wrote :

My experience with this bug is that if I enter the pin code myself, instead of having the N900 communicate with the SIM card, it works: http://ubuntuforums.org/showpost.php?p=10953857&postcount=14

This workaround is coherent with my above quote regarding waiting before communicating with /dev/ttyACM0 (because it takes at least a second or so to enter my PIN code).

Mikael Bergqvist (mikaelb) wrote :

Installing the maverick package for the modemmanager, as suggested in http://ubuntuforums.org/showthread.php?t=1771723 works for me.

Dan Williams (dcbw) wrote :

Original fix wasn't sufficient, this should do the trick for N900 USB:

commit 46d757faa768db7d7bb23d51cc2af3196f7a7e30
Date: Wed Jul 6 13:13:41 2011 -0500

    gsm: send init command twice to make the N900 happy (rh #583691) (lp:765516)

montun (montun) wrote :

Installing the #12 solution on Natyy (11.04). Overwrite /usr/lib/ModemManager/libmm-plugin-nokia.so with the attached libmm-plugin-nokia.so (for x86_64 Natty) . Or build yourself

# Get source
git clone git://anongit.freedesktop.org/ModemManager/ModemManager

(# Optional:) git checkout -b nokia_fix 0f6d1b2b42afe48583c9c3e7c159be4353462d86

# Install build depnedecies and build
sudo apt-get build-dep modemmanager
cd ModemManager
make

# Overwrite the current nokia modemmanager plugin with the good one
sudo cp --backup=numbered ./plugins/.libs/libmm-plugin-nokia.so /usr/lib/ModemManager/libmm-plugin-nokia.so

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.5-0ubuntu1

---------------
modemmanager (0.5-0ubuntu1) oneiric; urgency=low

  * New upstream release 0.5.
    - gsm: send init command twice to make the N900 happy (LP: #765516)
    - fix sierra modems' sleep mode command (LP: #459052, #738005)
  * debian/patches/lp700316_usb_blacklist.patch: add extra devices to blacklist
    of USB devices known to usually be serial dongles or other things MM should
    not touch. (LP: #700316)
  * debian/control, debian/rules: add a -dbg package for modemmanager, and
    override dh_strip accordingly. (LP: #415394)
  * debian/rules: fix .la/.a file removal to not fail if there is nothing to
    remove.
  * debian/modemmanager.install: install files to the modemmanager package
    explicitly now that it's not the only binary package.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 05 Aug 2011 12:46:32 -0400

Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Released
tempura (tempura) wrote :

Here is a cumulative patch for the current 11.04 package which contains both modifications for the N900:

commit 0f6d1b2b42afe48583c9c3e7c159be4353462d86 - nokia: N900 doesn't really need additional inter-character time
commit 46d757faa768db7d7bb23d51cc2af3196f7a7e30 - gsm: send init command twice to make the N900 happy

Tested and verified on Ubuntu 11.04 and N900 PR1.3 CSSU.

Olivier Berger (olivierberger) wrote :

Is this bug still considered open by upstream, as the discrepency between fix released for Ubuntu and New for upstream is a bit confusing.

Anyway, I seem to still be suffering the bug on Debian, which runs 0.5.

I noticed some additional commits on upstream 0.5 branch that seem to suggest there may be additional fixes pending for Nokia...

Thanks in advance.

Olivier Berger (olivierberger) wrote :

After some debugging, it appears I was using an incorrect APN. So the bug is no more on my Debian system. sorry about the bothering.

The rest of the comments stand, maybe.

Changed in modemmanager (Debian):
status: Unknown → Fix Released
Stéphane Caron (tastalian) wrote :

What does this "Fix Released" status mean? I'm running 11.04 with the latest official version of packages and it's still around (I have to do re-modprobe the cdc_acm module everytime I want to tether my N900)...

mrl586 (mrl586) wrote :

It is fixed in oneiric.

Simon Vass (svass) wrote :

Which build? Beta 1 appeared to have the same problem.

Simon Vass
Managing Director
E-Tech Uganda Ltd

http://www.etech.ug
Tel: +256 (0) 312260620 or (0) 312260621
email: <email address hidden>
skype: e-techservicedesk

----- Original Message -----
From: "mrl586" <email address hidden>
To: <email address hidden>
Sent: Saturday, 24 September, 2011 10:17:12 PM
Subject: [Bug 765516] Re: can't establish a mobile broadband connection using an n900 connected over USB

It is fixed in oneiric.

--
You received this bug notification because you are subscribed to a
duplicate bug report (782609).
https://bugs.launchpad.net/bugs/765516

Title:
  can't establish a mobile broadband connection using an n900 connected
  over USB

Status in ModemManager (with NetworkManager support):
  New
Status in “modemmanager” package in Ubuntu:
  Fix Released
Status in “modemmanager” package in Debian:
  Fix Released

Bug description:
  Binary package hint: network-manager

  When I try to connect it seem like it can't open the modem:
  Apr 19 07:35:46 localhost modem-manager[1119]: <info> (ttyACM0) opening serial port...
  Apr 19 07:35:46 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) closing serial port...
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) serial port closed

  I can establish a connection with wvdial though so it does work.

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: network-manager 0.8.4~git.20110319t175609.d14809b-0ubuntu3
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic i686
  NonfreeKernelModules: eee
  Architecture: i386
  CRDA: Error: [Errno 2] No such file or directory
  Date: Tue Apr 19 07:36:00 2011
  Gconf:

  InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
  IpRoute:

  Keyfiles: Error: [Errno 2] No such file or directory
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   LANGUAGE=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/modemmanager/+bug/765516/+subscriptions

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Download full text (5.2 KiB)

Ok scrub that must have been an anomaly. Working in Beta 1 of 11.10.

Simon Vass
Managing Director
E-Tech Uganda Ltd

http://www.etech.ug
Tel: +256 (0) 312260620 or (0) 312260621
email: <email address hidden>
skype: e-techservicedesk

----- Original Message -----
From: "Simon Vass" <email address hidden>
To: <email address hidden>
Sent: Sunday, 25 September, 2011 10:57:41 AM
Subject: Re: [Bug 765516] Re: can't establish a mobile broadband connection using an n900 connected over USB

Which build? Beta 1 appeared to have the same problem.

Simon Vass
Managing Director
E-Tech Uganda Ltd

http://www.etech.ug
Tel: +256 (0) 312260620 or (0) 312260621
email: <email address hidden>
skype: e-techservicedesk

----- Original Message -----
From: "mrl586" <email address hidden>
To: <email address hidden>
Sent: Saturday, 24 September, 2011 10:17:12 PM
Subject: [Bug 765516] Re: can't establish a mobile broadband connection using an n900 connected over USB

It is fixed in oneiric.

--
You received this bug notification because you are subscribed to a
duplicate bug report (782609).
https://bugs.launchpad.net/bugs/765516

Title:
  can't establish a mobile broadband connection using an n900 connected
  over USB

Status in ModemManager (with NetworkManager support):
  New
Status in “modemmanager” package in Ubuntu:
  Fix Released
Status in “modemmanager” package in Debian:
  Fix Released

Bug description:
  Binary package hint: network-manager

  When I try to connect it seem like it can't open the modem:
  Apr 19 07:35:46 localhost modem-manager[1119]: <info> (ttyACM0) opening serial port...
  Apr 19 07:35:46 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) closing serial port...
  Apr 19 07:35:49 localhost modem-manager[1119]: <info> (ttyACM0) serial port closed

  I can establish a connection with wvdial though so it does work.

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: network-manager 0.8.4~git.20110319t175609.d14809b-0ubuntu3
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic i686
  NonfreeKernelModules: eee
  Architecture: i386
  CRDA: Error: [Errno 2] No such file or directory
  Date: Tue Apr 19 07:36:00 2011
  Gconf:

  InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
  IpRoute:

  Keyfiles: Error: [Errno 2] No such file or directory
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   LANGUAGE=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/modemmanager/+bug/765516/+subscriptions

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

--
You received this bug notification because yo...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.