Sierra 308 Mobile Broadband cannot connect

Bug #738005 reported by John Smith on 2011-03-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

My Sierra 308 Mobile broadband used to connect to Ubuntu 10.10 without any problems, then one day it suddenly stopped working. The device connects fine in Windows so it is not a hardware problem. I have tried reinstalling Ubuntu, and both downgraded and upgrading the packages but nothing seems to work. It seems to be connecting fine then for some reason it suddenly stops. Below is the output from modem-manager and Network Manager in debug modes.

Network Manager

rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
**
Message: nm-ppp-plugin: (nm_phasechange): status 8 / phase 'network'
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP ProtRej id=0x5 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
Modem hangup
**
Message: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
**
Message: nm-ppp-plugin: (nm_phasechange): status 11 / phase 'disconnect'
Connection terminated.
NetworkManager[2298]:
<info> (ttyUSB2): device state change: 7 -> 9 (reason 5)
NetworkManager[2298]:
<info> Marking connection 'Telstra Default 1' invalid.
NetworkManager[2298]:
<warn> Activation (ttyUSB2) failed.
NetworkManager[2298]:
<info> (ttyUSB2): device state change: 9 -> 3 (reason 0)
NetworkManager[2298]:
<info> (ttyUSB2): deactivating device (reason: 0).
NetworkManager[2298]: SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
NetworkManager[2298]: <info> disconnect failed: (32) The serial port is not open.
**
Message: nm-ppp-plugin: (nm_phasechange): status 1 / phase 'dead'
**
Message: nm-ppp-plugin: (nm_exit_notify): cleaning up

Modem-manager
** (modem-manager:2271):

DEBUG: <1300340821.661259> (ttyUSB2): simple connect state 5
** (modem-manager:2271):
DEBUG: <1300340821.661373> Modem /org/freedesktop/ModemManager/Modems/0: state changed (registered -> connecting)
** (modem-manager:2271):
DEBUG: <1300340821.661475> (ttyUSB2): --> 'ATD*99***1#<CR>'
** (modem-manager:2271):
DEBUG: <1300340821.680819> (ttyUSB2): <-- '<CR><LF>CONNECT 7200000<CR><LF>'
** (modem-manager:2271):
DEBUG: <1300340821.680917> (ttyUSB2): port now connected
** (modem-manager:2271):
DEBUG: <1300340821.680956> Modem /org/freedesktop/ModemManager/Modems/0: state changed (connecting -> connected)
** (modem-manager:2271):
DEBUG: <1300340821.680995> (ttyUSB2): simple connect state 6
** (modem-manager:2271):
DEBUG: (net/ppp0): could not get port's parent device
** (modem-manager:2271):
DEBUG: <1300340823.98155> (ttyUSB2) device open count is 0 (close)
**
Message: (ttyUSB2) closing serial device...
** (modem-manager:2271):
DEBUG: <1300340823.98275> (ttyUSB2): port now disconnected
** (modem-manager:2271):
DEBUG: <1300340823.98500> Modem /org/freedesktop/ModemManager/Modems/0: state changed (connected -> disconnecting)
** (modem-manager:2271):
DEBUG: <1300340823.98631> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disconnecting -> connected)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cal 1397 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8400000 irq 48'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,1179ff57,00100000'
   Controls : 12
   Simple ctrls : 6
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xcfeec000 irq 49'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 10.10
HibernationDevice: RESUME=UUID=b7761952-3a19-40b7-9416-364cb9c0cbfa
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: TOSHIBA Satellite P300
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-25-generic root=UUID=7e253503-8a0d-4bca-9dcf-33512dc40c8c ro quiet splash
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Regression: No
RelatedPackageVersions: linux-firmware 1.38.3
Reproducible: Yes
Tags: maverick kernel-net needs-upstream-testing
Uname: Linux 2.6.35-25-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/28/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V2.50
dmi.board.name: Satellite P300
dmi.board.vendor: TOSHIBA
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV2.50:bd11/28/2008:svnTOSHIBA:pnSatelliteP300:pvrPSPCCA-05Y01Y:rvnTOSHIBA:rnSatelliteP300:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite P300
dmi.product.version: PSPCCA-05Y01Y
dmi.sys.vendor: TOSHIBA

Fabio Marconi (fabiomarconi) wrote :

assigned to linux to collect data

affects: ubuntu → linux (Ubuntu)
Fabio Marconi (fabiomarconi) wrote :

Hello
Can you please attach the device, reproduce the bug then run in a terminal
apport-collect -p linux 738005
Thanks
Fabio

Changed in linux (Ubuntu):
status: New → Incomplete
John Smith (john-smith) wrote :

This is the output from apport-collect -p linux 738005:

Error connecting to Launchpad: Unable to find the server at edge.launchpad.net
You can reset the credentials by removing the file "/home/cal/.cache/apport/launchpad.credentials"

I believe because I do not have an active internet connection, I tried removing the launchpad.credentials file but it does not exist. I also tried getting the output from apport-cli and saving it to a file, but it said that there were no active crash reports. Any explanation on how to get the info from a computer without an internet connection would be much appreciated.

John Smith (john-smith) wrote :

Any different way to get this output?

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Fabio Marconi (fabiomarconi) wrote :

From CurrentDmesg:

[ 293.100617] usb 1-4: USB disconnect, address 3
[ 293.100917] sierra ttyUSB0: Sierra USB modem converter now disconnected from ttyUSB0
[ 293.100950] sierra 1-4:1.0: device disconnected
[ 293.101175] sierra ttyUSB1: Sierra USB modem converter now disconnected from ttyUSB1
[ 293.101203] sierra 1-4:1.1: device disconnected
[ 293.101426] sierra ttyUSB2: Sierra USB modem converter now disconnected from ttyUSB2
[ 293.101454] sierra 1-4:1.3: device disconnected
[ 293.106416] sierra ttyUSB3: Sierra USB modem converter now disconnected from ttyUSB3
[ 293.106440] sierra 1-4:1.4: device disconnected
[ 293.133861] sierra_net 1-4:1.7: wwan0: unregister 'sierra_net' usb-0000:00:1a.7-4, Sierra Wireless USB-to-WWAN Modem
[ 293.182567] sierra_net 1-4:1.7: (unregistered net_device): usb_control_msg failed, status -19
[ 306.842696] usb 1-4: new high speed USB device using ehci_hcd and address 4
[ 306.991723] usb 1-4: config 1 has an invalid interface number: 9 but max is 5
[ 306.991728] usb 1-4: config 1 has an invalid interface number: 7 but max is 5
[ 306.991732] usb 1-4: config 1 has no interface number 2
[ 306.991735] usb 1-4: config 1 has no interface number 5
[ 306.996921] sierra 1-4:1.0: Sierra USB modem converter detected

From WiFi.log:

Apr 14 18:21:56 cal modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1a.7/usb1/1-4
[ 306.998834] usb 1-4: Sierra USB modem converter now attached to ttyUSB0
[ 306.998913] sierra 1-4:1.1: Sierra USB modem converter detected
[ 306.999887] usb 1-4: Sierra USB modem converter now attached to ttyUSB1
[ 306.999963] sierra 1-4:1.3: Sierra USB modem converter detected
[ 307.001183] usb 1-4: Sierra USB modem converter now attached to ttyUSB2
[ 307.001269] sierra 1-4:1.4: Sierra USB modem converter detected
[ 307.002028] usb 1-4: Sierra USB modem converter now attached to ttyUSB3
[ 307.011046] scsi8 : usb-storage 1-4:1.9
[ 307.026734] sierra_net 1-4:1.7: wwan0: register 'sierra_net' at usb-0000:00:1a.7-4, Sierra Wireless USB-to-WWAN Modem, 2e:39:ff:56:02:07

Fabio Marconi (fabiomarconi) wrote :

As Linux detect the device and it establish connection, I assign to modemmanager

affects: linux (Ubuntu) → modemmanager (Ubuntu)
Changed in modemmanager (Ubuntu):
status: Incomplete → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Hello John
It would be great if you can test a live session of the newest Natty downloading from
http://cdimage.ubuntu.com/daily-live/current/
writing the downloaded image on a usb key created with startup disk creator.
just to see if this issue is already fixed in th latest package.
Thanks
Fabio

tags: added: maverick
John Smith (john-smith) wrote :

I have tested this and the problem still exists in the latest Natty.

Fabio Marconi (fabiomarconi) wrote :

Hello John
Thanks for the support.
Fabio

tags: added: natty

This is extremely likely to be another case of the Sierra modems not liking the AT+CFUN commands, currently working on this...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.5-0ubuntu1

---------------
modemmanager (0.5-0ubuntu1) oneiric; urgency=low

  * New upstream release 0.5.
    - gsm: send init command twice to make the N900 happy (LP: #765516)
    - fix sierra modems' sleep mode command (LP: #459052, #738005)
  * debian/patches/lp700316_usb_blacklist.patch: add extra devices to blacklist
    of USB devices known to usually be serial dongles or other things MM should
    not touch. (LP: #700316)
  * debian/control, debian/rules: add a -dbg package for modemmanager, and
    override dh_strip accordingly. (LP: #415394)
  * debian/rules: fix .la/.a file removal to not fail if there is nothing to
    remove.
  * debian/modemmanager.install: install files to the modemmanager package
    explicitly now that it's not the only binary package.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 05 Aug 2011 12:46:32 -0400

Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers