Ubuntu

NO CARRIER error vodafone K3571-Z ZTE 3g modem

Reported by Robert Collins on 2010-12-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Ayan George
Nominated for Maverick by Ayan George

Bug Description

Binary package hint: modemmanager

Attempting to connect via USB1 gets NO CARRIER, attempting to connect via USB3 gets a connection trivially:

at
OK
atd*99***2#
CONNECT 3600000

(Thanks cyphermox for the hand holding and discussion).

I'm not sure how to tell modemmanager this (yet).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: modemmanager 0.4+git.20100809t153145.be28089-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
Architecture: amd64
Date: Thu Dec 2 18:11:26 2010
ProcEnviron:
 LANGUAGE=la_AU:tlh_GB:tlh:en
 PATH=(custom, user)
 LANG=la_AU.utf8
 SHELL=/bin/bash
SourcePackage: modemmanager

Bus 002 Device 009: ID 19d2:1010 ONDA Communication S.p.A.

https://forge.betavine.net/plugins/scmsvn/viewcvs.php/trunk/src/core/resources/udev/77-vmc-zte.rules?root=bcm&rev=608&r1=584&r2=608 has a (more crudely done that perhaps we'd land) fix.

/lib/udev/rules.d/77-mm-zte-port-types.rules

+# K3570-Z
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1008", ENV{.MM_USBIFNUM}=="03", ENV{ID_MM_PORT_TYPE_MODEM}="1"
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1008", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_PORT_TYPE_AUX}="1"
+# K3571-Z
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1010", ENV{.MM_USBIFNUM}=="03", ENV{ID_MM_PORT_TYPE_MODEM}="1" +ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1010", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_PORT_TYPE_AUX}="1"

cyphermox pointed out that we use a different variable with ZTE in it, so these lines didn't actually help, we need

+# K3570-Z
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1008", ENV{.MM_USBIFNUM}=="03", ENV{ID_MM_ZTE_PORT_TYPE_MODEM}="1"
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1008", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_ZTE_PORT_TYPE_AUX}="1"
+# K3571-Z
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1010", ENV{.MM_USBIFNUM}=="03", ENV{ID_MM_ZTE_PORT_TYPE_MODEM}="1"
+ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1010", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_ZTE_PORT_TYPE_AUX}="1"

Robert Collins (lifeless) wrote :
Robert Collins (lifeless) wrote :

Note that many folk on forums in .au / .nz have been asking about this without (apparent) success.

description: updated
description: updated
Robert Collins (lifeless) wrote :
Download full text (7.1 KiB)

Ok, so this isn't sufficient - its probably necessary, but there seems to be a race or other bug making probing still happen - and when it probes its a 50/50 chance whether USB1 or USB3 is detected and wins.

A bad insertion looks like this:
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB0) opening serial device...
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB0): probe requested by plugin 'ZTE'
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB1) opening serial device...
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB1): probe requested by plugin 'ZTE'
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB2) opening serial device...
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB2): probe requested by plugin 'ZTE'
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB3) opening serial device...
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB3): probe requested by plugin 'ZTE'
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB4) opening serial device...
Dec 2 20:26:32 lifeless-64 modem-manager: (ttyUSB4): probe requested by plugin 'ZTE'
Dec 2 20:26:38 lifeless-64 modem-manager: Got failure code 100: Unknown error
Dec 2 20:26:38 lifeless-64 modem-manager: Got failure code 100: Unknown error
Dec 2 20:26:38 lifeless-64 modem-manager: Got failure code 14: SIM busy
Dec 2 20:26:47 lifeless-64 modem-manager: (ttyUSB1) closing serial device...
Dec 2 20:26:47 lifeless-64 modem-manager: (ttyUSB2) closing serial device...
Dec 2 20:26:47 lifeless-64 modem-manager: (ttyUSB3) closing serial device...
Dec 2 20:26:47 lifeless-64 modem-manager: (ttyUSB1) opening serial device...
Dec 2 20:26:47 lifeless-64 modem-manager: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB1
Dec 2 20:26:47 lifeless-64 modem-manager: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:26:47 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:26:47 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:26:47 lifeless-64 modem-manager: mm_modem_base_add_port: assertion `port == NULL' failed
Dec 2 20:26:47 lifeless-64 modem-manager: (mm-generic-gsm.c:530):mm_generic_gsm_grab_port: runtime check failed: (port != NULL)
Dec 2 20:26:47 lifeless-64 modem-manager: do_grab_port: plugin 'ZTE' claimed to support tty/ttyUSB2 but couldn't: (-1) (unknown)
Dec 2 20:26:47 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:26:47 lifeless-64 modem-manager: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB3
Dec 2 20:26:47 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:26:47 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:26:47 lifeless-64 modem-manager: (ttyUSB1) closing serial device...
Dec 2 20:27:07 ...

Read more...

Robert Collins (lifeless) wrote :
Download full text (10.6 KiB)

And this is a good one:
robertc@lifeless-64:~$ Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB3) opening serial device...
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB3): probe requested by plugin 'ZTE'
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB0) opening serial device...
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB0): probe requested by plugin 'ZTE'
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB2) opening serial device...
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB2): probe requested by plugin 'ZTE'
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB1) opening serial device...
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB1): probe requested by plugin 'ZTE'
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB4) opening serial device...
Dec 2 20:30:48 lifeless-64 modem-manager: (ttyUSB4): probe requested by plugin 'ZTE'
robertc@lifeless-64:~$ Dec 2 20:30:49 lifeless-64 modem-manager: Got failure code 100: Unknown error
Dec 2 20:30:55 lifeless-64 modem-manager: Got failure code 100: Unknown error
Dec 2 20:30:55 lifeless-64 modem-manager: Got failure code 14: SIM busy
robertc@lifeless-64:~$ Dec 2 20:30:55 lifeless-64 modem-manager: Got failure code 14: SIM busy
Dec 2 20:31:04 lifeless-64 modem-manager: (ttyUSB3) closing serial device...
Dec 2 20:31:04 lifeless-64 modem-manager: (ttyUSB2) closing serial device...
Dec 2 20:31:04 lifeless-64 modem-manager: (ttyUSB1) closing serial device...
Dec 2 20:31:04 lifeless-64 modem-manager: (ttyUSB3) opening serial device...
Dec 2 20:31:04 lifeless-64 modem-manager: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB3
Dec 2 20:31:04 lifeless-64 modem-manager: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:31:04 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:31:04 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:31:04 lifeless-64 modem-manager: mm_modem_base_add_port: assertion `port == NULL' failed
Dec 2 20:31:04 lifeless-64 modem-manager: (mm-generic-gsm.c:530):mm_generic_gsm_grab_port: runtime check failed: (port != NULL)
Dec 2 20:31:04 lifeless-64 modem-manager: do_grab_port: plugin 'ZTE' claimed to support tty/ttyUSB2 but couldn't: (-1) (unknown)
Dec 2 20:31:04 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:31:04 lifeless-64 modem-manager: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB1
Dec 2 20:31:04 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:31:04 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 2 20:31:04 lifeless-64 modem-manager: (ttyUSB3) closing serial device...
robertc@lifeless-64:~$ Dec 2 20:31:24 lifeless-64 modem-manager: (ttyUSB0) closing serial d...

Changed in modemmanager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Robert Collins (lifeless) wrote :
Download full text (10.2 KiB)

Log with the _ZTE in the rules - connected first time:
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB1) opening serial device...
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB1): probe requested by plugin 'ZTE'
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB4) opening serial device...
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB4): probe requested by plugin 'ZTE'
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB0) opening serial device...
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB0): probe requested by plugin 'ZTE'
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB3) opening serial device...
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB3): probe requested by plugin 'ZTE'
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB2) opening serial device...
Dec 3 07:55:20 lifeless-64 modem-manager: (ttyUSB2): probe requested by plugin 'ZTE'
Dec 3 07:55:21 lifeless-64 modem-manager: Got failure code 100: Unknown error
Dec 3 07:55:24 lifeless-64 dnsmasq[1541]: no servers found in /etc/resolv.conf, will retry
Dec 3 07:55:27 lifeless-64 modem-manager: Got failure code 100: Unknown error
Dec 3 07:55:27 lifeless-64 modem-manager: Got failure code 14: SIM busy
Dec 3 07:55:27 lifeless-64 modem-manager: Got failure code 14: SIM busy
Dec 3 07:55:36 lifeless-64 modem-manager: (ttyUSB1) closing serial device...
Dec 3 07:55:36 lifeless-64 modem-manager: (ttyUSB3) closing serial device...
Dec 3 07:55:36 lifeless-64 modem-manager: (ttyUSB2) closing serial device...
Dec 3 07:55:36 lifeless-64 modem-manager: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB1
Dec 3 07:55:36 lifeless-64 modem-manager: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 3 07:55:36 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 3 07:55:36 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 3 07:55:36 lifeless-64 modem-manager: (ttyUSB3) opening serial device...
Dec 3 07:55:36 lifeless-64 modem-manager: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB3
Dec 3 07:55:36 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 3 07:55:36 lifeless-64 modem-manager: mm_modem_base_add_port: assertion `port == NULL' failed
Dec 3 07:55:36 lifeless-64 modem-manager: (mm-generic-gsm.c:530):mm_generic_gsm_grab_port: runtime check failed: (port != NULL)
Dec 3 07:55:36 lifeless-64 modem-manager: do_grab_port: plugin 'ZTE' claimed to support tty/ttyUSB2 but couldn't: (-1) (unknown)
Dec 3 07:55:36 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 3 07:55:36 lifeless-64 modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
Dec 3 07:55:36 lifeless-64 modem-manager: (ttyUSB3) closing serial device...
Dec 3 07:55:56 lifeless-64 modem-mana...

description: updated

Seems like these changes have already been added upstream, in commit acc4541ab31196fa2b6bbc60997c6b0d7e93392e.

Robert Collins (lifeless) wrote :

Sigh... well at least we know the fix was right.

Chris Van Hoof (vanhoof) on 2011-04-06
tags: added: hwe-blocker

This is in both Natty and Oneiric. Marking as Fix Released.

Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Released

Chris, I subscribed you because you marked this bug as hwe-blocker. Should we then consider this for SRU to Maverick?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers