Ubuntu

Disable mobile broadband has no effect on most modems

Reported by Daniel Oertwig on 2010-04-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
New
Medium
modemmanager (Ubuntu)
Wishlist
Unassigned

Bug Description

Hello to all of you.

I am using a complete up to date Lucid on my Thinkpad T500 with integrated mobile broadband modem. The modem itself can be used without any problems.
The only thing is, that the "Disable mobile broadband" switch in the right click menu of network-manager-applet (on gnome) takes absolutely no effect.
I can connect with the modem when mobile broadband should be disabled, and furthermore, when i disable via the switch, the device is not powered down.
This is not very nice on a laptop where energy is a rare resource.

I attached the corresponding lsusb -vvv part

This is what syslog shows when first clicking on enable mobile broadband:

Apr 6 11:17:15 localhost modem-manager: (ttyACM0) opening serial device...
Apr 6 11:17:15 localhost modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
Apr 6 11:17:15 localhost modem-manager: Got failure code 100: Unknown error
Apr 6 11:17:15 localhost modem-manager: Invalid error code
Apr 6 11:17:15 localhost modem-manager: Got failure code 100: Unknown error
Apr 6 11:17:15 localhost modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> enabled)

This powers up the device.
And then when clicking on disable, the following occurs:

Apr 6 11:17:26 localhost modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabled -> disabling)
Apr 6 11:17:26 localhost modem-manager: (ttyACM0) closing serial device...
Apr 6 11:17:26 localhost modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabling -> disabled)

But the device isn't powered down.
I can choose to connect both when the device is up and when the device isn't running yet (choosing then activates the device)

Daniel Oertwig (danieloertwig) wrote :
Nicolò Chieffo (yelo3) wrote :

The same happens to be, with a different modem, so I think this is not related on how network-manager handles the devices.

Nicolò Chieffo (yelo3) wrote :

"The same happens to ME", sorry for the spelling error

Changed in network-manager-applet:
status: Unknown → New
Changed in network-manager-applet:
status: New → Fix Released
Changed in network-manager-applet:
importance: Unknown → Medium

I can't reproduce this on maverick with a ZTE MF636 modem. Can you please test with the current development release (Maverick Meerkat) and see if you can reproduce the same behavior?

Changed in network-manager-applet (Ubuntu):
status: New → Incomplete

I don't know what I was doing before but I actually *can* reproduce the "issue". The problem is, modems can still be enabled by clicking on a connection, but while mobile broadband is disabled they would be in low-power state and signal strength, registration, etc, would be unavailable; which agrees with what I can see on my system...

My modem won't get powered off, but that's because it's on the USB bus and has no killswitch anyway.

However, as mentioned in the upstream bug, this is "intended" behaviour, by being the lesser evil: there is still no better way to deal with all the different types of devices out there.

Marking Triaged, in case someone would come up with a decent way of dealing with this, but without killswitches for most modems (e.g. USB) the chances are pretty slim (sorry!).

FWIW, I tried to deal with this by asking NM whether the device was enabled or not, but a MB device is enabled when connected and disabled when not (it goes to low power state), and there is no way to HW-disable the devices I had (though internal modems may have killswitches -- see 'rfkill list').

Changed in network-manager-applet (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Wishlist
summary: - Disable mobile broadband takes no effect
+ Disable mobile broadband has no effect on most modems
Daniel Oertwig (danieloertwig) wrote :

Bug is still unresolved with networkmanager 0.9.4.0-6.
The link to the report on gnome bugs is rather useless, as it does NOT fix the issue.

The main problem is not the "wrong" behaviour of the GUI, instead the still active device causes troubles (power consumption)

Marius B. Kotsbak (mariusko) wrote :

How do you propose to solve this? Turning the modem off probably requires a reboot of the computer to enable it again.

Don't you have a physical button on the keyboard to disable it completely?

Daniel Oertwig (danieloertwig) wrote :

No, turning it off using the /sys/devices/... switch works fine for me. The LED goes off, signalling that the modem is not powered.
It can be powered on again using the switch and can then be used to connect.

Yes, there is a physical button to completely disable it.
But:

This button disables ALL wireless communications: WLAN, bluetooth, WWAN.

Switching the physical button again, turns ON WLAN and bluetooth again, and is therefore useful to "switch the modem off" to save power. But unfortunately, networkmanager seems to have problems (sometimes) using the interface THEN again.
I only noticed this because I tried today, this used to work some time ago o.O

See here:
http://www.thinkwiki.org/wiki/Ericsson_F3507g_Mobile_Broadband_Module#Turning_the_card_off

Daniel Oertwig (danieloertwig) wrote :

.. only noticed, that it is rfkill1 on my machine.
There is also /sys/devices/platform/thinkpad_acpi/wwan_enable ...

Marius B. Kotsbak (mariusko) wrote :

Could you please add a new upstream bug report describing this. I see plugins for other modem types uses AT+CFUN=4 to power it down, but it is probably not safe to do for all modems. We should be able to easily add this to the Ericsson MBM plugin too.

Marius B. Kotsbak (mariusko) wrote :

Forget it, there is one already, I think.

Changed in network-manager-applet:
importance: Medium → Unknown
status: Fix Released → Unknown
affects: network-manager-applet (Ubuntu) → modemmanager (Ubuntu)
Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → New
Marius B. Kotsbak (mariusko) wrote :

This is a duplicate of bug #816400.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.