UMTS connection needs rebooting to work

Bug #506620 reported by mpolito1969 on 2010-01-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Here is a description:

http://ubuntuforums.org/showthread.php?t=1369235

I wrote to the NetworkManager community and I was told there is already a fix:

http://cgit.freedesktop.org/ModemManager/ModemManager/commit/?id=2fc0c039e65173123a39a0fb6c8f44804cbd773a

Would it be possibile to insert it in a next release of Ubuntu or, better, to have it through the "update manager"?

Ciao,
Max

affects: ubuntu → network-manager-applet (Ubuntu)
David Tombs (dgtombs) wrote :

Hi Max, thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, the commit you referenced was made a while ago and should already be in Ubuntu 9.10. So, if you're still experiencing the issue that commit did not fix it.

So, please update the description of this report with the relevant information from that forum thread. Please add reproduction steps and, if possible, run apport-collect 506620 to automatically attach helpful debugging information to the report. (You'll have to give it access to change non-private data.)

affects: network-manager-applet (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: New → Incomplete

> Hi Max, thank you for taking the time to report this bug and helping to
> make Ubuntu better. Unfortunately, the commit you referenced was made a
> while ago and should already be in Ubuntu 9.10. So, if you're still
> experiencing the issue that commit did not fix it.

Are you sure? The commit's date is 2009-12-12, while Ubuntu 9.10 was
released in october 2009, a couple of months before.

Ciao,
Max

Pietro Battiston (toobaz) wrote :

Hello Max,

maybe you already saw it, but the description of the commit you refer to reports "This is the MM equivalent of NM commit 9d7f5b3d084eee2ccfff721c4beca3e3f34bdc50", and NM commit http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=9d7f5b3d084eee2ccfff721c4beca3e3f34bdc50 is indeed older (March 09).

So I see three possibilities:
1) in Karmic, the fix to NM is used
2) in Karmic, the fix to NM is unused (or insufficient) but the fix to MM was added as patch at the packaging level, taking inspiration from the fix to NM
3) you're right...

David Tombs (dgtombs) wrote :

Hi Max, sorry about dropping this bug. You're right, the fix was removed from network-manager when Ubuntu transitioned to modemmanager. So, I'm reassigning this to modemmanager.

In fact, the latest release of mm was just uploaded to Lucid, so it looks like this will be fixed. Please check it out when the next Lucid cdimage comes out.

affects: network-manager (Ubuntu) → modemmanager (Ubuntu)

Architecture: i386
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: modemmanager 0.2.git.20091014t233208.16f3e00-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
Uname: Linux 2.6.31-17-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev uucp video

Changed in modemmanager (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

I ran apport-collect 506620 when the problem appeared, some hours ago, but as a consequence of that problem there is no internet connection, so the tool couldn't connect to Launchpad.

I've just ran it again, in the hope it could give you some useful information.

David Tombs (dgtombs) wrote :

Hi Max,

Yes, the bug isn't fixed in Karmic yet, but it's fixed in the development release (Lucid). The next Lucid pre-release should come out this month (?) so you can confirm that it's fixed then.

Thanks!

Changed in modemmanager (Ubuntu):
status: New → Confirmed

I've donwloaded lucid-netbook-i386.iso (the netbook version, the desktop was too big for my internet connection) and what I saw was not good at all.

nm-tool only shows eth0 and wlan0, there isn't any section "Device: ttyUSB0", my modem is not shown at all.

I had a look at the "messages" log and found that my modem was correctly identified and attached to /dev/ttyUSB0, /dev/ttyUSB1 and /dev/ttyUSB2.

I hope the netbook version is different from the desktop and this can explain why my modem is not shown as a network device in nm-tool

Ciao,
Max

David Tombs (dgtombs) wrote :

Thanks for the update, Max. I really don't know what the exact differences are between the netbook and desktop editions myself, but if you could possibly try the desktop that would be good. If you really did find a new issue, now is the perfect time to report it--before release!

Finally, I got the desktop live CD. I made 10 reboots using Lucid and 9 times out of 10 the modem was correctly connected to ttyUSB0. Once the modem was not detected at all but it was never connected to ttyUSB2.

I made only ten reboots but with the Ubuntu versions I've been using during the last two years the modem was connected to ttyUSB2 more than 50% of times, so as far as I can see my problem should be solved with Lucid.

Thanks a lot.

Ciao,
Max

David Tombs (dgtombs) wrote :

Great! Thanks for the update. I'll mark this as fixed now, and please reopen if you have any more issues.

Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Released

Bad bad bad news...

I've just upgraded to Ubuntu 10.4 and my HSDPA modem seems to have completely disappeared.

Using dmesg I can see a modem is found and connected to ttyUSB0, ttyUSB1 and ttyUSB2, as usual, using lsmod I can see that 'option' module is there but the UMTS modem doesn't appear neither in the network manager applet nor using 'nm-tool' or 'ifconfig'.

I have rebooted several times having always the same result.

Now what?

Attached you find output from dmesg, lsmod and nm-tool.

Ciao,
Max

David Tombs (dgtombs) wrote :

Hi Max,

Sorry for the trouble. Since this report was technically about a different issue, I'd recommend opening a new report against modemmaanger with "ubuntu-bug modemmanager". Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers