modemmanager 1.7.990-1ubuntu1 does not see my usb dongle

Bug #1777711 reported by corrado venturini on 2018-06-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

modemmanager 1.7.990-1ubuntu1 on my Ubuntu Cosmic does not see my usb dongles while 1.6.8-2ubuntu1 on Ubunty Bionic and Artful (same PC, different partition) is ok. Same problem on my laptop.
Problem happens with different dongle of different factories.

corrado@corrado-p7-cc-0527:~$ apt policy modemmanager
modemmanager:
  Installed: 1.7.990-1ubuntu1
  Candidate: 1.7.990-1ubuntu1
  Version table:
 *** 1.7.990-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p7-cc-0527:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 003: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
Bus 001 Device 002: ID 19d2:0037 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
corrado@corrado-p7-cc-0527:~$ mmcli -L

No modems were found

corrado@corrado-p7-cc-0527:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 003: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
Bus 001 Device 006: ID 19d2:0037 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
corrado@corrado-p7-cc-0527:~$ mmcli -L

No modems were found

corrado@corrado-p7-cc-0527:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 003: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
Bus 001 Device 008: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
corrado@corrado-p7-cc-0527:~$ mmcli -L

No modems were found

corrado@corrado-p7-cc-0527:~$ inxi -Fx
System:
  Host: corrado-p7-cc-0527 Kernel: 4.15.0-23-generic x86_64 bits: 64
  compiler: gcc v: 7.3.0 Desktop: Gnome 3.28.1
  Distro: Ubuntu Cosmic Cuttlefish (development branch)
Machine:
  Type: Desktop Mobo: ASRock model: H110M-G/M.2 serial: <root required>
  UEFI: American Megatrends v: P1.10 date: 05/11/2017
CPU:
  Topology: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP
  arch: Skylake rev: 9 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31296
  Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 801 2: 800
  3: 800 4: 801
Graphics:
  Card-1: Intel HD Graphics 630 driver: i915 v: kernel bus ID: 00:02.0
  Display: x11 server: X.Org 1.19.6 driver: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
  v: 4.5 Mesa 18.1.1 direct render: Yes
Audio:
  Card-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel v: kernel
  bus ID: 00:1f.3
  Sound Server: ALSA v: k4.15.0-23-generic
Network:
  Card-1: Intel Ethernet Connection I219-V driver: e1000e v: 3.2.6-k
  port: N/A bus ID: 00:1f.6
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full
  mac: 70:85:c2:44:7b:86
Drives:
  HDD Total Size: 931.51 GiB used: 8.48 GiB (0.9%)
  ID-1: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
Partition:
  ID-1: / size: 31.25 GiB used: 8.47 GiB (27.1%) fs: ext4 dev: /dev/sda7
  ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 44.5 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 236 Uptime: 26m Memory: 7.50 GiB used: 1.12 GiB (14.9%)
  Init: systemd runlevel: 5 Compilers: gcc: N/A Shell: bash v: 4.4.19
  inxi: 3.0.12
corrado@corrado-p7-cc-0527:~$

corrado@corrado-p8-bionic:~$ apt policy modemmanager
modemmanager:
  Installed: 1.6.8-2ubuntu1
  Candidate: 1.6.8-2ubuntu1
  Version table:
 *** 1.6.8-2ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p8-bionic:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 003: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
Bus 001 Device 002: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
corrado@corrado-p8-bionic:~$ mmcli -L

Found 1 modems:
 /org/freedesktop/ModemManager1/Modem/0 [huawei] E17X

corrado@corrado-p8-bionic:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 003: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
Bus 001 Device 006: ID 19d2:0037 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
corrado@corrado-p8-bionic:~$ mmcli -L

Found 1 modems:
 /org/freedesktop/ModemManager1/Modem/1 [ONDA COMMUNICATION] MT191UP

corrado@corrado-p8-bionic:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 003: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
Bus 001 Device 008: ID 19d2:0037 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
corrado@corrado-p8-bionic:~$ mmcli -L

Found 1 modems:
 /org/freedesktop/ModemManager1/Modem/2 [ONDA COMMUNICATION] MT503HSA

corrado@corrado-p8-bionic:~$ inxi -Fx
System: Host: corrado-p8-bionic Kernel: 4.15.0-23-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.28.1 (Gtk 3.22.30-1ubuntu1) Distro: Ubuntu 18.04 LTS
Machine: Device: desktop Mobo: ASRock model: H110M-G/M.2 serial: N/A UEFI: American Megatrends v: P1.10 date: 05/11/2017
CPU: Dual core Intel Core i3-7100 (-MT-MCP-) arch: Skylake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15648
           clock speeds: max: 3900 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics: Card: Intel HD Graphics 630 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) driver: i915 Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network: Card: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:44:7b:86
Drives: HDD Total Size: 1000.2GB (2.0% used)
           ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB
Partition: ID-1: / size: 32G used: 11G (37%) fs: ext4 dev: /dev/sda8
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 44.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 254 Uptime: 8 min Memory: 897.8/7680.8MB Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.191) inxi: 2.3.56
0.8MB Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.191) inxi: 2.3.56
corrado@corrado-p8-bionic:~$

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed
Ivan Denkov (idenkov) wrote :

Looks like the same bug to me.
Ubuntu 18.04
Package: modemmanager
Version: 1.6.8-2ubuntu1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers