package:modemmanager:1.4.10-1:subprocess installed post-installation script returned error exit status 100

Bug #1481798 reported by errors.ubuntu.com bug bridge on 2015-08-05
406
This bug affects 108 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Critical
Mathieu Trudel-Lapierre
Nominated for Wily by Alberto Salvia Novella

Bug Description

WORKAROUND:
At the end of the install if modemmanager fails to install correctly do the following:
Open a terminal and sudo dpkg --configure -a
sudo reboot
upon returning to the desktop the open a terminal and run
sudo apt-get update && sudo apt-get autoremove

This should have you back at a working system with any packages not needed removed.

ISSUE:
The Ubuntu Error Tracker has been receiving reports about a problem regarding modemmanager. This problem was most recently seen with version 1.4.10-1, the problem page at https://errors.ubuntu.com/problem/abc807de9d9c87d965fea31c865192edb30b6738 contains more details.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

From a duplicate here is the failure when installing the package:

Setting up modemmanager (1.4.10-1) ...^M
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused^M
invoke-rc.d: unknown initscript, /etc/init.d/modemmanager not found.^M
dpkg: error processing package modemmanager (--configure):^M
 subprocess installed post-installation script returned error exit status 100^M

Changed in modemmanager (Ubuntu):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Brian Murray (brian-murray) wrote :

This generally seems to be happening during distribution upgrades from vivid to wily.

tags: added: rls-w-incoming
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1481798

tags: added: iso-testing
David Pearson (akxwi-dave) wrote :

I had this ame error last night when attempting to update xubuntu 15.04 to 15.10.. left system unusable

no longer affects: modemmanager
Changed in modemmanager (Ubuntu):
status: Confirmed → Triaged
Christopher (soft-kristal) wrote :

I had the same issue upgrading, but was able to force restart and fix everything afterwards with Synaptic. It took a few reboots and Bleachbit to get rid of the apport errors, but all is well now. It isn't my work computer.

Changed in modemmanager (Ubuntu):
milestone: none → ubuntu-15.10
Changed in modemmanager (Ubuntu):
importance: High → Critical
Jonathan Riddell (jr) on 2015-09-24
tags: added: kubuntu
Dave Morley (davmor2) on 2015-09-24
description: updated
description: updated

I've verified this myself after uploading modemmanager 1.4.10-1ubuntu2; and asked davmor2 to verify as well -- this appears to be resolved.

Closing as Fix Released, please file a new bug report if this reoccurs.

Changed in modemmanager (Ubuntu):
status: Triaged → Fix Released
Brian Murray (brian-murray) wrote :

One could also watch the Error Tracker for package install failures at the following url:

https://errors.ubuntu.com/?release=Ubuntu%2015.10&package=modemmanager&period=week

To post a comment you must log in.