novatel: improve probing for Dell branded modems

Bug #1441095 reported by Bin Li on 2015-04-07
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Libmbim
Fix Released
Medium
ModemManager
Fix Released
High
OEM Priority Project
High
Unassigned
Trusty
High
Unassigned
libmbim (Ubuntu)
High
Unassigned
Declined for Wily by Brian Murray
Trusty
High
Unassigned
modemmanager (Ubuntu)
High
Unassigned
Declined for Wily by Brian Murray
Trusty
High
Unassigned
network-manager (Ubuntu)
High
Unassigned
Declined for Wily by Brian Murray
Trusty
High
Unassigned

Bug Description

[Impact]

 * The users can not use the WWAN of Sierra DW5809e (EM7305) or Sierra DW5811e (EM7455) to connect to Internet.

[Test Case]

 * Insert the WWAN of Sierra DW5809e (EM7305) or Sierra DW5811e (EM7455).

 * Insert the SIM, boot the Ubuntu system, and connect to Internet by NetworkManager.

[Regression Potential]

 * No trivial regression so far.

[Other Info]

 * There is no gateway information in Network Manager. (See the picture in comment #74)
  * Some ISPs like TW Mobile in Taiwan don't need the gateway to connect to Internet.
  * Some ISPs like Chunghwa Telecom in Taiwan do need the gateway to connect to Internet.
  * We need to see the gateway information in Network Manager to cover all ISPs.

Dell rebrands modems from different vendors, including Novatel, Sierra and Ericsson. Until now we defaulted to the Novatel plugin when a Dell device was found, but then we're breaking newer MBIM Sierra Dell-branded modems, as we don't have MBIM support in the Novatel plugin.

So, we should try to improve the probing in the Novatel, Sierra and MBM plugins, so that they probe also Dell devices, and we'll then try to match via AT-probing which plugin should be handling the Dell device.

https://bugs.freedesktop.org/show_bug.cgi?id=86713

Could we backport this patch into trusty? Thanks!

Related branches

Dell rebrands modems from different vendors, including Novatel, Sierra and Ericsson. Until now we defaulted to the Novatel plugin when a Dell device was found, but then we're breaking newer MBIM Sierra Dell-branded modems, as we don't have MBIM support in the Novatel plugin.

So, we should try to improve the probing in the Novatel, Sierra and MBM plugins, so that they probe also Dell devices, and we'll then try to match via AT-probing which plugin should be handling the Dell device.

Quoting Dan:

"The case we care about for Novatel is AT-only devices. For those, here
is a list of commands we can use to identify them and some sample
replies. Built from the XU870 (Dell Wireless 5510), EX725, S720, E362.

We should only do this probing if the following are true:

1) The device only has AT ports; eg it does *not* have any QMI, MBIM, or
"net" ports

2) The device does *not* report LTE capabilities via ATI or GCAP

Early Novatel QMI-capable devices (like the E362) support these commands
(at$nw*) but of course we don't want to treat them as AT-only Novatel.

=======

ati1
Manufacturer: Novatel Wireless Incorporated
Manufacturer: NOVATEL WIRELESS INCORPORATED

AT+GMI
Novatel Wireless Incorporated
NOVATEL WIRELESS INCORPORATED

at$nwdegc (GSM/UMTS only)
(non-error response sufficient)

=======

If for some reason those don't work, here are some more esoteric ones
that we could potentially use:

AT$NWHFP? (gsm only)
AT$NWCSQ (gsm only)
AT$NWWDIS? (gsm only)
AT$NWERR? (gsm only)
AT$NWCFT? (gsm only)
AT$NWRAT? (gsm only)
AT$NWLTIME (cdma only)
at$nwrssi (cdma only)"

More context in the ML:
http://lists.freedesktop.org/archives/modemmanager-devel/2014-November/001636.html

A new 'dell' plugin has been now merged to git master, will be available in ModemManager 1.6.

Bin Li (binli) wrote :

I've backport the patch and built it successfully, still not test it on Dell's device. we need find some one to help me.

Bin Li (binli) wrote :

Sorry the result is failed, we still need backport more file from upstream.

dell/mm-plugin-dell.c:29:31: fatal error: mm-common-novatel.h: No such file or directory

Pascal Morin (pcm689) wrote :

Bin, I suggest to contact, coordinate and work with Bofu specifically with WWAN sierra module. Bofu have additional information to share based on Mario's feedback and expectation

Bin Li (binli) wrote :

Done. I have finished backport patch.

Bin Li (binli) wrote :

If any issue, please collect the debug info for me.
1) Edit the /etc/init/modemmanager.conf, change the last line to 'exec /usr/sbin/ModemManager --debug'
2) Reboot the machine.
3) Test the 3G connection. And send me back the syslog file.

Emily Chien (emily.chien) wrote :

Copy comments from KittyHawk project - https://bugs.launchpad.net/kittyhawk/kittyhawk-2.0/+bug/1441943/comments/7

After installing modemmanager_1.0.0-2ubuntu2_amd64.deb from comment #5, WWAN works.
Speed test result: 37.05Mbps download, 15.97Mbps upload.

Also tried S3 and hybrid sleep, WWAN works after S3, but didn't work after resuming from disk in hybrid sleep.

[Machine]
HOU4-E3-C1B
BIOS: X57
WWAN card: EM7305

[Image]
kittyhawk2-trusty-amd64-20150416-0

Created attachment 116875
Debug message from ModemManager.

The EM7455 (Dell DW5811e) is not working when using the git master ModemManager/libmbim/libqmi.

The last message piece from "ModemManager --debug":
ModemManager[2470]: <info> [1435834110.545710] [mm-device.c:520] mm_device_create_modem(): Creating modem with plugin 'Dell' and '2' ports
ModemManager[2470]: <debug> [1435834110.545727] [dell/mm-plugin-dell.c:382] create_modem(): Dell-branded generic modem found...
ModemManager[2470]: <warn> [1435834110.545871] [mm-plugin.c:974] mm_plugin_create_modem(): Could not grab port (usbmisc/cdc-wdm0): 'Cannot add port 'usbmisc/cdc-wdm0', unsupported'
ModemManager[2470]: <debug> [1435834110.545898] [mm-base-modem.c:312] mm_base_modem_grab_port(): (wwan0) type 'net' claimed by /sys/devices/pci0000:00/0000:00:14.0/usb2/2-2
ModemManager[2470]: <debug> [1435834110.545926] [mm-base-modem.c:1493] finalize(): Modem (Dell) '/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2' completely disposed
ModemManager[2470]: <warn> [1435834110.545939] [mm-base-manager.c:158] find_device_support_ready(): Couldn't create modem for device at '/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2': Failed to find primary AT port

I tried mbimcli by "mbimcli -d /dev/cdc-wdm0 --query-device-caps --verbose":
[02 Jul 2015, 19:02:36] [Debug] opening device...
[02 Jul 2015, 19:02:36] [Debug] [/dev/cdc-wdm0] Queried max control message size: 4096
[02 Jul 2015, 19:02:36] [Debug] [/dev/cdc-wdm0] Sent message...
<<<<<< RAW:
<<<<<< length = 16
<<<<<< data = 01:00:00:00:10:00:00:00:01:00:00:00:00:10:00:00

[02 Jul 2015, 19:02:36] [Debug] [/dev/cdc-wdm0] Sent message (translated)...
<<<<<< Header:
<<<<<< length = 16
<<<<<< type = open (0x00000001)
<<<<<< transaction = 1
<<<<<< Contents:
<<<<<< max_control_transfer = 4096

And the transaction repeats for 30 times, in the end it says:

[02 Jul 2015, 19:03:06] [Debug] open operation timed out: closed
error: couldn't open the MbimDevice: Transaction timed out

But when using EM7305, everything works as expected.

Looks like the mbim-proxy cannot get the MBIM port open.

Could you run the following sequence?

[stop ModemManager]
$ sudo /usr/libexec/mbim-proxy --verbose > proxy.log 2>&1 &
$ sudo /usr/sbin/ModemManager --debug

And send back the proxy log?

Created attachment 116969
Log file from mbim-proxy.

(In reply to Kai-Heng Feng from comment #3)
> Created attachment 116969 [details]
> Log file from mbim-proxy.

Looks like the proxy didn't receive anything. Was ModemManager run *after* running the proxy?

Created attachment 116971
Log file from mbim-proxy.

Yes. There was already a ModemManager instance running. Here's the correct log.

(In reply to Kai-Heng Feng from comment #5)
> Created attachment 116971 [details]
> Log file from mbim-proxy.
>
> Yes. There was already a ModemManager instance running. Here's the correct
> log.

Thanks. Pretty weird, the modem doesn't seem to ever reply to any MBIM message...

Is there any chance that cdc_mbim kernel module does not support this card?

Now I can make the device work by changing the retry timer from 1s to 4s in mbim_device_command():
http://cgit.freedesktop.org/libmbim/libmbim/tree/src/libmbim-glib/mbim-device.c#n1234

After changing that, the device can operate normally.
So looks like it may be a driver/firmware/hardware problem.

Ara Pulido (ara) on 2015-08-10
Changed in oem-priority:
status: New → Incomplete
Bin Li (binli) wrote :

 I just wait for someone to review it, it works fine for EM7305. But now the Dell project want support another new device(EM7445), I just add some other new patches, but currently it can't work, and I need more time to debug it. :)

 I just prepare to backport below two patches, now it could build and run successfully. But they can't work for MBIM device, cause the backport depends on a lot changes, might be missed some other code.

'''
commit 37bda21a370bfd5c125a7093bec55dca3914af9b
Author: Aleksander Morgado <email address hidden>
Date: Tue Feb 17 10:57:22 2015 +0100

    plugin: add implicit QMI and MBIM forbidden drivers check
'''

'''
commit 6bbc4c1746c9e7c48e12dcb1e1986f1e16327161
Author: Aleksander Morgado <email address hidden>
Date: Fri Feb 6 20:02:20 2015 +0100

    sierra: move all the legacy Sierra support to a new 'sierra-legacy' plugin

    In short:

      * The 'sierra-legacy' plugin will handle all the old AT based modems,
        including the DirectIP ones. This plugin is filtered by driver ('sierra' or
        'sierra_net') and forbidden-drivers ('qmi_wwan' and 'cdc_mbim'). This plugin
        should also grab HP and AT&T branded models if they are handled by the
        proper kernel driver.

      * The 'sierra' plugin will only handle QMI or MBIM based Sierra modems, which
        are really all the new ones. This plugin is filtered by VID (0x1199) and
        driver (qmi_wwan and cdc_mbim).

    For this separation to work, the 'sierra' and 'sierra_net' plugins need to be
    complementary to each other.
'''

Changed in oem-priority:
status: Incomplete → In Progress
status: In Progress → New
Ara Pulido (ara) wrote :

We need some testing results on both Wily and Trusty.

Thanks,
Ara.

Changed in oem-priority:
importance: Undecided → High
status: New → Incomplete
Bin Li (binli) wrote :

 In trusty, I have finished the patches, I separated the previous patches based on the upstream commit, I merged these together for convenient in first version, I back-ported modemmanager from master branch(1.5) to trusty(1.0), some data structure was changed which I have updated in the backported patches.

 For Wily, we need to backport these patch from master branch(1.5) to 1.4 which is used by wily, I'm still working on it.

And now we just try find a better way which let the upstream cherry-picks from upstream(1.5) to 1.4, not sure if it is possible yet, :)

Bin Li (binli) wrote :

For wily, I just cherry picked from git master branch(1.5) to 1.4. No data structure was changed like the patch in 1.0.

Shih-Yuan Lee (fourdollars) wrote :

I collected some logs for EM7455 by the following commands.

sudo service network-manager stop
sudo ModemManager --debug > ModemManager.log 2>&1
sudo NetworkManager --no-daemon > NetworkManager.log 2>&1

Shih-Yuan Lee (fourdollars) wrote :
Shih-Yuan Lee (fourdollars) wrote :

There is an upstream bug report at https://bugs.freedesktop.org/show_bug.cgi?id=91189.

Changed in modemmanager:
importance: Undecided → Unknown
status: New → Unknown
Changed in modemmanager:
importance: Unknown → Medium
status: Unknown → Confirmed
Shih-Yuan Lee (fourdollars) wrote :

I made a PPA at https://launchpad.net/~fourdollars/+archive/ubuntu/modemmanager from the upstream development snapshots and included kaihengfeng's 4 seconds retry.
EM7455 can work on trusty now.

Shih-Yuan Lee (fourdollars) wrote :

"EM7455 can work on trusty now." of comment #23 means I can see the Mobile Broadband in the network indicator but I can not access Internet so far.
I am still trying to connect to Internet.

The attachment "delay_the_retry.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Shih-Yuan Lee (fourdollars) wrote :

Regarding comment #23 & #24, I can get the {IP Address,Broadcast Address,Subnet Mask,Primary DNS, Secondary DNS} from Mobile Broadband but there is no default gateway information.

Bin Li (binli) wrote :

$4,

  I took annual leave yesterday, so now it looks the upstream one works fine for the master version, I don't know why there are no default gateway, you add one with ifconfig, after that check if it could browse the website. :)

Shih-Yuan Lee (fourdollars) wrote :

BinLi,

Don't worry. It seems that the SIM card I used runs out of the mobile data volume.
I have added some data volume into it and will try it again.

Shih-Yuan Lee (fourdollars) wrote :

Some ISPs like TW Mobile in Taiwan don't need the gateway to connect to Internet.
Some ISPs like Chunghwa Telecom in Taiwan do need the gateway to connect to Internet.

BTW, after I used ppa:fourdollars/modemmanager and this patch for network-manager, I can connect to Internet.
But some informations such as Hardware Address, Driver and Speed are still unavailable.

Vivid and wily don't need this patch so we can do the SRU only for trusty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 1.4.10-1ubuntu1

---------------
modemmanager (1.4.10-1ubuntu1) wily; urgency=medium

  * New hardware enablement: Support the new MBIM devices from Dell.
    (LP: #1441095)

 -- Bin Li <email address hidden> Mon, 21 Sep 2015 15:01:04 -0400

Changed in modemmanager (Ubuntu):
status: New → Fix Released
Bin Li (binli) wrote :

4$,

 Yes, I thought we need push the network-manager patch separately. I will open another bug to trace it.

 And I found there are patch in 0.9.9.1, we need cherry pick into 0.9.8.8.

commit 19089fb9609c5a62a3cfe5ff81e3d3d93beabeb3
Author: Dan Williams <email address hidden>
Date: Tue Feb 18 13:51:03 2014 -0600

    mobile: use gateway returned from ModemManager

    If we get a gateway, use it.

Bin Li (binli) wrote :

I just found the networkmanager project was affected in this bug, so we don't need to open another one, :)

Shih-Yuan Lee (fourdollars) wrote :

@Bin,

In fact, my patch is derived from the commit of comment #31.
BTW, I thought wily didn't need this patch and could work fine, but I just found there is also the gateway issue on wily for Sierra DW5809e (EM7305).

Shih-Yuan Lee (fourdollars) wrote :

Comment #33 is verified by Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150921).

Shih-Yuan Lee (fourdollars) wrote :

There is still no Hardware Address, Speed and Default Route (default gateway) on wily.
IP Address should not be the same as Broadcast Address.

Bin Li (binli) wrote :

Now Shih-Yuan helped to debug more about it, I thought he will debug more for EM7305 and EM7455.

Changed in modemmanager (Ubuntu):
status: Fix Released → In Progress
Bin Li (binli) on 2015-09-24
Changed in modemmanager (Ubuntu):
status: In Progress → Fix Released

Created attachment 118426
Increase the retry interval to 5 seconds.

Comment on attachment 118426
Increase the retry interval to 5 seconds.

This breaks the timeout value given by the user. In open_message_ready() we'll do a ctx->timeout--; if we got a timeout error, so that we can retry. Instead of ctx->timeout--; there should be a ctx->timeout-=5 there, and along with that: make timeout a gint (not guint) and also don't do the (ctx->timeout) check, and instead do (ctx->timeout > 0)

Also, better #define RETRY_TIMEOUT_SECS 5 and use the symbol everywhere.

Could you update the patch and retest?

Created attachment 118427
Increase the retry interval to 5 seconds.

Sure.

I have verified the patch of comment #11.
It works fine and is better than the previous one.

Merged the patch to mbim-1-12 and git master, thanks!

So is this fixed or not?

Shih-Yuan Lee (fourdollars) wrote :

No, it is not for wily.

Shih-Yuan Lee (fourdollars) wrote :

BTW, no one verified the patch for wily on the real device and the patch is just accepted.

Bin Li (binli) wrote :

Mathieu,

 Shih-Yuan already helped to verify in trusty it works fine for EM7305 and EM7455,, and all the patches are almost same with trusty, just some data structure is changed for wily, I just find another Sierra device, although it's not use this Dell plugin, I will tested the wily package for this device, to make sure the ModemManager works correctly, in case of any issue, we will let you know.

 Thanks a lot!

Bin Li (binli) wrote :

I installed the new package in wily, looks this device can't work, it can't recognize the SIM card. We had two devices, same type from Lenovo, just one of them works for trusty which I tested them last year, but I can't find another device now. :)

So now ModemManager could finish the device detecting for other device. :)

ModemManager[2063]: <debug> [1443157535.179905] [mm-iface-modem.c:266] load_unlock_required_ready(): Couldn't check if unlock required: 'SIM not inserted'

Shih-Yuan Lee (fourdollars) wrote :

@Bin,

Could you help to change the status from "Fix Released" of this bug?
It confuses people and I don't have the permission to change it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu Trusty):
status: New → Confirmed
Changed in network-manager (Ubuntu Trusty):
status: New → Confirmed
Changed in network-manager (Ubuntu):
status: New → Confirmed
Bin Li (binli) wrote :

@Shih-Yuan,

 I have updated the status to 'Confirmed".:)

Changed in modemmanager (Ubuntu):
status: Fix Released → Confirmed
Shih-Yuan Lee (fourdollars) wrote :

The original modemmanager 1.4.10-1 can work for Sierra DW5809e (EM7305).
The mobile broadband connection behavior on wily works differently from trusty.
Trusty uses wwan0 and it needs the gateway for some ISPs.
Wily setups ppp0 and it doesn't need the gateway.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in oem-priority:
status: Incomplete → In Progress
Shih-Yuan Lee (fourdollars) wrote :

Only modemmanager 1.4.10-1ubuntu1 can not make Sierra DW5811e (EM7455) work.
We also need to patch libmbim to make Sierra DW5811e (EM7455) work.
Sierra DW5811e (EM7455) will use wwan0 instead ppp0 to connect to Internet.

Changed in libmbim (Ubuntu):
status: New → Confirmed
Changed in libmbim (Ubuntu Trusty):
status: New → Confirmed
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in libmbim (Ubuntu):
assignee: nobody → Shih-Yuan Lee (fourdollars)
status: Confirmed → In Progress
Changed in modemmanager (Ubuntu):
status: Confirmed → Fix Released
Changed in network-manager (Ubuntu Trusty):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Bin Li (binli) wrote :

I find another EM7355 device, it could be detected by ModemManager in wily, and I click the menu to connect it, and it need a password for my card, I don't know what is it yet, so I can't visit the Internet yet.

Anyway, the new ModemManager in wily could detect the 3G device. I'm still debugging and I will report later.

Shih-Yuan Lee (fourdollars) wrote :

@Bin,

That is the PIN number. Every SIM card has its own PIN number.

tags: added: trusty wily
Changed in modemmanager:
status: Confirmed → Fix Released
Changed in oem-priority:
status: In Progress → Confirmed
Changed in libmbim (Ubuntu Trusty):
status: Confirmed → In Progress
Changed in network-manager (Ubuntu):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in network-manager (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in modemmanager (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in network-manager (Ubuntu):
assignee: Shih-Yuan Lee (fourdollars) → nobody
Changed in network-manager (Ubuntu Trusty):
assignee: Shih-Yuan Lee (fourdollars) → nobody
Changed in libmbim (Ubuntu):
importance: Undecided → High
Changed in libmbim (Ubuntu Trusty):
importance: Undecided → High
Changed in modemmanager (Ubuntu):
importance: Undecided → High
Changed in modemmanager (Ubuntu Trusty):
importance: Undecided → High
Changed in network-manager (Ubuntu):
importance: Undecided → High
Changed in network-manager (Ubuntu Trusty):
importance: Undecided → High
Changed in network-manager (Ubuntu Trusty):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in oem-priority:
status: Confirmed → In Progress
assignee: nobody → Shih-Yuan Lee (fourdollars)
TJ (tj) on 2015-10-01
Changed in network-manager (Ubuntu Trusty):
status: Fix Released → In Progress
Changed in modemmanager (Ubuntu Trusty):
status: Fix Released → In Progress
Changed in libmbim (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmbim - 1.12.2-2ubuntu1

---------------
libmbim (1.12.2-2ubuntu1) wily; urgency=medium

  * libmbim-glib: Increase the retry interval to 5 seconds. (LP: #1441095)

 -- Shih-Yuan Lee (FourDollars) <email address hidden> Fri, 25 Sep 2015 15:59:59 +0800

Changed in libmbim (Ubuntu):
status: Fix Committed → Fix Released
Shih-Yuan Lee (fourdollars) wrote :

I have verified libmbim (1.12.2-2ubuntu1) and it does work for Sierra DW5811e (EM7455).

Chris J Arges (arges) wrote :

FourDollars,

Can you provide SRU bug template information as documented here:
https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

In addition do you plan on backporting this to vivid as well?
--chris

description: updated
Shih-Yuan Lee (fourdollars) wrote :

@arges,

I have updated the bug description for SRU.
I can help the parts of NetworkManager and libmbim, but ModemManager is done by Bin Li and it is the major part for this issue.

--$4

Bin Li (binli) wrote :

@arges, @$4,

 Fine, I will help it for vivid. :)

Hello Bin, or anyone else affected,

Accepted libmbim into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libmbim/1.6.0-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libmbim (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Bin Li (binli) wrote :

@arges, @$4,

 I have finished the backport for vivid.

@Brian,

 Great news, thanks a lot! Currently I don't have the device on hand. We need $4 help to verify it. :)

Changed in network-manager (Ubuntu Trusty):
assignee: Shih-Yuan Lee (fourdollars) → nobody
assignee: nobody → Shih-Yuan Lee (fourdollars)
Shih-Yuan Lee (fourdollars) wrote :

Only libmbim is not enough to fix this issue.
We also need to the fixes of modemmanager and network-manager for trusty.
The fix of modemmanager for trusty is at https://code.launchpad.net/~binli/ubuntu/trusty/modemmanager/lp1441095.
The fix of network-manager for trusty is at https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/1441095/comments/57.
Please also include these fixes for trusty.

tags: added: verification-failed
removed: verification-needed
Ara Pulido (ara) on 2015-10-23
tags: added: verification-needed
removed: verification-failed
Bin Li (binli) wrote :

@Ara,

 Could we let the modemmanager fixes in trusty in #65? Thanks!

affects: modemmanager → libmbim
Changed in modemmanager:
importance: Unknown → High
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

The modemmanager trusty SRU has been sponsored, thanks Mathieu
https://launchpad.net/ubuntu/trusty/+queue?queue_state=1&queue_text=modemmanager

Sebastien Bacher (seb128) wrote :

(n-m as well)

Shih-Yuan Lee (fourdollars) wrote :

Thanks a lot.

Brian Murray (brian-murray) wrote :

I don't see any SRU information regarding how to test the network-manager change use-the-gateway-from-ModemManager.patch. Could this please be added to the description so that we can accept network-manager into -proposed? Thanks!

Changed in modemmanager (Ubuntu Trusty):
status: In Progress → Fix Committed

Hello Bin, or anyone else affected,

Accepted modemmanager into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/modemmanager/1.0.0-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Shih-Yuan Lee (fourdollars) wrote :

There is no gateway information in Network Manager.

description: updated
Shih-Yuan Lee (fourdollars) wrote :

@Brian,

I just added the information in [Other Info] for network-manager.
Please help to sponsor the patch for network-manager, thx.

Chris J Arges (arges) wrote :

Hello Bin, or anyone else affected,

Accepted network-manager into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/0.9.8.8-0ubuntu7.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Trusty):
status: In Progress → Fix Committed
Shih-Yuan Lee (fourdollars) wrote :

I have verified Sierra DW5809e (EM7305) and Sierra DW5811e (EM7455) by trusty-proposed and they works.

Changed in oem-priority:
status: In Progress → Fix Committed
tags: added: verification-done
removed: verification-needed
Changed in network-manager (Ubuntu Trusty):
assignee: Shih-Yuan Lee (fourdollars) → nobody
Changed in libmbim (Ubuntu Trusty):
assignee: Shih-Yuan Lee (fourdollars) → nobody
Changed in libmbim (Ubuntu):
assignee: Shih-Yuan Lee (fourdollars) → nobody
Changed in oem-priority:
assignee: Shih-Yuan Lee (fourdollars) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmbim - 1.6.0-2ubuntu0.1

---------------
libmbim (1.6.0-2ubuntu0.1) trusty-proposed; urgency=medium

  * debian/patches/delay_the_retry.patch: Increase the retry interval for
    Sierra EM7455 (Dell DW5811e). (LP: #1441095)

 -- Shih-Yuan Lee (FourDollars) <email address hidden> Thu, 24 Sep 2015 11:45:13 +0800

Changed in libmbim (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libmbim has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 1.0.0-2ubuntu1.1

---------------
modemmanager (1.0.0-2ubuntu1.1) trusty; urgency=medium

  * Support the MBIM for Dell. (LP: #1441095)

 -- Bin Li <email address hidden> Mon, 13 Apr 2015 16:01:58 +0800

Changed in modemmanager (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.8.8-0ubuntu7.2

---------------
network-manager (0.9.8.8-0ubuntu7.2) trusty; urgency=medium

  * Use the gateway from ModemManager. (LP: #1441095)
    - use-the-gateway-from-ModemManager.patch

 -- Shih-Yuan Lee (FourDollars) <email address hidden> Mon, 21 Sep 2015 16:46:27 +0800

Changed in network-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released
Ara Pulido (ara) on 2016-01-18
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.