REGRESSION: MBIM kernel suppport should be disabled until userspace support available (breaks Ericsson H5321 etc.)

Bug #1169117 reported by Marius B. Kotsbak on 2013-04-15
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Debian)
Invalid
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned
modemmanager (Ubuntu)
Critical
Unassigned

Bug Description

"commit bd329e1 ("net: cdc_ncm: do not bind to NCM compatible MBIM devices")
    introduced a new policy, preferring MBIM for dual NCM/MBIM functions if
    the cdc_mbim driver was enabled. This caused a regression for users
    wanting to use NCM."

For background on this change please see Bug #1102343.

This could be solved in different ways:
1) Remove "cdc_mbim.ko" from packages like linux-image-extra-3.8.0-XX-YY. Easy, but makes it harder for people to experiment with MBIM and add userspace support

2) Set the kernel parameter "prefer_mbim" to false for "cdc_ncm" module. This could be done by adding a file "/etc/modprobe.d/avoid-mbim.conf" with content:
  options cdc_ncm prefer_mbim=N

This will allow people wanting to test MBIM easy access by removing or editing the file. Then the question is if this file should stay in modemmanager package or maybe in the kernel package? The required code for this option to exist seems to be in Ubuntu Raring packages in commit 04188f3010f64ddf2c75c3f4953eee9bdb4f5cc1.

3) Debian has solved it by patching the kernel to reverse the default to be not to use MBIM:
http://lists.alioth.debian.org/pipermail/kernel-svn-changes/2013-March/018852.html
http://lists.debian.org/debian-kernel/2013/03/msg00611.html

WORKAROUND: Add in /etc/modprobe.d/cdc_ncm.conf :
options cdc_ncm prefer_mbim=N

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in modemmanager (Ubuntu):
status: New → Confirmed
summary: MBIM kernel suppport should be disabled until userspace support
- available
+ available (breaks Ericsson H5321 etc.)
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in modemmanager (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu):
importance: High → Critical
Changed in modemmanager (Ubuntu):
importance: High → Critical
summary: - MBIM kernel suppport should be disabled until userspace support
- available (breaks Ericsson H5321 etc.)
+ REGRESSION: MBIM kernel suppport should be disabled until userspace
+ support available (breaks Ericsson H5321 etc.)
tags: added: regression-release
Changed in linux (Ubuntu):
milestone: none → ubuntu-13.04
Changed in modemmanager (Ubuntu):
milestone: none → ubuntu-13.04
Till Kamppeter (till-kamppeter) wrote :

That's it!

I created a file /etc/modprobe.d/avoid-mbim.conf containing

options cdc_ncm prefer_mbim=N

and then I rebooted. After logging in again I activated the mobile broadband connection via the Network Manager menu (as described in my original bug report bug 1167852) and I got a connection. After disconnecting Ethernet and WLAN I had still access to the internet, via mobile.

So please include the workaround/fix in Raring. Thanks.

Only for the brave:

 * libmbim from https://gitorious.org/lanedo/libmbim
 * ModemManager from the 'aleksander/mbim' branch in upstream git

;)

Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released
description: updated
Changed in linux (Debian):
status: New → Fix Committed
description: updated
Marius B. Kotsbak (mariusko) wrote :

This should probably be solved in the same way as in Debian, solution 3) in the description.

Changed in modemmanager (Ubuntu):
status: Confirmed → Invalid
tags: added: raring
Joseph Salisbury (jsalisbury) wrote :

The CONFIG_USB_NET_CDC_MBIM option is currently set to m in the Ubuntu kernel config file.

Are you requesting that this option is unset?

Changed in linux (Ubuntu):
importance: Critical → High
Marius B. Kotsbak (mariusko) wrote :

No, I think the best would be to solve it by the same patch that Debian uses. Please see solution 3) in the description.

Till Kamppeter (till-kamppeter) wrote :

The bug is still present in Saucy (13.04). The workaround of comment #3 also works here. So please fix it in Saucy (and a SRU for Raring is also welcome).

Comment #3 solved the problem for me too in Saucy. Lenovo X1 Carbon with the Ericson H5321 card.

Please note that ModemManager 0.7.991 already supports MBIM devices, if compiled with support for using libmbim.

Will modemmanager 0.7.991 make it into Saucy?

Marius B. Kotsbak (mariusko) wrote :

Probably, but it will not solve this bug. See bug #1102343.

zlatko (zlatko23) wrote :

Having the similar issue with Ericsson H5321gw in Toshiba Z830. SIM registers to network, but than fails to connect most of the tries(like 1success to 30 failures). I tried the solution in 2), after reboot I connected from the first try, but after that I have not be able to get connection.
I see the driver used in my case is cdc_acm - cna this be the reason?

zlatko (zlatko23) wrote :

Also the modem itself is recognized as Toshiba, not Ericsson:
[code]
Sep 21 15:31:49 toshiba kernel: [ 7078.450687] usb 1-1.6: new high-speed USB device number 7 using ehci_hcd
Sep 21 15:31:49 toshiba kernel: [ 7078.545002] usb 1-1.6: New USB device found, idVendor=0930, idProduct=1319
Sep 21 15:31:49 toshiba kernel: [ 7078.545013] usb 1-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep 21 15:31:49 toshiba kernel: [ 7078.545019] usb 1-1.6: Product: H5321gw
Sep 21 15:31:49 toshiba kernel: [ 7078.545024] usb 1-1.6: Manufacturer: TOSHIBA
Sep 21 15:31:49 toshiba kernel: [ 7078.545029] usb 1-1.6: SerialNumber: 24359BF58A1F4870
Sep 21 15:31:49 toshiba mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6"
Sep 21 15:31:49 toshiba kernel: [ 7078.578410] cdc_acm 1-1.6:1.1: ttyACM0: USB ACM device
Sep 21 15:31:49 toshiba kernel: [ 7078.582138] cdc_acm 1-1.6:1.3: ttyACM1: USB ACM device
Sep 21 15:31:49 toshiba kernel: [ 7078.590550] cdc_wdm 1-1.6:1.5: cdc-wdm0: USB WDM device
Sep 21 15:31:49 toshiba kernel: [ 7078.605591] usb 1-1.6: MAC-Address: 02:15:e0:ec:01:00
Sep 21 15:31:49 toshiba kernel: [ 7078.606071] cdc_ncm 1-1.6:1.6: usb0: register 'cdc_ncm' at usb-0000:00:1a.0-1.6, CDC NCM, 02:15:e0:ec:01:00
Sep 21 15:31:49 toshiba kernel: [ 7078.607135] cdc_wdm 1-1.6:1.8: cdc-wdm1: USB WDM device
Sep 21 15:31:49 toshiba kernel: [ 7078.607728] cdc_acm 1-1.6:1.9: ttyACM2: USB ACM device
Sep 21 15:31:49 toshiba mtp-probe: bus: 1, device: 7 was not an MTP device
[/code]

It is really wird why the modem connects occasionally, but most of the times doesn't.

description: updated

Marius B. Kotsbak, at this point I'm not seeing anything wrong with syncing with Debian on this, despite the WORKAROUND. -> Triaged

description: updated
Changed in linux (Ubuntu):
importance: High → Low
milestone: ubuntu-13.04 → ubuntu-14.04-feature-freeze
status: Confirmed → Triaged

Closing the linux (Debian) task given it's already resolved for them.

Changed in linux (Debian):
status: Fix Committed → Invalid
Marius B. Kotsbak (mariusko) wrote :

At this time, I think it is better to introduce MBIM support in Ubuntu as the support in Modemmanager is already there. See bug #1102343 and #1123302.

Marius B. Kotsbak (mariusko) wrote :

Maybe this should be set to WONTFIX and possibly just fix it for older versions (12.04 LTS).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.