Please package modemmanager >= 1.0.0

Bug #1123302 reported by Jeremy Bicha on 2013-02-12
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Medium
Unassigned
modemmanager (Debian)
Fix Released
Unknown
modemmanager (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre

Bug Description

modemmanager 0.7 is now needed to build the network panel in gnome-control-center 3.7.90. It would be nice to have this in raring as it's one less system dependency I would need to maintain in the GNOME3 Staging PPA.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: modemmanager 0.6.0.0.really-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-6.11-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Tue Feb 12 13:05:06 2013
MarkForUpload: True
SourcePackage: modemmanager
UpgradeStatus: No upgrade log present (probably fresh install)

See also related bug #977761.

Related branches

Jeremy Bicha (jbicha) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed
Marius B. Kotsbak (mariusko) wrote :

Do you mean to provide both v6 and v7 with separate package names so the user can install one of them? I have it in a PPA, with NM and n-m-a.

Marius B. Kotsbak (mariusko) wrote :

I guess the issue here is that MM 0.7 is unreleased and has great regression potential.

Jeremy Bicha (jbicha) wrote :

No, I don't believe it's worth the complexity to try to provide multiple versions of modemmanager simultaneously in a single Ubuntu release.

I don't understand what you mean by "great regression potential". modemmanager 0.7.990 was released 2 months ago but it's not marked as "stable" yet; however GNOME 3.8 will depend on it for the next GNOME stable release due next month. We already package the latest development snapshot of networkmanager which is the most critical reverse dependency and should work fine with the new version.

Marius B. Kotsbak (mariusko) wrote :

Ah, I haven't noticed that there was a tagged release. Maybe it is of beta type. Anyway, the risk is because there is a lot of rewritten code/plugins. But it is not a LTS after all so it should be fine to risk that for Raring.

Marius B. Kotsbak (mariusko) wrote :

I'm using https://code.launchpad.net/~mariusko/modemmanager/ubuntu-0.7 published at:

https://launchpad.net/~mariusko/+archive/network-manager-snapshots

but that also includes QMI support requiring libqmi package that is in queue at debian.

Marius B. Kotsbak (mariusko) wrote :

Maybe we should include libqmi in Ubuntu in the mean time or try to get priority in the NEW queue.

I think it should be fine to include MM 07; I'll talk to Dan to see if we can have a release at some point in the near future. Regarding the regression potential, yes, there is some, as in every new release of everything :) Allowing a fallback to MM 0.6 (i.e. keeping libmm-glib installed but falling back to MM 0.6) should at least make it easier for users to go back while the bugs, if any, get fixed in MM 0.7.

BTW, 0.7.990 was just a tag to integrate it in jhbuild AFAIK; we didn't make a tarball out of it.

Marius B. Kotsbak (mariusko) wrote :

But how would it work if NM and N-M-A etc. were built to use libmm-glib (and it being installed), but with MM 0.6 running?

When NM or n-m-a are compiled against libmm-glib; it doesn't mean that only MM 0.7 is supported. If they detect a MM 0.7, they will use libmm-glib; otherwise they'll use the old MM support, which wasn't removed.

Marius B. Kotsbak (mariusko) wrote :

Okay, that means that we in theory could split just MM into e.g. "modemmanager" and "modemmanager-0.7" (conflicting with each other) or the opposite depending on what should be default and the other ones require just one of them.

Why not just package the new version as modemmanager? what's the issue with that? If you want to fallback, you can always grab the deb for the old version, and that's it.

Marius B. Kotsbak (mariusko) wrote :

Japp, that is what I meant by "or the opposite" above. Given the priority of people with new devices (that require e.g. QMI or new plugins) over regression affecting people with old devices. Similar to how e.g. libboost is packaged, with old versions available and even newer versions available in universe.

Changed in modemmanager (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) wrote :

There's a working patch to build gnome-control-center master without modemmanager on https://bugzilla.gnome.org/show_bug.cgi?id=688238 so I don't personally *need* this for raring but it might be nice to have if it's released as stable.

description: updated
Changed in modemmanager (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

0.7.991 is now released. It has build dependency on "dia" removed.

summary: - Please package modemmanager >= 0.7.990
+ Please package modemmanager >= 0.7.991
Logan Rosen (logan) wrote :

modemmanager 0.7.991 is now available in Debian experimental.

Changed in modemmanager (Debian):
status: New → Fix Released
Jerry Hicks (jerry-hicks) wrote :

ModemManager 1.0.0 is released.

Tim Lunn (darkxst) wrote :

We will need this updated for trusty.

gnome-shell requires network manager 0.9.8.8, which depends on this.
It also is needed for modem support in gnome-control-center

Changed in ubuntu-gnome:
milestone: none → trusty
importance: Undecided → Medium
status: New → Triaged
tags: added: trusty
Mantas Kriaučiūnas (mantas) wrote :

ModemManager 1.0.0 is in Ubuntu 14.04 proposed, see:
https://launchpad.net/ubuntu/+source/modemmanager/+changelog

summary: - Please package modemmanager >= 0.7.991
+ Please package modemmanager >= 1.0.0
Tim Lunn (darkxst) on 2014-02-24
Changed in ubuntu-gnome:
status: Triaged → Fix Released
Peter Meiser (meiser79) on 2014-04-14
Changed in modemmanager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.