modemmanager holds /dev/ttyACM0 open for a long time after connecting a nexus7

Bug #1105352 reported by Steve Langasek on 2013-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Mathieu Trudel-Lapierre
modemmanager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

When I connect my nexus7 to my raring desktop, modemmanager monopolizes it for half a minute before I'm able to use it:

Jan 25 10:36:22 virgil modem-manager[21336]: <info> (ttyACM0) opening serial port...
Jan 25 10:36:34 virgil modem-manager[21336]: <info> (ttyACM0) closing serial port...
Jan 25 10:36:34 virgil modem-manager[21336]: <info> (ttyACM0) serial port closed
Jan 25 10:36:34 virgil modem-manager[21336]: <info> (ttyACM0) opening serial port...
Jan 25 10:36:40 virgil modem-manager[21336]: <info> (ttyACM0) closing serial port...
Jan 25 10:36:40 virgil modem-manager[21336]: <info> (ttyACM0) serial port closed
Jan 25 10:36:40 virgil modem-manager[21336]: <info> (ttyACM0) opening serial port...
Jan 25 10:36:52 virgil modem-manager[21336]: <info> (ttyACM0) closing serial port...
Jan 25 10:36:52 virgil modem-manager[21336]: <info> (ttyACM0) serial port closed
Jan 25 10:36:52 virgil modem-manager[21336]: <info> (ttyACM0) opening serial port...
Jan 25 10:36:52 virgil modem-manager[21336]: <info> (ttyACM0) closing serial port...
Jan 25 10:36:52 virgil modem-manager[21336]: <info> (ttyACM0) serial port closed

Is there some way that modemmanager could detect more quickly that it's not talking to a modem?

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: modemmanager 0.6.0.0.really-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-22.34-generic 3.5.7.2
Uname: Linux 3.5.0-22-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
Date: Fri Jan 25 10:34:37 2013
InstallationDate: Installed on 2010-09-24 (854 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MarkForUpload: True
SourcePackage: modemmanager
UpgradeStatus: Upgraded to raring on 2013-01-25 (0 days ago)

Steve Langasek (vorlon) wrote :

Yes!

I had seen this, but then could not reproduce for some reason, and asked ogra about it, who said he didn't notice the problem.

I was already planning to blacklist it, there's a patch ready or already enough information to do so, with the advantage that it's a default USB ID used in the kernel and only for g_serial -- it should be safe to blacklist, and those using it and really expecting ModemManager to claim the device can easily drop the blacklist.

Triaged/High. It's kind of annoying for anyone playing with the nexus 7 images.

Changed in modemmanager (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in ubuntu-nexus7:
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in ubuntu-nexus7:
status: New → Triaged
importance: Undecided → High
Changed in modemmanager (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.6.0.0.really-0ubuntu3

---------------
modemmanager (0.6.0.0.really-0ubuntu3) raring; urgency=low

  * debian/patches/linux-default-usb-id.patch: blacklist the USB-Gadget default
    USB ID (the module actually allows you to set a custom one). The default ID
    is re-used by the Nexus 7 with Ubuntu images to expose a tty you can use
    to login to the system; but if it's not ignored ModemManager will
    harass it for some time trying to probe it. (LP: #1105352)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 28 Jan 2013 11:24:42 -0500

Changed in modemmanager (Ubuntu):
status: In Progress → Fix Released

AFAIK this got fixed with the change; let's just make sure it's still fixed with the switch from the gadget module to the other one for tethering and all...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers