Ericsson H5321gw's new USB ID

Bug #1057956 reported by Ari Sovijärvi on 2012-09-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Precise
Medium
Mathieu Trudel-Lapierre

Bug Description

There's a new version of Ericsson H5321gw 3G modem in the wild now. The previous one had USB ID of 0dbd:1919, the new version is 0dbd:1926. This new modem is found atleast in Lenovo Thinkpad L530 and T430 models.

The new one works when its ID is added to modem manager's database.

I'm attaching a small patch with the proper line added.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: modemmanager 0.5.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Uname: Linux 3.2.0-31-generic x86_64
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
Date: Fri Sep 28 11:01:42 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: modemmanager
UpgradeStatus: No upgrade log present (probably fresh install)

Ari Sovijärvi (apz-fi) wrote :

The attachment "Patch to add the new variant to database." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed

Confirming; patch is trivial so also a candidate to be included as SRU.

Changed in modemmanager (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in modemmanager (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.6.0.0-0ubuntu4

---------------
modemmanager (0.6.0.0-0ubuntu4) quantal; urgency=low

  * debian/patches/git_fall_back_to_csq_cind_8bd6903.patch: fallback to +CSQ if
    +CIND reports a signal level of 0. (LP: #1060831)
  * debian/patches/git_move_cind_process_func_1dee45e.patch: moving the CIND
    processing function down a bit to make the above change cleaner. Cherry-pick
    from upstream.
  * debian/patches/ericsson_h5321gw_usbids.patch: Add another known USB ID for
    the Ericsson H5321gw. (LP: #1057956)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 04 Oct 2012 16:38:54 -0400

Changed in modemmanager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers