FFE: ModemManager 0.6 in Quantal

Bug #1043486 reported by Mathieu Trudel-Lapierre on 2012-08-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Undecided
Unassigned

Bug Description

This FFE is for the upload of the release of ModemManager 0.6 in Quantal; we already have a snapshot of the 0.6 tree, but there has now been an official release.

The changes included since the last upload (I've anotated those that are not simply bugfix):

d14fb6f release: bump version to 0.6.0
d24085b release: update NEWS
c5fc283 sierra: fix CSQ handling on APP1 port
7a4bc7b sierra: allow users to help debug APP1 PPP capability *****
90e705f core: speed up QCDM probing a bit *****
94b37c4 sierra: use DHCP for the USB 305 (AT&T Lightning)
f845522 icera: allow implementors to supply custom call control commands *****
d3d98de icera: handle additional IPv4 configuration options *****
fb11f26 zte: handle Icera-based devics that use DHCP
f4cce13 gsm: if the generic CNMI request fails, try a Qualcomm-compatible one
f3a33ec sms: fix handling of 'data' property for multipart messages
cf172a9 sms: suppress warnings when reconstructing multipart messages
a682bd4 mbm: add Ericsson H5321gw (often found in Thinkpad X230) *****
9466c0a gsm: better handling of IMSI response
164da2f novatel: fix checking ERI for roaming/home decision
2bfd215 icera: be more paranoid about cleaning up connect operations
31b3c0f icera: retry configuring PDP context if it fails.
ecdb519 test: add utility to force a modem disconnect *****
4a78833 core: send State property change signals
082f683 sierra: fix detection of APP1 port
8f74fc2 core: add function to open probe ports without removing echo
6250314 sierra: fix detection of CDMA modems
6d4515c build: clean marshallers from git master
36ef5fa mbm: use +CFUN=4 for powering down
caaa9a8 qcdm: interpret MCC value from StatusSnapshot command *****
2810e99 sierra: implement band functions for Icera-based devices *****
48466e3 icera/samsung: implement supported bands *****
9dfe543 api: move SupportedBands property to Gsm.Network interface
1125f23 icera: add generic band handling functions *****
fdbab19 icera: add generic unlock retries checking *****
b6909ea huawei: limit the number of deferred tasks
181cf1e qcdm: get/set functions for hybrid preference *****
3025049 core: looser SMS message data entry regex
774fdf1 zte: add CFUN=4 power down property *****
bed0f62 zte: fix regex used when parsing allowed mode response
87cc698 longcheer: implement unlock retries checking *****
0c759d4 release: bump version to 0.5.995.0 (0.6-rc1)
0732259 release: update NEWS
4777f84 trivial: whitespace fixes
65f13f4 gsm: fix sending SMS messages on some modems and use PDU by default
3cea1b8 serial: fix AT port carriage return handling
e0246e0 hso: handle reading PIN/PUK retry counts *****
d69dbb3 decode: handle another UsbSnoop URB function *****
965b1ba gsm: ensure cleanup commands are sent when disabling
d09375e core: ignore unsupported qmi_wwan ports (rh #835153)
3270ecf gsm: emit usable reason code when disconnecting due to roaming
cae86b0 trivial: fix some build errors due to stricter warnings
73c9f36 build: update enable-more-warnings to allow yes/no/error
6705382 uml290: git-ignore generated program
9f6b6d6 huawei: ignore unsolicited ^CSNR messages
14dec9f huawei: don't set the GError if already set
08699ed huawei: avoid possible use of disposed memory
f4b5578 gsm: ensure PDU mode is set before falling back to PDU mode SMS
91e6cc9 decode: handle FUNCTION_CLASS_INTERFACE requests like CONTROL_TRANSFER
a75ed35 trivial: fix format string

Since there is at least one added test / command-line utility; I'll take this opportunity to make sure they are shipped in the package so that they are usable by users.

Stéphane Graber (stgraber) wrote :

Most of the new features seem to be either hardware enablement for pretty common hardware (lenovo x230) or making things more reliable and easy to debug. I'm not seeing any new user visible feature in that list or any obvious API change that'd be harmful at this point.

From the IRC discussion, this was test built on x86 and tested with the usual set of devices.

I'm granting the FFe, this will be uploaded after beta-1 but should be uploaded really right after it to leave us as much time as possible to catch any potential regression/new bug.

Changed in modemmanager (Ubuntu):
status: New → Confirmed
Changed in modemmanager (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.6.0.0-0ubuntu1

---------------
modemmanager (0.6.0.0-0ubuntu1) quantal; urgency=low

  * New upstream release. (LP: #1043486)
  * debian/patches/fix-format-string.patch: dropped, applied upstream.
  * debian/patches/qdl-blacklist.patch: replaced with installing the rules file
    directly to the udev rules directory.
  * debian/77-mm-qdl-device-blacklist.rules, debian/rules: additional rules
    file from the qdl-blacklist.patch; we now install it directly to the udev
    rules directory. This fixes daily builds.
  * debian/rules: build with --with-tests.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 07 Sep 2012 10:58:06 -0400

Changed in modemmanager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers