Can't connect with Huawei E173Eu-1 [12d1:14a8] (Natcom Haiti)

Bug #1030531 reported by Fabián Rodríguez on 2012-07-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Usb Modeswitch Data
Fix Released
Undecided
Unassigned
modemmanager (Ubuntu)
Undecided
Unassigned
usb-modeswitch-data (Ubuntu)
Undecided
Unassigned

Bug Description

When connecting this key in Ubuntu 12.04 LTS, it's not available in Network Manager.

This is from the Natcom Haiti provider. lsusb reports it as:
Bus 001 Device 017: ID 12d1:14a8 Huawei Technologies Co., Ltd.

A sticker under the key identifies it as E173Eu-1.

I added the following lines to /lib/udev/rules.d/40-usb_modeswitch.rules:

# Natcom Haiti (Huawei) E173Eu-1
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14a8", RUN+="usb_modeswitch '%b/%k'"

I also found guides indicating how to complete a workaround for this, but I lack the time to pursue this further.

http://www.linuxandlife.com/2012/03/make-usg-3g-work-on-arch-linux.html
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?p=4340

It also seems this was reported and fixed in Meego:
https://bugs.meego.com/show_bug.cgi?id=22878

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: modemmanager 0.5.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Sun Jul 29 14:46:01 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: modemmanager
UpgradeStatus: No upgrade log present (probably fresh install)

Fabián Rodríguez (magicfab) wrote :
summary: - Can't connect with Huawei E173Eu-1 [12d1:14a8] (Netcom Haiti)
+ Can't connect with Huawei E173Eu-1 [12d1:14a8] (Natcom Haiti)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed

Are you able to test this compiling a ModemManager 0.6 release, like the rc1 listed here?
https://mail.gnome.org/archives/networkmanager-list/2012-July/msg00120.html

Please provide a full content of /var/log/syslog so we can see at which layers the USB ID might be missing; if it needs to be added to the option driver (or another); what information it needs for usb-modeswitch (preferably along with /var/log/usb-modeswitch.log) and whether it gets seen by NetworkManager after that -- testing ModemManager 0.6 might indeed be useful at this point, but needs to be compiled manually.

Fabián Rodríguez (magicfab) wrote :

Attached syslog. I am requesting Canonical to provide a testing package, will provide feedback as possible. Interestingly the attached log shows the switch happens but the key still isn available in NM.

Fabián Rodríguez (magicfab) wrote :

I also found this blog mentioning a script that would enable this key:
http://ryanalberts.com/494/natcom-haiti-phone-setup/

This comment refers to http://www.sakis3g.org making this key work in Mint:
http://ryanalberts.com/494/natcom-haiti-phone-setup/comment-page-1/#comment-1059

I prefer advancing this bug and getting proper support in Ubuntu/Debian+derivatives for this key than running a script everytime, but the above links may have information that will help.

Fabián Rodríguez (magicfab) wrote :

Canonical support is suggesting the following potential solution:
# modprobe -r usbserial
# modprobe -v usbserial vendor=0x12d1 product=0x14a8

I lack the time to confirm this is a regression from 10.04 LTS or the above potential workaround, and I lack the connectivity to report this with the hardware in hand (I'll be leaving Haiti tomorrow).

Hopefully this report helps someone else achieve better results.

anacaona (anacaona) wrote :

Hello Fabián,

Thank you for filing the bug. I am also using the same model USB Modem with the the same ISP (Natcom). What is odd is that for at least the first month using Precise Pangolin it worked without a hitch. Since then I've been using Sakis3G as a workaround. This morning out of curiosity I researched the issue again and found this thread on configuring the modem via usb_modeswitch (which also worked for me for previous releases of Ubuntu, but not Precise!):

(Huawei) E173Eu-1
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=633

I haven't tried it yet, either, but hopefully it will come in useful for others.

Nadine

Changed in modemmanager (Ubuntu):
status: Confirmed → Invalid
Marius B. Kotsbak (mariusko) wrote :

It seems like we are missing the config file for this stick in usb-modeswitch-data. Upstream has not added it either. See forum post: http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=3&t=633
for what config file should be added, and place it in "/etc/usb_modeswitch.d/" (you should not need to chnage "/lib/udev/rules.d/40-usb_modeswitch.rules").

Marius B. Kotsbak (mariusko) wrote :
Fabián Rodríguez (magicfab) wrote :

I am unable to test this hardware as I don't have access to it anymore and I am not in Haiti (and won't in the short term). I hope other subscribers can help test the proposed workarounds and ensuing solution (if any).

Josua Dietze (digidietze) wrote :

It has been added to "usb-modeswitch-data-20120531", released on May 31st.
This version is in Debian "wheezy (testing)".

The current version is 20120815, which is in Debian "sid (unstable)".

This is the content of the respective config file ("12d1:14b5"):
----------------------------------

# Huawei E173 (Viettel 3G)

TargetVendor= 0x12d1
TargetProductList="14a8,14aa"

MessageContent="55534243123456780000000000000011062000000100000000000000000000"
----------------------------------

Note that "12d1:14a8" is the *modem* mode which does not need switching.

There is a hint in the syslog of post #5:

Jul 29 14:10:23 bertha usb_modeswitch: switching device 12d1:14b5 on 001/009
...
Jul 29 14:10:28 bertha usb_modeswitch: switched to 12d1:14a8 on 001/009

If the target ID is not contained in the config file, the ad-hoc binding to the "option" driver will fail. This is relevant if the "option" driver doesn't have the ID in its code yet.

Josua Dietze (digidietze) wrote :

BTW, the use of "usbserial" is not recommended for 3G modems.

To bind a driver to the modem, do this:

# modprobe option
# echo "12d1 14a8 ff" > /sys/bus/usb-serial/drivers/option1/new_id

Ubuntu Precise is still using data package release "20120120"; the modem ID was first reported in April.

Changed in usb-modeswitch-data:
status: New → Fix Released
Changed in usb-modeswitch-data (Ubuntu):
status: New → Confirmed
Marius B. Kotsbak (mariusko) wrote :

Ubuntu Quantal contains the 20120815 version, and I verified that the config in comment #12 is there, so this configuration just needs to be backported to Precise.

Fabian, could you please test the latest Ubuntu 12.10 live ISO image?

Changed in usb-modeswitch-data (Ubuntu):
status: Confirmed → Incomplete
Fabián Rodríguez (magicfab) wrote :

Marius, as I mentioned on #11 I don't have this hardware anymore so can't provide further feedback.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers