modem-manager crashed with SIGSEGV in g_match_info_unref()

Bug #1015328 reported by Fabián Núñez on 2012-06-19
102
This bug affects 15 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

I was AFK when the crash happened.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: modemmanager 0.6~git201203261122.16a0029-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.2.3-0ubuntu5
Architecture: amd64
CrashCounter: 1
Date: Tue Jun 19 17:54:21 2012
ExecutablePath: /usr/sbin/modem-manager
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: /usr/sbin/modem-manager
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
SegvAnalysis:
 Segfault happened at: 0x7f31bd6fdfc1 <g_match_info_unref+1>: mov (%rdi),%eax
 PC (0x7f31bd6fdfc1) ok
 source "(%rdi)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: modemmanager
StacktraceTop:
 g_match_info_unref () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 mm_gsm_parse_clck_response ()
 ?? ()
 ?? ()
 ?? ()
Title: modem-manager crashed with SIGSEGV in g_match_info_unref()
UpgradeStatus: Upgraded to quantal on 2012-06-15 (4 days ago)
UserGroups:

Fabián Núñez (fabian-nunez) wrote :

StacktraceTop:
 g_match_info_unref (match_info=0x4) at /build/buildd/glib2.0-2.33.1/./glib/gregex.c:555
 g_match_info_free (match_info=<optimized out>) at /build/buildd/glib2.0-2.33.1/./glib/gregex.c:579
 mm_gsm_parse_clck_response (reply=<optimized out>, enabled=enabled@entry=0x7ffff3f76e0c) at mm-modem-helpers.c:964
 get_facility_lock_state_done (port=port@entry=0xd12120, response=response@entry=0xd2bb40, error=error@entry=0x0, user_data=user_data@entry=0xd1b5c0) at mm-generic-gsm.c:1732
 handle_response (port=<optimized out>, response=0xd09070, error=0x0, callback=0x41e2c0 <get_facility_lock_state_done>, callback_data=0xd1b5c0) at mm-at-serial-port.c:134

Changed in modemmanager (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in modemmanager (Ubuntu):
status: New → Confirmed
visibility: private → public

This bug is fixed now in ModemManager MM_06 branch:

http://cgit.freedesktop.org/ModemManager/ModemManager/commit/?h=MM_06&id=318aaa02fa21321cd3493c7dd1ba8fa29e115064

MM_05 and git master are not affected.

To include the patch ASAP for Quantal.

Changed in modemmanager (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 0.6.0.0-0ubuntu3

---------------
modemmanager (0.6.0.0-0ubuntu3) quantal; urgency=low

  * debian/patches/git_lte_4g_parsing_90489ae.patch,
    debian/patches/git_lte_etsi_mode_0af47c7.patch: cherry-pick the patches
    to properly handle and display LTE/4G technology modes. (LP: #1044744)
  * debian/patches/git_lp1015328_segfault_in_clck_parser_318aaa0.patch: avoid
    crashing when parsing +CLCK responses. (LP: #1015328)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 25 Sep 2012 16:51:16 -0400

Changed in modemmanager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers