Please merge modconf 0.3.9 (universe) from Debian unstable (main).

Bug #300547 reported by Nick Ellery on 2008-11-21
4
Affects Status Importance Assigned to Milestone
modconf (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge modconf 0.3.9 (universe) from Debian unstable (main).

modconf (0.3.9) unstable; urgency=low

  * debian/control:
    + Bump kernel dependency to 2.6.26
  * debian/rules:
    + Do not try to apply Debian patches.
      linux-source-* contains those already.
    + Reduce with help of dh

 -- Frank Lichtenheld <email address hidden> Thu, 31 Jul 2008 04:15:52 +0200

modconf (0.3.8) unstable; urgency=low

  * modconf, modules/*:
    + Fix bashisms of form "local foo=bar" (Closes: #471877)
  * Makefile:
    + Fix handling of Module-HOWTO file
  * debian/control:
    + Bump Standards-Version to 3.8.0 (no changes)

 -- Frank Lichtenheld <email address hidden> Tue, 22 Jul 2008 03:07:05 +0200

Related branches

Daniel Holbach (dholbach) wrote :

Did you try to test-build this? There's no linux-source-2.6.26 in jaunty.

Nick Ellery (nick.ellery) wrote :

Ugh, my apologies on this, I cannot believe I forgot to do that. I assume then, that this requires a merge. I'll submit a debdiff for this.

Again, my apologies on this mistake, I will not let that happen again.

Nick

description: updated
Nick Ellery (nick.ellery) wrote :

Hi,

I am not able to get the updated version to build properly, as well as the old version, though it is shown as successfully built. I'll attach the debdiff's, in case you have any ideas as to what I am doing incorrectly.

Daniel Holbach (dholbach) wrote :

As discussed on IRC, this needs further testing.

Thanks for taking care of it.

Changed in modconf:
assignee: nobody → nick.ellery
status: New → In Progress
Nick Ellery (nick.ellery) wrote :

Hi,

Here's the debdiffs with the discussed changes.

Thanks,
Nick

Changed in modconf:
assignee: nick.ellery → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

 - I'm not sure what "Do not try to apply Debian kernel patches before building (fixes FTBFS)." means? Which change does it relate to?
 - Did you try using modconf afterwards? Does it work?
 - What is the "cd build/linux-source-$(version26)" change for?

Nick Ellery (nick.ellery) wrote :

Hi Daniel,

- Not sure why I put that part in the changelog entry, but the same change was made in Ubuntu, so I've removed that.
- I've tested this, and it appears to run properly.
- The "cd build/linux-source-$(version26)" change was Ubuntu-specific, then carried over to Debian later, where that line was removed. I went with the Ubuntu version, but since it was removed in Debian, it should probably be synced with it.

I'm attaching a new debdiff with the mentioned changes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modconf - 0.3.9ubuntu1

---------------
modconf (0.3.9ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes (LP: #300547):
  * Use build-dep-indep on linux-source-2.6.27 rather than linux-source-2.6.26
    (Changed from 2.6.24).

modconf (0.3.9) unstable; urgency=low

  * debian/control:
    + Bump kernel dependency to 2.6.26
  * debian/rules:
    + Do not try to apply Debian patches.
      linux-source-* contains those already.
    + Reduce with help of dh

modconf (0.3.8) unstable; urgency=low

  * modconf, modules/*:
    + Fix bashisms of form "local foo=bar" (Closes: #471877)
  * Makefile:
    + Fix handling of Module-HOWTO file
  * debian/control:
    + Bump Standards-Version to 3.8.0 (no changes)

 -- Nick Ellery <email address hidden> Sun, 23 Nov 2008 22:57:33 -0800

Changed in modconf:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers