Wrong symlink in libapache2-mod-wsgi-py3 and incompatible with python3.2

Bug #749720 reported by Tobias Bradtke on 2011-04-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mod-wsgi (Ubuntu)
Medium
James Page

Bug Description

I just installed libapache2-mod-wsgi-py3. Apache gave an error after the attempt to restart:

# service apache2 restart
apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/wsgi.load: Cannot load /usr/lib/apache2/modules/mod_wsgi.so into server: /usr/lib/apache2/modules/mod_wsgi.so: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

# ls /usr/lib/apache2/modules/mod_wsgi.so* -l
lrwxrwxrwx 1 root root 17 2011-04-03 18:54 /usr/lib/apache2/modules/mod_wsgi.so -> mod_wsgi.so-3.2-1
-rw-r--r-- 1 root root 156320 2010-12-03 19:59 /usr/lib/apache2/modules/mod_wsgi.so-3.1
-rw-r--r-- 1 root root 156320 2010-12-03 19:59 /usr/lib/apache2/modules/mod_wsgi.so-3.2

Attempt to fix:
# cp -sf /usr/lib/apache2/modules/mod_wsgi.so{-3.2,}

Now i get:
# service apache2 restart
apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/wsgi.load: Cannot load /usr/lib/apache2/modules/mod_wsgi.so into server: /usr/lib/apache2/modules/mod_wsgi.so: undefined symbol: PyCObject_FromVoidPtr
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

Related branches

Tobias Bradtke (webwurst) wrote :

Ok, i can get it working with mod_wsgi.so-3.1

# cp -sf /usr/lib/apache2/modules/mod_wsgi.so{-3.1,}

# service apache2 restart
 * Restarting web server apache2
 ... waiting . ...done.

description: updated
James Page (james-page) on 2011-04-07
tags: added: natty
James Page (james-page) wrote :

Confirmed on up-to-date natty instance:

jamespage@natty-jenkins:~$ sudo apachectl configtest
apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/wsgi.load: Cannot load /usr/lib/apache2/modules/mod_wsgi.so into server: /usr/lib/apache2/modules/mod_wsgi.so: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
jamespage@natty-jenkins:~$

James Page (james-page) wrote :

the postinst script that creates the symbolic link for mod_wsgi.so does not correctly parse the default python3 package installation and hence the symbolic link is invalid.

Changed in mod-wsgi (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
James Page (james-page) wrote :

The PyCObject_FromVoidPtr is no longer present in 3.2 - see [0]

It looks like a fix is available in upstream trunk but its not been released yet (see [1])

[0] http://stackoverflow.com/questions/5544756/mod-wsgi-archlinux-python-3-2-problem
[1] http://code.google.com/p/modwsgi/source/browse/trunk/mod_wsgi/mod_wsgi.c

Changed in mod-wsgi (Ubuntu):
assignee: nobody → James Page (james-page)
summary: - Wrong symlink in libapache2-mod-wsgi-py3
+ Wrong symlink in libapache2-mod-wsgi-py3 and incompatible with python3.2
James Page (james-page) wrote :

I'll see if I can pull a patch out of upstream trunk.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mod-wsgi - 3.3-2ubuntu1

---------------
mod-wsgi (3.3-2ubuntu1) natty; urgency=low

  * Updates to support python >= 3.2 (LP: #749720):
    - Picked patch to support python >= 3.2 from upstream trunk.
    - Fixed libapache2-mod-wsgi-py3.postinst to correctly detect
      default python 3 version.
  * Converted to source/format "3.0 (quilt)" and updated debhelper
    version (>= 7.0.15).
 -- James Page <email address hidden> Thu, 07 Apr 2011 11:25:17 +0100

Changed in mod-wsgi (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers