proxy_html is missing libxml2.so.2 (AMD64 and i386)

Bug #964397 reported by Pivert on 2012-03-25
116
This bug affects 21 people
Affects Status Importance Assigned to Milestone
mod-proxy-html (Debian)
Fix Released
Unknown
mod-proxy-html (Ubuntu)
Undecided
Unassigned

Bug Description

After installing and enabling proxy_html (libapache2-mod-proxy-html) on a fresh 12.04 server install, we get the following error :

root@herbert:/etc/apache2# /etc/init.d/apache2 restart
apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/proxy_html.load: Cannot load /usr/lib/libxml2.so.2 into server: /usr/lib/libxml2.so.2: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

libxml2 is installed, but as on amd64 architecture, the libxml2 file is in :
/usr/lib/x86_64-linux-gnu/libxml2.so.2

The solution consists of changing in /etc/apache2/mods-available/proxy_html.load
LoadFile /usr/lib/libxml2.so.2
into :
LoadFile /usr/lib/x86_64-linux-gnu/libxml2.so.2

summary: - proxy_html is missing libxml2.so.2
+ proxy_html is missing libxml2.so.2 (AMD64)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mod-proxy-html (Ubuntu):
status: New → Confirmed
mdmcginn (mcweb) wrote :

My solution was to change the line to:
LoadFile /usr/lib/i386-linux-gnu/libxml2.so.2

Carles Oriol (carlesoriol) wrote :

It does not work for me:

apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/mods-enabled/proxy_html.load: Cannot load /usr/lib/i386-linux-gnu/libxml2.so.2 into server: /usr/lib/i386-linux-gnu/libxml2.so.2: wrong ELF class: ELFCLASS32

zemudkram (zemudkram) wrote :

navigating to /usr/lib and issuing a sudo ln -s /usr/lib/x86_64-linux-gnu/libxml2.so.2 libxml2.so.2 fixed this for me, and for anything else that will rely on libxml2 as well. Maybe this is an issue with libxml, and not mod-proxy-html?

humboink (humboink) on 2012-04-26
summary: - proxy_html is missing libxml2.so.2 (AMD64)
+ proxy_html is missing libxml2.so.2 (AMD64 and i386)
Komet (ewg118) wrote :

Confirming that zemudkram's solution fixed the problem for me.

Changed in mod-proxy-html (Debian):
status: Unknown → New
Aron Xu (happyaron) on 2012-04-29
tags: added: libxml2-ma
Changed in mod-proxy-html (Debian):
status: New → Fix Committed
Mr Raosaheb (patilraosaheb) wrote :

What is the process to overcome this bug.. I need to install Nagios 3 and giving me error
apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/proxy_html.load: Cannot load /usr/lib/libxml2.so.2 into server: /usr/lib/libxml2.so.2: cannot open shared object file: No such file or directory
Action 'configtest' failed.

Changed in mod-proxy-html (Ubuntu):
status: Confirmed → Opinion
Changed in mod-proxy-html (Debian):
status: Fix Committed → Fix Released
Stu (stuzart) on 2012-07-06
Changed in mod-proxy-html (Ubuntu):
status: Opinion → Confirmed

any chance this could get fixed in ubuntu precise? A fix was released for debian about 6 months ago.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.