libxml.so.2 not symlinked into /usr/lib

Bug #1018136 reported by Jim Salter on 2012-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mod-proxy-html (Debian)
Unknown
Unknown
mod-proxy-html (Ubuntu)
Undecided
Unassigned

Bug Description

proxy_html.load looks for libxml.so.2 in /usr/lib, but it's not there - it's in /usr/lib/x86_64-linux-gnu/libxml.so.2.

root@webserver:/var/log/apache2# /etc/init.d/apache2 start
 * Starting web server apache2 apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/proxy_html.load: Cannot load /usr/lib/libxml2.so.2 into server: /usr/lib/libxml2.so.2: cannot open shared object file: No such file or directory
Action 'start' failed.
The Apache error log may have more information.
                                                                                        [fail]
root@webserver:/var/log/apache2# locate libxml2.so.2
/usr/lib/x86_64-linux-gnu/libxml2.so.2
/usr/lib/x86_64-linux-gnu/libxml2.so.2.7.8
root@webserver:/var/log/apache2# ln -s /usr/lib/x86_64-linux-gnu/libxml2.so.2 /usr/lib/libxml2.so.2
root@webserver:/var/log/apache2# /etc/init.d/apache2 start
 * Starting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
                                                                                          [ OK ]
root@webserver:/var/log/apache2#

Jim Salter (jrssnet) wrote :

note: I've seen this on every Ubuntu Precise server I've installed libapache2-mod-proxy-html, which is six-ish - this is just the first moment I've found time to file the bug. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.