libapache2-mod-mono and libapache2-mod-php are mutually exclusive

Bug #227781 reported by Andrei Tanas on 2008-05-07
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mod-mono (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libapache2-mod-mono

In Ubuntu 8.04, libapache2-mod-mono depends on apache2-mpm-worker, while libapache2-mod-php5 depends on apache2-mpm-prefork, which makes mono and php5 mutually exclusive.
I have just upgraded from 7.04, where this was never a problem - I used to run successfully php5 and asp.net 2.0 web servers simultaneously.

Andrei Tanas (andrei-tanas) wrote :

libapache2-mod-mono:
  Installed: (none)
  Candidate: 1.2.5-2
  Version table:
     1.2.5-2 0
        500 http://archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status

libapache2-mod-php5:
  Installed: 5.2.4-2ubuntu5
  Candidate: 5.2.4-2ubuntu5
  Version table:
 *** 5.2.4-2ubuntu5 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

If mod-php5 is not thread-safe and has to be built against prefork worker, then there should be prefork version of mod-mono too, to make it possible to run both at the same time.

Mike Taylor (miketay) wrote :

I just ran into this bug, it's a big problem not being able to run php and mono at the same time.

Daniel James (daniel-netbreeze) wrote :

Shouldn't libapache2-mod-mono allow us to install any apache?

Adam Conrad (adconrad) wrote :

From the Debian changelog:

  * Replaced build-dependency apache2-dev || apache2-threaded-dev with only
    apache2-threaded-dev.
  * Replaced apache2 binary dependency with apache2-mpm-worker, as the built
    module for threaded apache will not work with prefork apache.

This is a blatant lie and misunderstanding of the apache2 headers. He was *always* building against threaded headers (apache2-dev pulls in threaded headers), so the first change made no difference whatsoever and, if the package always worked with -prefork before (which is should have, and people claim it did), it still would.

Backing out the second change would be a pretty non-intrusive thing, pretty much a no-brainer for Intrepid, and probably a good idea for a Hardy SRU as well, assuming this module actually has a userbase of any sort.

directhex (directhex) wrote :

Fixed in 1.9-1 (Intrepid). If the problem is urgent, backport packages for Hardy are part of my PPA

Changed in mod-mono:
status: New → Fix Released
graylion (graylion) wrote :

I am going to need it in hardy as i am not going to migrate my server to Intrepid

Dave Morley (raceprouk) wrote :

You could use XSP2 as the Mono server, and configure Apache to proxy to it. I've done that on my laptop, so I can help with the config directives ;)

graylion (graylion) wrote :

that would involve me having a productive XP box ...

no the aim is to run iFolder on my universal *doitallserver" and I'll happily wait for the backport. I am just saying that it needs to be available in the LTS version, as that is the one that people will be running.

Dave Morley (raceprouk) wrote :

sudo apt-get install xsp2 ;)

Andrei Tanas (andrei-tanas) wrote :

Apache proxy is garbage - it removes the !DOCTYPE declaration from html that gets sent through it and this makes browsers switch to "quirks" mode, breaking expected page layout.

Dave Morley (raceprouk) wrote :

It must be your set up, as the !DOCTYPEs are preserved on mine.

graylion (graylion) wrote :

interesting idea ...

Matt Austin (mattaustin) wrote :

I would also like to see an updated package in hardy-backports, as I would like to stick with an LTS edition on my server.

I am interested also in this being backported to hardy. I have clients asking for mod_mono, and I cannot enable it for them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers