Crash when logging in

Bug #364581 reported by Colin Leroy on 2009-04-21
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
mod-auth-mysql (Debian)
Fix Released
Unknown
mod-auth-mysql (Ubuntu)
Low
Unassigned
Jaunty
Medium
Chuck Short
Karmic
Medium
Chuck Short
Lucid
Low
Unassigned

Bug Description

When trying to logging via mod-auth-mysql on an uptodate Jaunty install, I get a segmentation fault:

root@colin:~# export APACHE_RUN_USER=www-data
root@colin:~# export APACHE_RUN_GROUP=www-data
root@colin:~# gdb /usr/sbin/apache2
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
(no debugging symbols found)
(gdb) run -X
#0 0x00007f30db318c60 in strlen () from /lib/libc.so.6
#1 0x00007f30da52f4ec in mysql_query () from /usr/lib/libmysqlclient_r.so.15
#2 0x00007f30d6af1219 in ?? () from /usr/lib/apache2/modules/mod_auth_mysql.so
#3 0x00007f30d6af17ea in ?? () from /usr/lib/apache2/modules/mod_auth_mysql.so
#4 0x00007f30d6af1fec in mysql_authenticate_basic_user () from /usr/lib/apache2/modules/mod_auth_mysql.so
#5 0x00007f30dc104143 in ap_run_check_user_id () from /usr/sbin/apache2
#6 0x00007f30dc106428 in ap_process_request_internal () from /usr/sbin/apache2
#7 0x00007f30dc11a588 in ap_process_request () from /usr/sbin/apache2
#8 0x00007f30dc1173d8 in ?? () from /usr/sbin/apache2
#9 0x00007f30dc110c63 in ap_run_process_connection () from /usr/sbin/apache2
#10 0x00007f30dc11ef06 in ?? () from /usr/sbin/apache2
#11 0x00007f30dc11f236 in ?? () from /usr/sbin/apache2
#12 0x00007f30dc11fd6d in ap_mpm_run () from /usr/sbin/apache2
#13 0x00007f30dc0f560d in main () from /usr/sbin/apache2

The .htacccess file:
AuthType Basic
AuthMySQL_User bugs
AuthMySQL_Password ******
AuthMySQL_DB bugs
AuthMySQL_Host server.localdomain
Auth_MySQL_Password_Table profiles
AuthMySQL_Username_Field login_name
AuthMySQL_Password_Field cryptpassword
Auth_MySQL_Encryption_Types Crypt
AuthBasicAuthoritative Off
AuthUserFile /dev/null

This configuration fetches a login/password from a distant Bugzilla on another server.

Related branches

Colin Leroy (colin-colino) wrote :

This is this bug:

http://<email address hidden>/11291843.html

Or http://groups.google.com/group/ubuntu-users-archive/browse_thread/thread/9e03284b53639844/f00fa4582ef139da
I didn't have time to raise a bug using launchpad at the time, but I can do it now if that's a different issue from this one.

Colin, do you mean that you applied the patch there and it fixed your problem?

Here is the patch attached. Could anybody please do something about it? At the moment, I have to reapply the patch after every update.

Colin Leroy (colin-colino) wrote :

Stephane, yes, this is the same bug, and the same patch I use to fix this bug.

Scottix (scottix) wrote :

I can confirm this error as well. It allows me to login then the page fails.

AuthName "Login"
AuthType Basic
AuthBasicAuthoritative off
AuthMySQL on
AuthMySQL_Authoritative on
AuthMySQL_Host localhost
AuthMySQL_User ****
AuthMySQL_Password ****
AuthMySQL_DB readspeed
AuthMySQL_Password_Table users
AuthMySQL_Username_Field username
AuthMySQL_Password_Field password
AuthMySQL_Empty_Passwords off
AuthMySQL_Encryption_Types PHP_MD5
AuthUserFile /dev/null
require valid-user

[Tue Jul 21 15:17:09 2009] [notice] child pid 21856 exit signal Segmentation fault (11)

Thomas Seliger (neovatar) wrote :

I also had this Bug under Ubuntu Server 8.04 64bit and can confirm that Stephane Chazelas fixes the issue.

Chuck Short (zulcss) wrote :

Which version of apache are you using (output of dpkg -l | grep apache will do)?

Thanks
chuck

Changed in mod-auth-mysql (Ubuntu):
status: New → Incomplete

2009-10-05 14:02:29 -0000, Chuck Short:
> Which version of apache are you using (output of dpkg -l | grep apache
> will do)?
[...]

Any version of apache will do, the bug is not with apache.

ii apache2-doc 2.2.11-2ubuntu2.3 Apache HTTP Server documentation
ii apache2-mpm-itk 2.2.6-02-1build4.3 multiuser MPM for Apache 2.2
ii apache2-src 2.2.11-2ubuntu2.3 Apache source code
ii apache2-utils 2.2.11-2ubuntu2.3 utility programs for webservers
ii apache2.2-common 2.2.11-2ubuntu2.3 Apache HTTP Server common files
ii libapache-htpasswd-perl 1.8-0.1 Manage Unix crypt-style password file
ii libapache2-mod-auth-mysql 4.3.9-11 Apache 2 module for MySQL authentication
ii libapache2-mod-auth-pam 1.1.1-6.1ubuntu1 module for Apache2 which authenticate using
ii libapache2-mod-auth-sys-group 1.1.1-6.1ubuntu1 Module for Apache2 which checks user against
ii libapache2-mod-perl2 2.0.4-5ubuntu1 Integration of perl with the Apache2 web ser
ii libapache2-mod-php5 5.2.6.dfsg.1-3ubuntu4.2 server-side, HTML-embedded scripting languag
ii libapache2-mod-proxy-html 3.0.1-1 Apache2 filter module for HTML links rewriti
ii libapache2-reload-perl 0.10-2 Reload Perl modules when changed on disk
ii libapache2-svn 1.5.4dfsg1-1ubuntu2.1 Subversion server modules for Apache
ii libapache2-webauth 3.6.0-1 Apache 2 modules for WebAuth authentication
ii libapache2-webkdc 3.6.0-1 Apache 2 modules for a WebAuth authenticatio

Attached is an updated version of the diff that fixes the other
compiler warnings.

IIRC, I've provided with an explanation of the actual bug, it is
a bug that occurs on 64bit systems. Please let me know if it's
not clear enough.

Cheers,
Stephane

Chuck Short (zulcss) wrote :

Thanks

You have provided the information that I have needed.

Regards
chuck

Changed in mod-auth-mysql (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged

2009-10-13 20:05:29 -0000, Chuck Short:
[...]
> You have provided the information that I have needed.
>
> Regards
> chuck
>
> ** Changed in: mod-auth-mysql (Ubuntu)
> Importance: Undecided => Low
[...]

Hi Chunk,

Why low? It crashes on 64bit machines, it's not really benign,
is it? And the fix is the adding of a missing "#include", which
can't do much harm.

regards,
Stephane

JanBrinkmann (jbrinkmann) wrote :

The problem was fixed in a new debian version (see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542007) . Attached is a debdiff against the new debian version. Includes the fix from Matthias Gug ( * debian/control: Change build dependencies to MySQL 5.1. ). The relevant changelog excerpt:

  * Merged new debian version (fixes LP: #364581). Remaining changes:
    - debian/control: Change build dependencies to MySQL 5.1.
    - bumped standards version

Changed in mod-auth-mysql (Ubuntu):
status: Triaged → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mod-auth-mysql - 4.3.9-12ubuntu1

---------------
mod-auth-mysql (4.3.9-12ubuntu1) lucid; urgency=low

  * Merged new debian version (fixes LP: #364581). Remaining changes:
    - debian/control: Change build dependencies to MySQL 5.1.
    - bumped standards version.
 -- Jan Brinkmann <email address hidden> Thu, 28 Jan 2010 14:27:45 +0100

Changed in mod-auth-mysql (Ubuntu Lucid):
status: Confirmed → Fix Released
Chuck Short (zulcss) on 2010-03-19
Changed in mod-auth-mysql (Ubuntu Karmic):
status: New → In Progress
Changed in mod-auth-mysql (Ubuntu Jaunty):
status: New → In Progress
importance: Undecided → Medium
Changed in mod-auth-mysql (Ubuntu Karmic):
importance: Undecided → Medium
Changed in mod-auth-mysql (Ubuntu Jaunty):
assignee: nobody → Chuck Short (zulcss)
Changed in mod-auth-mysql (Ubuntu Karmic):
assignee: nobody → Chuck Short (zulcss)

This is already fixed in karmic according to the changelog.

Regards
chuck

summary: - Crash when logging in
+ [SRU] Crash when logging in
Chuck Short (zulcss) wrote :

Rejected as a candidate for SRU.

Regards
chuck

Changed in mod-auth-mysql (Ubuntu Jaunty):
status: In Progress → Won't Fix
Chuck Short (zulcss) on 2010-03-19
summary: - [SRU] Crash when logging in
+ Crash when logging in
Chuck Short (zulcss) on 2010-06-22
Changed in mod-auth-mysql (Ubuntu Karmic):
status: In Progress → Won't Fix
Changed in mod-auth-mysql (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.