Segfault in v4.3.9-9 with mod_dav_svn

Bug #357799 reported by Sean Edwards on 2009-04-08
This bug report is a duplicate of:  Bug #364581: Crash when logging in. Edit Remove
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mod-auth-mysql (Ubuntu)
Undecided
Unassigned

Bug Description

I am attempting to configure Apache's mod-auth-mysql to use the credentials of an installation of the Drupal CMS to protect a path to be served by mod_dav_svn, but there seem to be a number of problems with the module. Here is the relevant parts of my mod_dav_svn configuration:

  AuthType Basic
  AuthName "SVN"

  Auth_MySQL On
  Auth_MySQL_Host localhost
  Auth_MySQL_User *****
  Auth_MySQL_Password *****
  Auth_MySQL_DB drupal
  Auth_MySQL_Password_Table dp_users
  Auth_MySQL_Username_Field name
  Auth_MySQL_Password_Field pass
  Auth_MySQL_Encryption_Types PHP_MD5
  Auth_MySQL_Empty_Passwords off

  AuthBasicAuthoritative Off
  Auth_MySQL_Authoritative on

  require valid-user

The line that causes problems seems to be "AuthBasicAuthoritative Off". If that line is absent, Apache attempts to use basic authentication and when I attempt to log in I get the following error in /var/log/apache2/error.log:

  [Wed Apr 08 14:05:29 2009] [error] Internal error: pcfg_openfile() called with NULL filename
  [Wed Apr 08 14:05:29 2009] [error] [client 24.97.63.58] (9)Bad file descriptor: Could not open password file: (null)

A google search reveals that this error comes in not specifying a user file for the basic authentication method (which shouldn't be a problem, as I'm not using the basic authentication method)

If that line is present, the error changes to the following:

  [Wed Apr 08 15:40:02 2009] [notice] child pid 19095 exit signal Segmentation fault (11)

The contents of /etc/init.d/apache2/mods-enabled/ are:

 alias.conf
 alias.load
 auth_basic.load
 auth_mysql.load
 authn_file.load
 authz_default.load
 authz_groupfile.load
 authz_host.load
 authz_user.load
 autoindex.conf
 autoindex.load
 cgi.load
 dav.load
 dav_svn.conf
 dav_svn.load
 deflate.conf
 deflate.load
 dir.conf
 dir.load
 env.load
 mime.conf
 mime.load
 negotiation.conf
 negotiation.load
 php5.conf
 php5.load
 setenvif.conf
 setenvif.load
 status.conf
 status.load

Could the issue be an incompatibility with libmysqlclient in php5's mysql module (which I have active) vs. mod_auth_mysql?

depe (depe-ubuntu) wrote :

I had a similar problem using 9.04 64bits server edition.

AuthBasicAuthoritative Off was present, so authentication was really made with MySQL data.

I could enter login and password, but then I got a blank page and /var/log/apache2/error.log reported child pid <xxxx> exit signal Segmentation fault (11)

I found interesting info on ubuntu lists: https://lists.ubuntu.com/archives/ubuntu-users/2009-January/172447.html

After switching back to 9.04 32bits, problem was solved (I used the same configuration file in both cases)

It seems that there is still a problem with libapache2-mod-auth-mysql 4.3.9-11, which prevents me from using the 64bits edition

Willie Gillespie (wgillespie) wrote :

Doesn't have to be a directory served by mod_dav_svn. In my experience, it can be any directory -- and it doesn't matter whether it is a plain HTML file, or a PHP file it will be serving. I am (now) using 9.04 64-bit Desktop edition and seeing this error. The same configuration file worked previously on the 8.04 LTS Desktop edition (still 64-bit). Might be interesting to see what Apache2/auth_mysql versions changed between those.

There seems to be a related or duplicate bug <https://bugs.launchpad.net/ubuntu/+source/mod-auth-mysql/+bug/364581> that mentions the same fix depe links to above: <http://launchpadlibrarian.net/26316509/mod-auth-mysql.diff>.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers