Ubuntu

libapache2-mod-auth-mysql is missing in 13.10 amd64

Reported by Tobias Leich on 2013-10-22
130
This bug affects 24 people
Affects Status Importance Assigned to Milestone
mod-auth-mysql (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
Trusty
High
Unassigned

Bug Description

When I search for "libapache2-mod-auth-mysql" I get two results listed:

a) libapache2-mod-auth-mysql
b) libapache2-mod-auth-mysql:i386

When I click on the "more information"-button next to one of them, it states:

"Not found. There is no such package »libapache2-mod-auth-mysql« in your current software sources.".
(Translated from german.)

That might even be the reason the update from 13.04 didn't finished yesterday, because I use/used this package in my apacha2's vhost config. So apaches configure check stumbeld upon invalid configuration, and the installation process stopped.

This page btw states that there is such a package:
https://launchpad.net/ubuntu/saucy/+package/libapache2-mod-auth-mysql

--
lsb_release -rd
Description: Ubuntu 13.10
Release: 13.10

LC_ALL=C apt-cache policy libapache2-mod-auth-mysql
libapache2-mod-auth-mysql:
  Installed: (none)
  Candidate: (none)
  Version table:
     4.3.9-13.1ubuntu1 0
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: software-center 13.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
Date: Tue Oct 22 09:29:26 2013
ExecutablePath: /usr/share/software-center/software-center
InstallationDate: Installed on 2011-11-10 (711 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to saucy on 2013-10-21 (0 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
John Crawford (jcrawford83) wrote :

Has there been an update on this? As can been seen here: http://askubuntu.com/questions/365061/ubuntu-13-10-gives-package-libapache2-mod-auth-mysql-has-no-installation-cand in just 3 days, over 100 people have looked at this issue... as such it is impacting a lot of people that are trying to set up a LAMP environment using Ubuntu 13.10

Flavio Aiello (faiello-s) wrote :

Same problem on my server. Cannot setup lamp and I need it urgently.

Case (muzzwood) wrote :

Also affecting me. Need this asap

Flavio Aiello (faiello-s) wrote :

In the meantime I suggest to switch to dbd as follows instead:

# mod_dbd configuration
DBDriver mysql
DBDParams "dbname=vmail user=? password=?"

DBDMin 4
DBDKeep 8
DBDMax 20
DBDExptime 300

<Directory /usr/share/postfix-cluebringer-webui/webui/>
    DirectoryIndex index.php
    Options ExecCGI
    Order allow,deny
    allow from all

    AuthType Basic
    AuthName "Authorization Required"
    AuthBasicProvider dbd

    # core authorization configuration
    Require valid-user

    # mod_authn_dbd SQL query to authenticate a user
    AuthDBDUserPWQuery "SELECT password FROM mailbox WHERE username = %s"

</Directory>

Johan (kohan) on 2013-11-12
no longer affects: software-center
John Crawford (jcrawford83) wrote :

I see that there is still no update to this. I do find it puzzling that with so many people using a LAMP environment this is still not fixed on the latest issue of Ubuntu.

Sidney akers (sidneyaks) wrote :

This bug also affects me, as I require this to run the lamp stack on my laptop for testing. As a workaround until it is fixed, I wound up installing lamp in a VM running raring server.

nasir khan saikat (nasir8891) wrote :

this bug was confirmed on 2013-10-24 and no update yet !!!

dgoosens (dgoosens) wrote :

hi,
this is a vital package for me and my usage of Ubuntu...
is there any news about this ?
thanks
dGo

John Crawford (jcrawford83) wrote :

ok, so in just a few months since I posted my question about this bug, there has now been over 2500 different people viewing it. http://askubuntu.com/questions/365061/ubuntu-13-10-gives-package-libapache2-mod-auth-mysql-has-no-installation-cand This is obviously an issue for a lot of people need this to be fixed. Can we at least have some sort of update to it?

Roger Lanoue Jr (m-roger) wrote :

I am also having the same problem with a LAMP install in 13.10. What in the world is going on in this day and age.

WHEN WILL A SOLUTION OR ANSWER GIVE US DIRECTION ON WHAT TO DO WITH LAMP INSTALL ON 13.10.

Thanks

Hitesh Pachpor (hiteshspac) wrote :

Ubuntu without LAMP environment is handicapped! Please fix this ASAP!!

Shane O'Sullivan (hitsuji) wrote :

mod_auth_mysql is not compatible with apache 2.4 and it would appear the upstream developer has no interest in currently updating it to apache 2.4 and may no longer be maintained:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666826

I would go with faiello-s 's suggestion and move on to another solution such as his suggested mod_dbd

affects: software-center (Ubuntu) → mod-auth-mysql (Ubuntu)
Matthias Klose (doko) on 2014-01-20
Changed in mod-auth-mysql (Ubuntu Saucy):
importance: Undecided → High
status: New → Confirmed
Changed in mod-auth-mysql (Ubuntu Trusty):
importance: Undecided → High
milestone: none → ubuntu-14.01
information type: Public → Public Security
makitso (makitso) wrote :

So, does anyone know where this is headed? Will there be a LAMP install process for 14.04? Will Faiello's workaround (not sure where the code goes ) be the official process?

Robie Basak (racb) wrote :

This is clearly not a security issue. Please don't mess with bug statuses like this without providing an explanation.

information type: Public Security → Public
Robie Basak (racb) wrote :

I have confirmed what Shane described above. It seems that upstream are inactive. I haven't been able to find any sign that upstream have ported this module to the Apache 2.4 API, which is a requirement for making this work with Apache 2.4. The package has been removed from Debian testing for this reason already. I presume that all other distributions will follow suit as they upgrade to Apache 2.4.

Thus, I will file a bug to have this package permanently removed from Ubuntu.

If someone ports the upstream code to Apache 2.4, then this situation could change. However, feature freeze is coming up, so it seems unlikely to me that this will make Trusty.

I get the impression that many people have ended up here because they want to install a LAMP stack, since some instructions somewhere state that this package should be installed to get a LAMP stack. This is incorrect. This package is only required for Apache authentication against MySQL (as opposed to doing it at the web app end, which is far more common). It appears to me that there are cargo culted instructions floating around the Internet.

Since there is nothing that can be done about this situation in Ubuntu, I'm marking this bug Won't Fix.

Changed in mod-auth-mysql (Ubuntu Saucy):
status: Confirmed → Won't Fix
Changed in mod-auth-mysql (Ubuntu Trusty):
status: Confirmed → Won't Fix
Robie Basak (racb) wrote :

I have filed bug 1278995 for removal.

Changed in mod-auth-mysql (Ubuntu):
status: Confirmed → Won't Fix
Paul Thomas (pautho) wrote :

Nobody can adapt the source code to work with Apache 2.4 it's so hard ? (Or try to contact the maintainer ?)

I think that's a bug when I have tried Apache 2.4 (summer 2013) but the problem is still there and found this bug report now :(
It's not only for LAMP but all authentifications to MySQL from Apache.

I can use DBD, switch to PostgreSQL or create a webpage for MySQL authentification but it's not more secure directly from Apache than a webpage ?

wlx (wangliangxu) wrote :

Thanks for the solution offered by Flavio Aiello, which could replace the mysql auth mod.

Robie Basak (racb) wrote :

xnox fixed the build so this package has been spared removal in Trusty. I didn't attempt this because it seemed likely to me that a more significant port would be needed to actually make it functional.

Could someone please verify if this is now fixed, or if the built package doesn't actually work? If it is still broken, it still will need a volunteer to fix, but at least current status will be clearer.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.