Sync mochikit 1.4.2-1 (universe) from Debian unstable (main).

Bug #384859 reported by Charlie_Smotherman on 2009-06-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mochikit (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync mochikit 1.4.2-1 (universe) from Debian unstable (main).

Explanation of the Ubuntu delta and why it can be dropped:
The copyright information for DragAndDrop.js, Sortable.js and Style.js
have been added to upstream. MoM shows a differnce in debian/copyright of
the use of backquote as compared to regular quotes. With this all Ubuntu
changes can be dropped.

Changelog since current karmic version 1.4.2-0ubuntu1:

mochikit (1.4.2-1) unstable; urgency=low

  * New Upstream Version (Closes: #510913)
  * Replaced 'prototype' with 'mochikit' in debian/README.Debian
  * Updated debian/copyright (thanks JCF Ploemen <email address hidden>), adding
    copyright notices for:
    + lib/MochiKit/DragAndDrop.js
    + lib/MochiKit/Sortable.js
    + lib/MochiKit/Style.js
  * Removed lib from docs debhelper file
  * Added DM-Upload-Allowed control field

 -- Marcelo Jorge Vieira (metal) <email address hidden> Mon, 2 Mar 2009 18:22:13 -0200

Changed in mochikit (Ubuntu):
importance: Undecided → Wishlist
Daniel Holbach (dholbach) wrote :

That'd drop the get-orig-source target in debian/rules - can you forward that to Debian too?

Do you know if dropping these files is intended:
Comparing ./libjs-mochikit_1.4.2-0ubuntu1_all.deb and /var/cache/pbuilder/result/libjs-mochikit_1.4.2-1_all.deb
[The following lists of changes regard files as different if they have
different names, permissions or owners.]

Files in first .deb but not in second
-------------------------------------
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Async.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Base.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Color.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/DOM.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/DateTime.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/DragAndDrop.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Format.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Iter.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Logging.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/LoggingPane.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/MochiKit.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/MockDOM.js
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Position.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Selector.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Signal.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Sortable.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Style.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Test.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/Visual.js.gz
-rw-r--r-- root/root /usr/share/doc/libjs-mochikit/lib/MochiKit/__package__.js

Charlie_Smotherman (cjsmo) wrote :

Danial,

Thank you for looking at this.

There is a debian/watch file.

--- mochikit-1.4.2.orig/debian/watch
+++ mochikit-1.4.2/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://www.mochikit.com/download.html dist/MochiKit-([\d\.]*).zip

Yes I believe that those files where remove on purpose.

1.4.2 changelog entry:

+ + lib/MochiKit/Style.js
+ * Removed lib from docs debhelper file
+ * Added DM-Upload-Allowed control field

--- mochikit-1.4.2.orig/debian/docs
+++ mochikit-1.4.2/debian/docs
@@ -0,0 +1,3 @@
+doc
+include
+tests

--- mochikit-1.3.1.orig/debian/docs
+++ mochikit-1.3.1/debian/docs
@@ -0,0 +1,4 @@
+doc
+include
+lib
+tests

Best regards
Charlie Smotherman

Daniel Holbach (dholbach) wrote :

ACKed.

Changed in mochikit (Ubuntu):
status: New → Confirmed
Changed in mochikit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers