Megafon switched APN to single "internet" without indexes

Bug #952184 reported by Platon Pukhlechev on 2012-03-11
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mobile-broadband-provider-info (Ubuntu)
High
Bhavani Shankar

Bug Description

http://sib.corp.megafon.ru/press/information/region/2006-08-23_14_09_00.html
from 2006(!) Megafon changed their APN from "internet.{sib,nw,etc}" to "internet", so there is no need to choose region

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mobile-broadband-provider-info (Ubuntu):
status: New → Confirmed

 <provider>
  <name>Megafon</name>
  <name xml:lang="ru">Мегафон</name>

  <gsm>
   <network-id mcc="250" mnc="02"/>
   <apn value="internet">
    <plan type="postpaid"/>
    <usage type="internet"/>
    <name>RUS</name>
    <name xml:lang="ru">Россия</name>
    <username>gdata</username>
    <password>gdata</password>
   </apn>
  </gsm>
 </provider>

Thats how serviceproviders.xml should be in Megafon Section. Single APN for every region as they did.

Changed in mobile-broadband-provider-info (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High

Marking as Fix Committed because the next upload will include it. We should do one new snapshot shortly before the Precise release and roll that out to all the supported releases.

Bhavani; do you think you could keep this in mind to be done... soonish, possibly by April 9 at the latest for the Precise upload?

Changed in mobile-broadband-provider-info (Ubuntu):
status: Confirmed → Fix Committed
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
assignee: nobody → Bhavani Shankar (bhavi)

If not, just reassign it to me and I'll look into it :)

Bhavani Shankar (bhavi) wrote :

Sure Matt

I just got free now and m looking at enhancements here :-)

Thanks for your work upstream :-)

Regards

Bhavani Shankar (bhavi) wrote :

Matt: here is the diff attached.

Kindly request you to upload :-)

Regards
Bhavani

tags: added: patch
Bhavani Shankar (bhavi) wrote :

Matt: Just a headsup here

Uploaded the same diff to debian

Kindly request you to synch the same across to ubuntu :-)

Regards

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mobile-broadband-provider-info - 20120410-0ubuntu1

---------------
mobile-broadband-provider-info (20120410-0ubuntu1) precise; urgency=low

  * New upstream release.
    - la: add Unitel, Beeline, and Lao Telecom providers (LP: #907674)
    - in: Add support for Reliance 3G provider in India (LP: #892937)
    - au: add Telstra BigPond plan (LP: #941773)
    - dk: add provider Onfone Internet DK (LP: #929448)
    - ke: Change of Provider name from celtel to Airtel (LP: #912728)
    - pk: add CDMA provider WorldCall Wireless (LP: #939828)
    - nl: mark T-Mobile as the primary provider for MCC/MNC 204/16 (rh #671372)
    - ru: update Russian Megafon provider (LP: #952184)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 10 Apr 2012 14:12:19 -0400

Changed in mobile-broadband-provider-info (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches