Please SRU mobile-broadband-provider-info into lucid(SRU exception)

Bug #607788 reported by Bhavani Shankar on 2010-07-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mobile-broadband-provider-info (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: mobile-broadband-provider-info

Please SRU this package as it supports various new networks over the present version in lucid

Upstream Changeset:

8 days us: add old Midwest Wireless SIDs (bought by Alltel in 2005) Dan Williams 1 -0/+5
11 days rwanda/burundi: add various operators (bgo #623909) Dan Williams 1 -0/+30
11 days hu: Pannon -> Telenor, add Invitel (bgo #623693) Dan Williams 1 -14/+13
11 days de: fix Fonic APN (bgo #623684) Dan Williams 1 -1/+4
12 days us: add Mid-Rivers Cellular Dan Williams 1 -0/+6
13 days us: add MTPCS/CellularOne (former Chinook Wireless) Dan Williams 1 -0/+7
13 days us: add Alltel GSM roaming-only network Dan Williams 2 -1/+5
2010-06-28 tunisia: add Orange TN (rh #601574) Dan Williams 1 -0/+16
2010-06-26 denark: add unotel and happiimobil; update 3 DK (bgo #622359) MH 1 -2/+17
2010-06-22 germany: add Alice Dan Williams 1 -0/+11
2010-06-15 denmark: add Telmore (bgo #621550) Dan Williams 1 -0/+11
2010-06-04 venezuela: add Movistar and Movilnet (bgo #620408) Dan Williams 1 -0/+20
2010-06-01 france: add 'slsfr' APN (bgo #620101) Dan Williams 1 -0/+7
2010-05-26 bangladesh: AKTel -> Robi, add CityCell (bgo #619577) Dan Williams 1 -1/+11
2010-05-22 malaysia: add Diginet Broadband (bgo #619362) Dan Williams 1 -0/+4
2010-05-10 release: bump version to 2010051020100510 Dan Williams 1 -1/+1
2010-05-05 armenia: update Orange and Vivacell/MTS plans (bgo #608581) Dan Williams 1 -2/+13
2010-04-29 romania: fix Digi.Net Mobil (rh #583225) Dan Williams 1 -2/+7
2010-04-27 sudan: add Zain Dan Williams 1 -0/+11
2010-04-26 india: add MTS MBlaze (bgo #616765) Dan Williams 1 -0/+8
2010-04-24 australia: update Optus DNS servers (bgo #616507) Dan Williams 1 -5/+5
2010-04-24 italy: clarify 3's plan names (bgo #616496) Dan Williams 1 -2/+2
2010-04-24 iceland: add Síminn (bgo #616465) Björgvin Ragnarsson 1 -0/+10
2010-04-24 italy: update Vodafone APN Dan Williams 1 -1/+4
2010-04-16 poland: add GaduAIR (bgo #615673) Dan Williams 1 -0/+6
2010-04-08 uganda: update providers (bgo #615149) Dan Williams 1 -2/+37
2010-04-08 Finland: fix erronous 817959d2bdca339074157e559c09d63b579ece38 which added Timo Jyrinki 1 -9/+10
2010-04-08 sweden: add Parlino and UTVC Dan Williams 1 -0/+19
2010-04-08 norway: add TDC's MCC/MNC Dan Williams 1 -0/+1
2010-04-08 norway: fix Telenor APN Dan Williams 1 -1/+1
2010-04-08 Fix O2's name Dan Williams 1 -2/+2
2010-04-08 sweden: add a few more APNs; add Com Hem Dan Williams 1 -7/+24
2010-04-08 sweden: add Glocalnet bredband APN (bgo #615008) Dan Williams 1 -2/+8
2010-04-08 uk: add O2 m-bb APN (bgo #615075) Dan Williams 1 -1/+6
2010-04-08 uruguay: update provider APNs Dan Williams 1 -1/+20
2010-04-04 italy: add PosteMobile (bgo #613878)

and it is safe to do SRU from readme:

The Package contains only informational files so it's safe for distributions to grab updates even during feature freeze and maintenance stages."

and it has an exception:

https://wiki.ubuntu.com/StableReleaseUpdates#mobile-broadband-provider-info

Bhavani Shankar (bhavi) wrote :
Martin Pitt (pitti) wrote :

Closing the maverick task, this looks very recent:

mobile-broadband-provider-info | 20100716-1 | maverick | source, all

Changed in mobile-broadband-provider-info (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Bhavani,

debian/changelog says this is 20100716, but the configure diff says

- VERSION='20100122'
+ VERSION='20100510'

Is that intended? (It might just be the upstream configure.ac version being behind, of course)

Bhavani Shankar (bhavi) wrote :

yes martin I forward bugs upstream according to their relevance and do a git pull twice a month and update the package in debian. It should be no harm I think

regards

Martin Pitt (pitti) wrote :

OK, thanks. SRU ack, please upload.

Benjamin Drung (bdrung) wrote :

uploaded to lucid-proposed

Changed in mobile-broadband-provider-info (Ubuntu Lucid):
status: New → Fix Committed

Accepted gcj-4.4 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Jonathan Riddell (jr) wrote :

Accepted mobile-broadband-provider-info into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Jonathan Riddell (jr) wrote :

Ignore comment #8, wrong package

Martin Pitt (pitti) wrote :

Could anyone please test the new package in -proposed whether it still works?

Verification for Lucid.

The change affects the data files, and the package baked for more than a week in -proposed without regression reported. Following https://wiki.ubuntu.com/StableReleaseUpdates#mobile-broadband-provider-info the package can be moved to -updates.

I've installed version 20100716-1ubuntu0.1 in lucid-proposed and I've been able to configure a French provider.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mobile-broadband-provider-info - 20100716-1ubuntu0.1

---------------
mobile-broadband-provider-info (20100716-1ubuntu0.1) lucid-proposed; urgency=low

  * SRU exception upload to support various updated networks
    (LP: #607788)

mobile-broadband-provider-info (20100716-1) unstable; urgency=low

  * Merging upstream version 20100716 from git
  * Summary of upstream changes:
    - us: support old Midwest Wireless SIDs
    - us: support Mid-Rivers Cellular operator
    - us: support MTPCS/CellularOne (former Chinook Wireless) operator
    - us: support Alltel GSM roaming-only network
    - rwanda/burundi: support various operators like africell and mtn
    - hu: Pannon name changed to Telenor
    - hu: support invitel operator
    - de: fix Fonic operator APN

mobile-broadband-provider-info (20100702-1) unstable; urgency=low

  * Merging upstream version 20100702 from git
  * Modifying long description in debian/control
  * Renaming upstream target in debian/rules to get-orig-source
  * Bumping the Standards-Version to 3.9.0 No other changes

mobile-broadband-provider-info (20100616-1) unstable; urgency=low

  * Merging upstream version 20060616 from git

mobile-broadband-provider-info (20100602-1) unstable; urgency=low

  * The "delay due to exams release"
  * Merging upstream version 20100602 from git

mobile-broadband-provider-info (20100507-1) unstable; urgency=low

  * Merging upstream version 20100507 from git

mobile-broadband-provider-info (20100422-1) unstable; urgency=low

  * Merging upstream version 20100422 from git
 -- Bhavani Shankar <email address hidden> Tue, 17 Aug 2010 11:48:22 +0200

Changed in mobile-broadband-provider-info (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers