mobile-atlas-creator version 1.8+dfsg1-1 failed to build with openjdk-7

Bug #888982 reported by James Page on 2011-11-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mobile-atlas-creator (Ubuntu)
Medium
Unassigned
proguard (Debian)
Fix Released
Unknown
proguard (Ubuntu)
Medium
Unassigned

Bug Description

During a rebuild test on precise with default-jdk switched to openjdk-7, a build failure was detected for mobile-atlas-creator version 1.8+dfsg1-1.

See attached log for full build failure details.

This log snippet might also be of interest:

    [javac] * The square of excentricity: e???? = (a????-b????)/a???? where <var>e</var> is the
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/mapsources/mapspace/MercatorPower2MapSpaceEllipsoidal.java:58: error: unmappable character for encoding ASCII
    [javac] * The square of excentricity: e???? = (a????-b????)/a???? where <var>e</var> is the
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/mapsources/mapspace/MercatorPower2MapSpaceEllipsoidal.java:58: error: unmappable character for encoding ASCII
    [javac] * The square of excentricity: e???? = (a????-b????)/a???? where <var>e</var> is the
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDm2Format.java:36: error: unmappable character for encoding ASCII
    [javac] degFmt = new DecimalFormat("00??", dfs);
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDm2Format.java:36: error: unmappable character for encoding ASCII
    [javac] degFmt = new DecimalFormat("00??", dfs);
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDm2Format.java:58: error: unmappable character for encoding ASCII
    [javac] String[] tokens = source.trim().split("[??\\']");
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDm2Format.java:58: error: unmappable character for encoding ASCII
    [javac] String[] tokens = source.trim().split("[??\\']");
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDms2Format.java:37: error: unmappable character for encoding ASCII
    [javac] degFmt = new DecimalFormat("00??", dfs);
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDms2Format.java:37: error: unmappable character for encoding ASCII
    [javac] degFmt = new DecimalFormat("00??", dfs);
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDms2Format.java:63: error: unmappable character for encoding ASCII
    [javac] String[] tokens = source.trim().split("[??\\'\\\"]");
    [javac] ^
    [javac] /«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/src/main/java/mobac/utilities/geo/CoordinateDms2Format.java:63: error: unmappable character for encoding ASCII
    [javac] String[] tokens = source.trim().split("[??\\'\\\"]");
    [javac] ^
    [javac] 26 errors
    [javac] 1 warning

BUILD FAILED
/«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1/build.xml:50: Compile failed; see the compiler error output for details.

Total time: 3 seconds
dh_auto_build: ant returned exit code 1
make[1]: *** [override_dh_auto_build] Error 2
make[1]: Leaving directory `/«BUILDDIR»/mobile-atlas-creator-1.8+dfsg1'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
────────────────────────────────────────────────────────────────────────────────
Build finished at 20111110-2129

Finished
────────

E: Build failure (dpkg-buildpackage died)

Related branches

tags: added: amd64 auto java7-ftbfs
James Page (james-page) on 2011-11-25
tags: added: encoding
James Page (james-page) wrote :

Reconfirmed in Ubuntu Quantal - adding ftbfs tag.

tags: added: ftbfs
Logan Rosen (logan) wrote :

James, can you please check if the latest version, 1.9.6+dfsg1-1, builds properly with OpenJDK 7? Thanks in advance!

James Page (james-page) wrote :

Yep - still fails.

James Page (james-page) wrote :

BUILD FAILED
/home/jamespage/src/ubuntu/quantal/java7/universe-rebuild/mobile-atlas-creator-1.9.6+dfsg1/build.xml:161: Can't read [proguard.ClassPathEntry@5ae8bc1f] (Can't process class [com/oracle/net/Sdp$1.class] (Unsupported version number [51.0] for class format))

I suspect that proguard is not working with Java 7 ATM - but I might be wrong.

James Page (james-page) wrote :

Looks like we need a later version of proguard - 4.7 minimum:

http://proguard.sourceforge.net/index.html#downloads.html

Logan Rosen (logan) wrote :

Should a wishlist bug be filed at Debian, requesting that the new upstream version of proguard be packaged?

James Page (james-page) wrote :

Ideally yes - but we might have to push a new version in quantal if it does not land in Debian pre-freeze.

James Page (james-page) wrote :

Confirmed - building with proguard 4.8 resolves this issue.

Looks like we need that upgrade.

Changed in proguard (Ubuntu):
status: New → Confirmed
Changed in mobile-atlas-creator (Ubuntu):
status: New → Confirmed
Changed in proguard (Ubuntu):
importance: Undecided → Medium
Changed in mobile-atlas-creator (Ubuntu):
importance: Undecided → Medium
Changed in proguard (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package proguard - 4.8-0ubuntu1

---------------
proguard (4.8-0ubuntu1) quantal; urgency=low

  * New upstream release. Necessary to fix FTBFS on
    mobile-atlas-creator package. (LP: #888982)
  * debian/patches/add-bin.patch: tidy up auto-generated patch which creates
    proguard and proguardgui shell scripts.
 -- Sebastian Carneiro <email address hidden> Wed, 11 Jul 2012 20:52:33 -0300

Changed in proguard (Ubuntu):
status: Confirmed → Fix Released
James Page (james-page) on 2012-07-18
Changed in mobile-atlas-creator (Ubuntu):
status: Confirmed → Fix Released
Changed in proguard (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.