MLT++ needs rebuild

Bug #363805 reported by Olivier Banus on 2009-04-19
60
This bug affects 8 people
Affects Status Importance Assigned to Milestone
mlt++ (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu Jaunty, libmlt++1 0.3.8-0ubuntu1

After the latest mlt rebuilt with some compiling options modifications, mlt++ hasn't been rebuilt. mlt++ depends on mlt so this is causing problems.

edit : invalid bug report

Olivier Banus (sunab) on 2009-04-19
description: updated
Olivier Banus (sunab) on 2009-04-20
description: updated
Psy[H[] (vovik-wfa) wrote :

I've tried to install libmlt++1_0.3.8-0ubuntu2~ppa1 and libmlt++1_0.3.8-0ubuntu2~ppa2 from your and Michael Marley's ppa's, removed kdenlive config after both installations. Codec are still unaccessible.

Psy[H[] (vovik-wfa) wrote :

...not sure what exactly I did, but after some continuous installation/removal/reconfiguring of related packages, the trick worked.

Psy[H[] (vovik-wfa) wrote :

All profiles are active, but rendering is still impossible.
x264 rendering crashes:
Rendering of /home/psycho/kdenlive/1.mp4 crashed
consumer_avformat.c: audio codec libfaac unrecognised - ignoring
consumer_avformat.c: video codec libx264 unrecognised - ignoring
consumer_avformat.c: Unable to encode audio - disabling audio output.

other profiles producing either empty (~10-500KB) files or video with only big "INVALID" frame.

Olivier Banus (sunab) wrote :

hi Psy[H[],

what version of ffmpeg libs do you have?

To encode using libfaac or lix264 you must have the unstripped version of ffmpeg libs.

ps : on my computer I can do it without errors.

Psy[H[] (vovik-wfa) wrote :

I have ffmpeg version 3:0.svn20090303-1ubuntu6, from ubuntu repos.

Olivier Banus (sunab) wrote :

ok,

when you install kdenlive many dependencies are installed, one of the most important is libmlt1 (the framework kdenlive relies on) and if you look at this : http://packages.ubuntu.com/jaunty/libmlt1
you will see that libmlt1 depends on many ffmpeg libraries (libavcodec,libavformat,libavutil,libswscale) and you can see that, example for libavcodec, there are two alternatives : libavcodec52 or libavcodec-unstripped-52

by default when you install kdenlive the "simple" libs are installed not the "unstripped"versions, this is because the unstripped versions activate codecs like faac or x264 with more or less patents in some countries.

if you want to create an mp4 file with ACC sound and H264, unstripped libs of ffmpeg are mandatory. You must install them manually, like I did :
sudo apt-get install libavcodec-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libswscale-unstripped-0

Psy[H[] (vovik-wfa) wrote :

I haven't noticed that. Thanks!
Now rendering "works", but resulting video shows only "INVALID" frames. Sometimes generators (noise and countdown) get rendered correctly, but not always and without apparent pattern. But mpeg2 video, which showed correctly in project monitor, renders only in "INVALID" frames. Tried to render test project (two mpeg2 clips and noise generator in between with fade in/out) in x264 and mpeg2. No errors were in terminal output.

Psy[H[] (vovik-wfa) wrote :

Oops. Forgot about swscale. Now everything works fine. Thank you!

Olivier Banus (sunab) on 2009-04-28
Changed in mlt++ (Ubuntu):
status: New → Confirmed
SuperBypass (taniroku) wrote :

Hi

I have also the unavailable rendering of HDV, mpeg2, mpeg4, flv after upgrading ubuntu 8.10 to 9.04. Before rebuilding the libmlt++1_0.3.8-0ubuntu1 to libmlt++1_0.3.8-0ubuntu2, I tried to install "libavcodec-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libswscale-unstripped-0". After installing these libraries with apt-get, kdenlive0.73 could be launched correctly, then I ran the kdenlive config again. Kdenlive could showed all rendering formats of HDV, mpeg2, mpeg4, flv after restarting itself. The rendering of HDV, mpeg2, mpeg4 could be completed fine.
It is not clear why kdenlive can work the rendering of HDV, mpeg2, mpeg4, flv without rebuilding libmlt++...
Any way, the rendering could be work in my ubuntu9.04 environment after installing "libavcodec-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libswscale-unstripped-0"

Olivier Banus (sunab) wrote :

ok SuperBypass,

your info demonstrates a curious behaviour, I have tested it and you are wright. But mlt++ still needs rebuild :

- in case of using regular (stripped) versions of ffmpeg libs.
- if you want to use any frei0r plugin with stripped or unstripped ffmpeg libs. When mlt was rebuilt the packager introduced the frei0r option, but mlt++ was not rebuilt, causing problems in kdenlive when installing frei0r plugins even if none are use in the current project. (install kdenlive, install frei0r plugins after and create a project as simple as a single track with no transitions and no effects and try to render it to any format ... if you use a rebuilt version of mlt++ you can)

so that's why I created my mlt++ rebuilt version on my ppa.

can you confirm the problem I met with the original mlt++ package and frei0r plugins installed? (anything can be rendered in that case). And if using my mlt++ package solves the problem?

SuperBypass (taniroku) wrote :

Thank you Sunab!

I have just confirmed the rendering of simple project of single track without no transition and effect. But the rendering was completed without any problem, and the created movies of HDV and mpeg4 were played normally. Then, I tried to render the two track project with transition of Luma. the rendering and the created movie was also normally finished and played.
After re-installing the frei0r-plugins using synaptics without rebuilding mlt++, the same process that I mentioned above was finished. I could not confirm any problems in the editing and rendering video clips of HDV(m2t).
I would like to know the actual phenomen of the problem you have experienced before rebuilding mlt++ libraries.

To be honest, I am using three ubuntu machines, desktop Core2Duo, panasonic let'sNote PC, desktop Core2quad, and I have installed your mlt++ package on my Core2Duo desktop machine, and installed frei0r-plugins on it. Of course, the rendering of a project could be completed normally. Then, I tried the installation of ffmpeg unstripped libralies only without rebuilding mlt++ on my panasonic Let'sNote, and Core2quad desktop. I could not experienced the problem you suggested.

I would like to know the prolem you mentioned. Or still I have to check other factor of libraries...?
Thank you.

Guillaume (guillaume-zin) wrote :

Hello,

I went into the same troubles as Psy[H[], uninstall, reinstall of libmlt++ from sunab ppa, Kdenlive, ffmpeg, unstripped libraries... with no possibility to encode in various formats from Kdenlive. I managed to get new formats appearing in Kdenlive by relaunching the configuration wizard from the Kdenlive configuration menu.

Guillaume

Psy[H[] (vovik-wfa) wrote :

I've got another problem: rendering in h264 results in extremely large files:
Renders of the same test project: mpeg4 4000k ~10MB, h264 4000k ~100MB

andre (andre-jellema) wrote :

Hi I am new to the world of linux.

I tried to solve the problem with:

'if you want to create an mp4 file with ACC sound and H264, unstripped libs of ffmpeg are mandatory. You must install them manually, like I did :
sudo apt-get install libavcodec-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libswscale-unstripped-0'

But still can not render HDV, mpeg2, mpeg4 formats.

What I am supposed to do next?

'But mlt++ still needs rebuild'

How do I do that?

Guillaume (guillaume-zin) wrote :

Add these lines at the end of /etc/apt/sources.list (you need a text editor with root privileges, I think you can do it from Synaptic and Adept too):

deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main

From the command line, run

sudo apt-get update

and then

sudo apt-get upgrade

Or use Synaptic or Adept to update your package list and to look for upgrade.

A new (unsigned) mlt++ version will be proposed for installation.

After that, run the configuration wizard from the Kdenlive configuration menu and this should work.

Guillaume

Olivier Banus (sunab) wrote :

I was wrong, my bug report seem to be invalid. I will delete my mlt++ package on my ppa.
Sorry for that...

description: updated
description: updated
Changed in mlt++ (Ubuntu):
status: Confirmed → Invalid
SuperBypass (taniroku) wrote :

Thank you Snab!

I understand the problem of the rendering related ffmpeg libraries. But, your bug report was very helpful for me, especially the unstripped ffmpeg libraries was essential to render HDV, mpeg2,mpeg4, etc... I don't think that your bug report about mlt++ was not useful, because I could confirm the package versions of mlt++ in ubuntu 9.04.
Any way let's continue to report bugs and discuss those! Thank you!

Thanx a lot that was very helpfull. I can render hd formats now!.

However a solution often leeds to more questions.

1. I still cannot view my original sony m2t files in a movy player. (Kdenlive only contains a small player)

2. After rendering the resulting file becomes stripy especially when something is moving.

Any idea's about the solution to these problems???

cheers Andre

--- On Sat, 5/2/09, Guillaume <email address hidden> wrote:

From: Guillaume <email address hidden>
Subject: [Bug 363805] Re: MLT++ needs rebuild
To: <email address hidden>
Date: Saturday, May 2, 2009, 2:59 PM

Add these lines at the end of /etc/apt/sources.list (you need a text
editor with root privileges, I think you can do it from Synaptic and
Adept too):

deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main

>From the command line, run

sudo apt-get update

and then

sudo apt-get upgrade

Or use Synaptic or Adept to update your package list and to look for
upgrade.

A new (unsigned) mlt++ version will be proposed for installation.

After that, run the configuration wizard from the Kdenlive configuration
menu and this should work.

Guillaume

--
MLT++ needs rebuild
https://bugs.launchpad.net/bugs/363805
You received this bug notification because you are a direct subscriber
of the bug.

Status in “mlt++” source package in Ubuntu: Confirmed

Bug description:
ubuntu Jaunty, libmlt++1 0.3.8-0ubuntu1

After the latest mlt rebuilt with some compiling options modifications, mlt++ hasn't been rebuilt. mlt++ depends on  mlt so this is causing problems.

At this moment I have seen one : in kdenlive it is impossible to render a project with some codecs (x.264, mpeg2, ...), but after rebuilding mlt++ against the actual mlt (0.3.8-0ubuntu2) I have acces to all codecs.

SuperBypass (taniroku) wrote :

Hi Andre,

The answer to the first question will be vlc, VideoLan. You can install it as followings.
sudo apt-get install vlc

Of course, I have already been able to play a m2t files encoded by Sony HDV converter. If you want to play it with mediaplayer, you need to install gstreamer0.10-plugins-bad which is restricted MPEG2 Transport Stream demuxer.

The second question you mentioned,
>the resulting file becomes stripy especially when something is moving
What do you mean actually? what is "stripy"?, What is "something"?
And what format and codec did you rendered?

Guillaume (guillaume-zin) wrote :

Hello,

Correct me if I'm wrong, but indeed, libmlt++ doesn't need to be updated to get all codecs (Xvid, flash, ...)?

All we need is to install unstripped libraries (sudo apt-get install libavcodec-unstripped-52libavdevice-unstripped-52 libavfilter-unstripped-0 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0) and relaunch the configuration wizard from the configuration menu to get all missing codecs.

Because I came back to the original libmlt++ from jaunty repository, I relaunched the wizard and I still have all the codecs now.

Guillaume.

Mateusz Łoskot (mloskot) wrote :

Hi,

I just want to confirm that under Ubuntu 9.04 (re)installation of the *-unstripped-* codecs and libmlt++ as well as reconfiguration of kdenlive works - all codecs are enabled and available to use for rendering.

Thanks for the tips and packages!

Mateusz

PAUL STOKS (stokkie-p) on 2011-03-09
Changed in mlt++ (Ubuntu):
status: Invalid → In Progress
AdamOutler (adamoutler) wrote :

It appears MLT has been rebuilt several times.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers