updatedb.mlocate causes long time high ntfs-3g IO usage

Bug #362809 reported by Carl Ådahl on 2009-04-17
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mlocate (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mlocate

Computer was extremely sluggish, but CPU usage showed nothing. Looked at IORR column in htop and found that ntfs-3g kept quite active (value around 60).

I traced this IO usage to updatedb.mlocate, which was processing the /mnt/xp mount (which I set up in my fstab last night).

Examining /etc/updatedb.conf shows that:
- /mnt is not included in PRUNEPATHS, but /media is.
- "ntfs-3g" is not included in PRUNEFS.

Adding either seems to have fixed my issue. I consider it a bug since for some reason it causes extreme IO load to do the updatedb on ntfs-3g. The machine was nearly unusable for several hours until I found the issue.

aav@dello:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

Cruncher (ubuntu-wkresse) wrote :

Not sure if this will help for ntfs, but I changed my mlocate cronjob to launch updatedb.mlocate with an "idle" io priority. So the last lines of /etc/cron.daily.mlocate look like:

##

# See ionice(1)
if [ -x /usr/bin/ionice ] &&
    /usr/bin/ionice -c3 true 2>/dev/null; then
    IONICE="/usr/bin/ionice -c3"
fi

$IONICE /usr/bin/updatedb.mlocate

This should probably be accompanied by a nice 19, to also reduce actual userspace CPU stress.

Cruncher (ubuntu-wkresse) wrote :

Ah, I just realized I didn't add the ionice stuff manually, it was added in Jaunty, so your system probably already has it? (check /etc/cron.daily/mlocate).

This looks alot like a duplicate of bug #332790 (except for the ntfs thing), but I am reluctant to mark it as such as long as that bug is marked as "Fix Released" - although several people over there are still complaining about general sluggishness.

Maybe ionice simply doesn't work for ntfs?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mlocate (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers