mknbi fails to build from source in maverick on amd64

Bug #600551 reported by Matthias Klose on 2010-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mknbi (Debian)
Fix Released
Unknown
mknbi (Ubuntu)
High
Colin Watson
Maverick
High
Colin Watson

Bug Description

Binary package hint: mknbi

1.4.4-2 adds amd64 and kfreebsd-amd64 to the list of architectures, but the
package fails to build, using -mcpu=i386 unconditionally. If the package is
wanted to build on these architectures, then maybe -m32 -mcpu=i386 and a build
dependency on gcc-multilib is needed.

Related branches

Matthias Klose (doko) on 2010-07-01
Changed in mknbi (Ubuntu Maverick):
importance: Undecided → High
milestone: none → maverick-alpha-3
status: New → Confirmed
Changed in mknbi (Debian):
status: Unknown → Fix Released
summary: - fails to build from source in maverick on amd64
+ mknbi fails to build from source in maverick on amd64
Thierry Carrez (ttx) wrote :

Not a server package, tentatively assigning to Foundations team

Changed in mknbi (Ubuntu Maverick):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Martin Pitt (pitti) wrote :

The current Debian version still FTBFSes for me:

gcc -E -DRELOC=0x92800 start32.S | as -o start32@0x92800.o
start32.S: Assembler messages:
start32.S:61: Error: number of operands mismatch for `ljmp'
start32.S:68: Error: invalid instruction suffix for `push'
start32.S:69: Error: invalid instruction suffix for `push'
start32.S:70: Error: invalid instruction suffix for `push'
start32.S:92: Error: invalid instruction suffix for `push'
start32.S:94: Error: invalid instruction suffix for `push'
start32.S:95: Error: invalid instruction suffix for `push'
start32.S:96: Error: invalid instruction suffix for `push'
make[2]: *** [start32@0x92800.o] Error 1

Changed in mknbi (Ubuntu Maverick):
milestone: maverick-alpha-3 → ubuntu-10.10-beta
Colin Watson (cjwatson) on 2010-08-19
Changed in mknbi (Ubuntu Maverick):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mknbi - 1.4.4-6ubuntu1

---------------
mknbi (1.4.4-6ubuntu1) maverick; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Makefile: Add -fno-stack-protector to CFLAGS.
  * Pass appropriate options to ld and as to make gcc-multilib build work
    (LP: #600551).

mknbi (1.4.4-6) unstable; urgency=low

  * Updating standards version to 3.9.0.
  * Building with gcc-multilib (Closes: #587734).

mknbi (1.4.4-5) unstable; urgency=low

  * Correcting yet another spelling error in package long-description
    (Closes: #584708).

mknbi (1.4.4-4) unstable; urgency=low

  * Correcting another spelling error in package long-description
    (Closes: #584618).

mknbi (1.4.4-3) unstable; urgency=low

  * Updating year in copyright file.
  * Updating to standards 3.8.4.
  * Correcting spelling error in package long-description (Closes:
    #584131).
 -- Colin Watson <email address hidden> Thu, 19 Aug 2010 17:08:05 +0100

Changed in mknbi (Ubuntu Maverick):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.