Fix visual artifact due to Qt bug or upgrade to 1.8.0.1 final

Bug #645804 reported by Albert Santoni
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mixxx (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: mixxx

A few days ago, a user discovered an bug where Mixxx's library table appears with the colour scheme applied incorrectly (bug #642606):
https://bugs.launchpad.net/mixxx/+bug/642606/+attachment/1606860/+files/Screenshot-3.png

As you can see from the screenshot, this bug will have a large impact on every single user that runs Mixxx. Since Mixxx has become the DJ software of choice for Linux DJs, it's reasonable to assume that every DJ on Ubuntu is going to be presented with this very unprofessional-looking user interface when they launch Mixxx on Maverick. It turns out this is actually a bug in Qt 4.7.0, not in Mixxx, and there is a fix targeted for Qt 4.7.1 but that unfortunately won't be in Maverick. However, we have a workaround for this bug that we've included in our official Mixxx 1.8.0.1 release, which I've just uploaded.

There are two ways we can solve this:
1) Modify the Mixxx 1.8.0 RC package in Maverick to include a patch to fix this issue.
2) Upgrade the Mixxx 1.8.0 RC package to our final Mixxx 1.8.0.1 release, which includes a significant number of other bug fixes.

Both of these options require a feature freeze exception, and the Mixxx team strongly believes option #2 is the better option for Ubuntu users.

Mixxx 1.8.0.1 includes over 180 commits worth of bug fixes to our code, our DJ MIDI controller mappings, and updates to our artwork. Highlights from these changes include:

- Workaround for the incorrect library colours bug caused by Qt 4.7.0
- Fix segfault with JACK on startup when samplerates mismatch
- Fixes for some corner cases where our library scanner might miss files
- Fixed a data loss issue when importing libraries from Mixxx 1.7
- Optimizing waveform drawing which can result in a 40% (!) drop in CPU usage with Intel graphics chips
- Fixed bugs in DJ MIDI controller mappings for Vestax VCI-100, Hercules DJ Control MP3, Hercules DJ Control e2, Hercules RMX, Reloop Digital Jockey2, DJTechTools MIDI Fighter, M-Audio Xponent, Behringer BCD3000, Mixman DM2
- Optimizations to the library scanner, 4x speedup
- Artwork fixes and improvements for skins
- Memory leak fixes in the library scanner and Rhythmbox track source
- UTF-8 handling fixes for FLAC/WAV files and the Rhythmbox track source
- Updated manual
- DFSG-compatible license for skins (Creative Commons 3.0 Attribution Share-Alike unported)

A full changelog for Mixxx 1.8.0.1 vs. Mixxx 1.8.0 RC is attached.

Furthermore, Mixxx 1.8 has been through our longest and most successful beta cycles to date, which began back in Februrary. It's received by far the most testing of any release we've produced through active involvement of our community and our developers, and we even worked together to create a standardized QA procedure for Mixxx. Because of the wide testing and acceptance of this update, we believe the risk of regression or breakage to be very low.

Mixxx is also essential to the suite audio applications included in Ubuntu Studio by default, as Mixxx is the only application included for live performance DJing. We also believe that because most of Ubuntu Studio's users are artists, having such a jarring bug in Mixxx's appearance will impact users' perception of both Mixxx and Ubuntu Studio's quality. It is for this reason that we believe updating this package is necessary.

I have uploaded a package for Mixxx 1.8.0.1 to REVU:
http://revu.ubuntuwire.com/p/mixxx

Along with updating Mixxx to our final 1.8.0.1 release (which includes a workaround for the incorrect colours bug), I've also added a fix for bug #634072 which was filed against the package in Ubuntu.

As per the Feature Freeze Exception Process, I will be attaching the following files in the next few comments:
- The log from pdebuild when I built the new package I uploaded to REVU.
- A log from a clean installation of the Mixxx 1.8.0.1 package on Maverick.
- A log from an upgrade from the existing Mixxx 1.8.0 RC package in Universe to the new 1.8.0.1 package.
- A screenshot demonstrating the colours in the library bug is resolved.

Thank you, and please let me know if you require any additional information or assistance. We're looking forward to working with you to improve the user experience for DJs on Ubuntu and maintaining the high level of polish that our users expect.

Albert Santoni

Lead Developer, Mixxx

Revision history for this message
Albert Santoni (gamegod) wrote :
Revision history for this message
Albert Santoni (gamegod) wrote :

The log from pdebuild when I built the new package I uploaded to REVU:

Revision history for this message
Albert Santoni (gamegod) wrote :

A log from a clean installation of the Mixxx 1.8.0.1 package on Maverick.

Revision history for this message
Albert Santoni (gamegod) wrote :

A log from an upgrade from the existing Mixxx 1.8.0 RC package in Universe to the new 1.8.0.1 package.

Revision history for this message
Albert Santoni (gamegod) wrote :

A screenshot demonstrating the colours in the library bug is resolved.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack. FFe approved. Leaving bug at New for sponsor review.

Emmet Hikory (persia)
Changed in mixxx (Ubuntu):
assignee: nobody → Emmet Hikory (persia)
status: New → Confirmed
importance: Undecided → Medium
Changed in mixxx (Ubuntu):
status: Confirmed → In Progress
assignee: Emmet Hikory (persia) → Alessio Treglia (quadrispro)
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Oops, sorry Emmet.
Re-assigning this to persia, however I'm working on this by the Debian side, too.

Changed in mixxx (Ubuntu):
assignee: Alessio Treglia (quadrispro) → Emmet Hikory (persia)
status: In Progress → Confirmed
Revision history for this message
Alessio Treglia (quadrispro) wrote :

<quadrispro> persia, building right now a package for experimental (LP: #645804)
<quadrispro> once uploaded, a merge should be enough
<persia> quadrispro, Why merge? Why not sync?
<persia> And please reassign to yourself: watching your commits to git, I think you know lots more about this package than I (I was just trying to figure out why it was repacked)
[...]
quadrispro> persia, I'd prefer to not add a dependency on pulseaudio-utils (it's likely that who uses this on Debian may not use pulse), plus Ubuntu provides a mp4v2 package but Debian doesn't

Changed in mixxx (Ubuntu):
assignee: Emmet Hikory (persia) → Alessio Treglia (quadrispro)
status: Confirmed → In Progress
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Uploaded, sitting in the queue.

Changed in mixxx (Ubuntu):
assignee: Alessio Treglia (quadrispro) → nobody
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mixxx - 1.8.0.1~dfsg-1ubuntu1

---------------
mixxx (1.8.0.1~dfsg-1ubuntu1) maverick; urgency=low

  * Re-sync with Debian experimental (FFe granted LP: #645804).
  * Don't apply 91-desktop_file.patch, Ubuntu uses PulseAudio.
  * Depends on pulseaudio-utils (LP: #634072);
    thanks to Evgeni Golov for reporting this.
  * Enable soundsourcem4a plugin:
    - Build-depends on libmp4v2-dev.
    - Don't apply 30-disable_soundsourcem4a.patch patch.
  * Build-depends on libqtwebkit-dev.

mixxx (1.8.0.1~dfsg-1) experimental; urgency=low

  * New upstream release:
    - Fix visual artifact due to Qt bug (LP: #645804).
  * Add README.source to document the repacking.
  * Update copyright information.
  * Add get-orig-source target.
  * Refresh patches.
  * Build-depends on libwavpack-dev.
  * Update debian/gbp.conf.
  * Install missing icon file (LP: #641880).
 -- Alessio Treglia <email address hidden> Thu, 23 Sep 2010 11:54:04 +0200

Changed in mixxx (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
James Kittsmiller (jkittsmiller2) wrote :

I'm using the latest version of Mixxx in the repo's for ubuntu 10.10 and the shade skins display with the wrong colours in play lists, I fixed it by over writing them with the ones downloaded from the Mixxx forums,You may need to check and repack all the skins..

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 645804] Re: Fix visual artifact due to Qt bug or upgrade to 1.8.0.1 final

Please file a new bug for this.

To post a comment you must log in.