There does not exist a 64-bit version of mit-scheme. A deb of mit-scheme-c (portable) would fix this.

Bug #373018 reported by WolphFang on 2009-05-06
This bug affects 25 people
Affects Status Importance Assigned to Milestone
mit-scheme (Debian)
mit-scheme (Ubuntu)
Colin Watson

Bug Description

There does not exist a 64-bit version of mit-scheme. Would not mit-scheme-c (portable) fix this serious lack? (

I work for a college, and I have two labs I need to deploy mit-scheme into, but they are all 64-bit systems. This is in preparation to introduce selected staff/students to the MIT LISP/SCHEME book and video lectures, and I am trying to be as true to the material as reasonably possible.


Changed in mit-scheme (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mit-scheme (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

"hillma" pointed out on #ubuntu-devel IRC that there's an amd64 version of mit-scheme in Debian now, so I bootstrapped it for Ubuntu vivid based on that. If you need it for older releases of Ubuntu, the binary package from the build I just did is downloadable from and its dependencies are satisfiable back as far as Ubuntu 12.04, so you should be able to install it by hand using "dpkg -i" or similar.

Changed in mit-scheme (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.