SRU: mit-scheme uninstallable on Intrepid

Bug #341832 reported by Evan Broder on 2009-03-12
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mit-scheme (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: mit-scheme

Bug #288000 (dependency on nonexistent libltdl3) and bug #217792 (AppArmor blocks mit-scheme from allocating memory near 0) apply to Intrepid as well as Jaunty. Thanks to #288000, the package is not installable on Intrepid, and even if it were installable, it doesn't run under ubuntu-standard thanks to #217792. This was fixed in Jaunty in bug #339449.

Since the package is more or less completely broken, instead of generating the minimal patch (which would be very time-consuming), I propose uploading the same version that was uploaded to Jaunty for bug #339449 to Intrepid.

As with bug #339449, I believe the regression potential is essentially 0, since it's hard to regress from an uninstallable package.

Evan Broder (broder) wrote :
Evan Broder (broder) wrote :
John Dong (jdong) wrote :

My 2c as MOTU-SRU is this reminds me of the Azureus situation in Gutsy -- it's a completely broken package and for that matter introducing the Jaunty version to Intrepid is an appropriate action to get it back into sane state. I see no risk for regression.

Given the unusual nature of this SRU I'd like to get another opinion before calling it ACKed though.

Geoffrey Thomas (geofft) wrote :

I can confirm that installing the Jaunty package (via adding the repo and pinning all but mit-scheme and libltdl7) works perfectly on my Intrepid laptop. Because of the versioned dependency on libtldl7, I think that will need to be SRU'd too.

Geoffrey Thomas (geofft) wrote :

Er, maybe I'm confused and building on Intrepid will let it use the older version of libltdl7.

Evan Broder (broder) wrote :

Right - the libltdl7 dependency is auto-generated at buildtime by dpkg-shlibdeps, and the dependency is versioned based on what's available.

John Dong (jdong) wrote :

Based on a bit of consulting this is a reasonable approach for solving this problem. I am approving the SRU and will sponsor the upload later this evening.

Marking Fixed Released for Jaunty.

To the above commenter, yes, building the package in Intrepid as opposed to installing the Jaunty binary does link the package against the correct dependency versions.

Changed in mit-scheme (Ubuntu):
status: New → Fix Released
John Dong (jdong) wrote :

Sorry for the delay, I've just uploaded this into -proposed.

Martin Pitt (pitti) wrote :

Accepted mit-scheme into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mit-scheme (Ubuntu Intrepid):
status: New → Fix Committed
tags: added: verification-needed
Evan Broder (broder) wrote :

The package in -proposed works for me - I was able to install it and do some simple arithmetic.

Martin Pitt (pitti) on 2009-04-01
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mit-scheme - 7.7.90+20090107-1ubuntu0.1

---------------
mit-scheme (7.7.90+20090107-1ubuntu0.1) intrepid-proposed; urgency=low

  * Merge from debian unstable, remaining changes (LP: #288000, #217792,
    #341832):
    * Bootstrapping done via binary package from Debian unstable. See log
        entry for 7.7.90+20060906-3ubuntu1 for details.

 -- Evan Broder <email address hidden> Thu, 12 Mar 2009 12:34:43 -0400

Changed in mit-scheme (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers