FeatureFreezeException: Merge mit-scheme with Debian

Bug #339449 reported by Evan Broder on 2009-03-08
6
Affects Status Importance Assigned to Milestone
mit-scheme (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: mit-scheme

The mit-scheme package has been uninstallable since Intrepid, due to some bad auto-generated dependencies (LP bug #288000).

It also hasn't worked without some hacking around AppArmor since at least Hardy (LP bug #217792).

Re-syncing the package from Debian Testing and rebuilding solves both of these problems.

I think this merits a FeatureFreezeException simply because the chance of regression is 0 - the package is uninstallable now, so it can't regress.

For this resync, I've updated the bootstrap image by using the binary package for mit-scheme 7.7.90+20090107-1 from squeeze, in order to keep the package more or less up to date.

I'm excluding the debdiffs in this case because they're truly massive, thanks to the uuencoded Debian archive used for bootstrapping

Evan Broder (broder) wrote :
  • changelog Edit (199.4 KiB, text/plain; x-mac-type="2A2A2A2A"; x-mac-creator="48647261"; name="changelog")
  • build-log Edit (270.4 KiB, text/plain; x-mac-type="0"; x-mac-creator="0"; name="build-log")
  • install-log Edit (2.4 KiB, text/plain; x-mac-type="0"; x-mac-creator="0"; name="install-log")
  • test-log Edit (946 bytes, text/plain; x-mac-type="0"; x-mac-creator="0"; name="test-log")

Here is the upstream changelog, build log, install log, and log of some
quick functionality tests.

- Evan

Evan Broder (broder) wrote :

Blargh. I tried to submit the source package by e-mail so it should show up in a single comment, but Launchpad seems to be unwilling to let me do that, so here we go one file at a time instead.

Evan Broder (broder) wrote :
Evan Broder (broder) wrote :
Evan Broder (broder) wrote :
Evan Broder (broder) wrote :
Evan Broder (broder) wrote :

This debdiff excludes the uuencoded bootstrap deb, and is just to see the actual changes needed in the source package to build.

Iulian Udrea (iulian) wrote :

No rdepends, package builds, installs fine and closes all open bugs.

ACK #1

Thanks for taking care of this Evan.

Scott Kitterman (kitterman) wrote :

Ack #2. Approved. Subscribing uus for sponorship.

Changed in mit-scheme:
importance: Undecided → High
status: New → Confirmed
John Dong (jdong) wrote :

Sponsored into Jaunty; Since there is no changelog reference to this bug ticket, someone please update the bug status to Fix Released after it builds :)

Changed in mit-scheme:
status: Confirmed → Fix Committed
Evan Broder (broder) wrote :

This hit the archive some time in the last few hours. Thanks for your help, Iulian, Scott, and John.

Changed in mit-scheme:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers