Miredo dies unexpectedly on reload signals.

Bug #485377 reported by Toni Ruottu on 2009-11-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
miredo (Debian)
Fix Released
Unknown
miredo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: miredo

I was subscribed to bug 304958 "Network manager handles teredo interface inappropriately". The issue got fixed, but another bug was said to cause similar effects. I'm filing this new bug to pin it down for Ubuntu. It is already filed against Debian with id 554577 in their bug database.

Changed in miredo (Debian):
status: Unknown → Confirmed
Changed in miredo (Debian):
status: Confirmed → Fix Committed
Toni Ruottu (toni-ruottu) wrote :

Is the miredo Debian package maintainer aware that (s)he should be getting the new version in?

Changed in miredo (Debian):
status: Fix Committed → Fix Released
Toni Ruottu (toni-ruottu) wrote :

Version 1.2.2 which fixes this bug has hit Debian unstable. I've subscribed universe sponsors to this bug. Could someone pick this bug up and sync the package to Lucid? Unless updated the broken package will continue to break IPv6 tunnels for people who tend to move between networks. This includes many laptop users.

Ilya Barygin (randomaction) wrote :

Toni, could you convert this bug to a sync request according to https://wiki.ubuntu.com/SyncRequestProcess ? I'm unsubscribing u-u-s for now, please resubscribe when ready.

Toni Ruottu (toni-ruottu) wrote :

I've been trying to file the sync request. It is possible to do that by hand, but preferably one would use a command line utility called "requestsync". The problem is that the package does not appear at http://packages.debian.org/changelogs/pool/main/m/miredo/
Why is that? Is it just outdated? When is it going to update?

Rémi Denis-Courmont (rdenis) wrote :

There's still 6 days to go before it hits Debian squeeze.

Toni Ruottu (toni-ruottu) wrote :

Having it in Unstable is not a problem, as long as packages.debian.org updates. If it does not appear there by ~Tuesday I guess I'll file the request by hand. The only problem is I have never done that. The guide explains it all, but I'd need to find an example sync request to really understand what the end result is supposed to look like.

I filed a bug at https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/+bug/518574 for the requestsync tool depending on packages.debian.org

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package miredo - 1.2.2-1

---------------
miredo (1.2.2-1) unstable; urgency=low

  * New upstream version:
    - fixes signal handling (Closes: #554577) (LP: #485377).
    - drop merged libfreebsd-dev libtun6 patch.
  * Update my mail address and copyright statements.
  * Backport FreeBSD >= 7.2 fix from 1.2-stable branch.
  * Run autoreconf before build (Closes: #558583).
  * Build-Depend on automake and cvs as autoreconf requires both.
  * Fix closefrom() usage (returns void on FreeBSD) in src/main.c
    (backported from upstream 91ae0afe2cda419a733699a0479021882ea950aa)
  * Update standards version to 3.8.4.
 -- Ubuntu Archive Auto-Sync <email address hidden> Mon, 08 Feb 2010 11:03:37 +0000

Changed in miredo (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.