[SRU] Mir needs to be updated to 0.26 in 16.04LTS

Bug #1685186 reported by Alan Griffiths on 2017-04-21
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mir (Ubuntu)
High
Alan Griffiths
Xenial
High
Alan Griffiths
Yakkety
High
Alan Griffiths
Zesty
High
Alan Griffiths

Bug Description

[Impact]
Snap development using Mir has been using the "stable phone overlay" PPA which is both inconvenient and a legacy of the cancelled Unity8 project.

It would greatly simplify things if Mir were updated in the Xenial archive.

[Test Case]

Build a Mir client snap (e.g. lp:~albaguirre/+snap/mir-client-demos) against "Primary Ubuntu Archive" and deploy as described in https://developer.ubuntu.com/en/snappy/guides/mir-snaps/

Expected: the client apps start and are visible on screen
Actual: the client apps don't start and are not visible on screen

[Regression Potential]
Mir has two categories of dependent project:

  1 Unity8 and unity-system-compositor "server" packages
  2 toolkits and other "clients" of Mir

"Server" packages from the archive will stop working in the LTS as they will continue using the earlier libmirserver.so.38 (from Mir 0.21) which doesn't work with the libmirclient.so.9 from Mir 0.26. This is unimportant as these packages were provided as an "early experience", not for serious use.

"Client" packages are dependent only on libmirclient.so.9 which is ABI stable. The principle type of regression would be FTBFS where APIs have been deprecated in 0.26. The linked 0.26.3 release has these deprecations disabled for 16.04.

The packages are available in silo:
https://bileto.ubuntu.com/#/ticket/2736

notes:

A recursive search or rdependencies identifies the following packages in category 1:

camera-app-autopilot
gallery-app-autopilot
indicator-network-autopilot
indicators-client
qtdeclarative5-qtmir-plugin
qtmir-android
qtmir-desktop
qtmir-tests
ubuntu-desktop-mir
ubuntu-experience-tests
ubuntu-pocket-desktop
ubuntu-push-autopilot
ubuntu-touch
ubuntu-touch-session
unity8
unity8-autopilot
unity8-desktop-session-mir
unity-scope-click-autopilot
unity-system-compositor
unity-system-compositor-autopilot

Anyone wanting these packages should switch to the "unity8-desktop-session" preview package in 17.04 where they are far more functional.

[Alternatives]
If we want to keep everything working in Xenial, we *could* bump the libmirclient SONAME to libmirclient.so.10. This would result in libmirclient9 being NBS, but continuing to work against the Mir servers available in 16.04[*] (until and unless they are rebuilt).

However, this does not enable the desired result for IoT deployments of toolkits (GTK, Qt etc) and other clients working against servers (specifically miral-kiosk) built against the updated libraries.

To work for IoT these would need to rebuilt from source - at which point they (and their dependencies) would stop working against the servers in category 1.

[*] with the exception of the servers provided in mir-examples, these would only work with clients linking against libmirclient.so.10.

description: updated
Changed in mir (Ubuntu):
assignee: nobody → Alan Griffiths (alan-griffiths)
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

Yeah I agree. Mir lives on in a new form, and that should be without PPAs. Thus the archive should be updated if anything Mir-related is desired on xenial.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
Alan Griffiths (alan-griffiths) wrote :

Keeping notes here for ease of reference. The rdepends of libmirclient are:

libmirclient9
Reverse Depends:
  Depends: ubuntu-application-api3-desktop (>= 0.19.0+16.04.20160128)
  Depends: xmir-hwe-16.04 (>= 0.21.0+16.04.20160330)
  Depends: xmir (>= 0.21.0+16.04.20160330)
  Depends: libgtk-3-0 (>= 0.21.0+16.04.20160330)
  Depends: xmir (>= 0.20.3+16.04.20160322)
  Depends: url-dispatcher (>= 0.17.1+16.04.20151105.1)
  Depends: unity-system-compositor (>= 0.20.2+16.04.20160307)
  Depends: ubuntu-system-settings-online-accounts (>= 0.20.2+16.04.20160307)
  Depends: ubuntu-application-api3-touch (>= 0.19.0+16.04.20160128)
  Depends: qtdeclarative5-qtmir-plugin (>= 0.20.3+16.04.20160322)
  Depends: ubuntu-app-test (>= 0.17.1+16.04.20151105.1)
  Depends: qtubuntu-desktop (>= 0.20.2+16.04.20160307)
  Depends: qtubuntu-android (>= 0.20.2+16.04.20160307)
  Depends: qtmir-desktop (>= 0.20.3+16.04.20160322)
  Depends: qtmir-android (>= 0.20.3+16.04.20160322)
  Depends: libubuntu-app-launch2 (>= 0.17.1+16.04.20151105.1)
  Depends: pay-service (>= 0.20.2+16.04.20160307)
  Depends: mir-utils (>= 0.21.0+16.04.20160330)
  Depends: mir-test-tools (>= 0.21.0+16.04.20160330)
  Depends: mir-demos (>= 0.21.0+16.04.20160330)
  Depends: mir-client-platform-mesa5 (>= 0.21.0+16.04.20160330)
  Depends: mir-android-diagnostics (>= 0.21.0+16.04.20160330)
  Depends: libtrust-store2 (>= 0.18.1+16.04.20160115)
  Depends: glmark2-es2-mir (>= 0.14.0+15.10.20150701)
  Depends: glmark2-mir (>= 0.14.0+15.10.20150701)
  Depends: libmirserver38 (>= 0.21.0+16.04.20160330)
  Depends: libmirclient-dev (= 0.21.0+16.04.20160330-0ubuntu1)
  Depends: libgtk-3-0 (>= 0.20.2+16.04.20160307)

Removing the Mir packages:

glmark2-es2-mir
glmark2-mir
libgtk-3-0
libtrust-store2
libubuntu-app-launch2
pay-service
qtubuntu-android
qtubuntu-desktop
ubuntu-application-api3-desktop
ubuntu-application-api3-touch
ubuntu-app-test
ubuntu-system-settings-online-accounts
unity-system-compositor
url-dispatcher
xmir

These are the packages that may FTBFS if 0.26 is pushed to the store

Changed in mir (Ubuntu):
status: Confirmed → In Progress
description: updated
Changed in mir (Ubuntu):
importance: Undecided → High
tags: added: verification-needed
description: updated
summary: - Mir needs to be updated in 16.04 and the dependency tree trimmed
+ Mir needs to be updated to 0.26 in 16.04LTS
Michał Sawicz (saviq) on 2017-05-12
summary: - Mir needs to be updated to 0.26 in 16.04LTS
+ [SRU] Mir needs to be updated to 0.26 in 16.04LTS
description: updated
description: updated
description: updated
Changed in mir (Ubuntu):
status: In Progress → Fix Committed
Changed in mir (Ubuntu):
status: Fix Committed → In Progress
description: updated
description: updated

Hello Alan, or anyone else affected,

Accepted mir into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+16.04.20170510-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mir (Ubuntu Xenial):
status: New → Fix Committed
Alan Griffiths (alan-griffiths) wrote :

This works fine on a AMD64 desktop

Michał Sawicz (saviq) wrote :

We've updated, built and tested the snaps comprising the "kiosk" stack [1]. Everything is in order.

[1] https://developer.ubuntu.com/en/snappy/guides/mir-snaps/

Alan Griffiths (alan-griffiths) wrote :

Tested version 0.26.3+16.04.20170510-0ubuntu1

Brian Murray (brian-murray) wrote :

I've set this to verification-failed to prevent the accidental release of the package because these changes do not seem to exist in Artful, a requirement of the SRU process, and the version number of the package in xenial-proposed is greater than the version of the package in releases newer than Ubuntu 16.04.

Changed in mir (Ubuntu Xenial):
status: Fix Committed → Incomplete
tags: added: verification-failed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+17.10.20170526.3-0ubuntu1

---------------
mir (0.26.3+17.10.20170526.3-0ubuntu1) artful; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Alan Griffiths <email address hidden> Fri, 26 May 2017 16:57:20 +0000

Changed in mir (Ubuntu):
status: In Progress → Fix Released
Changed in mir (Ubuntu):
status: Fix Released → In Progress
Changed in mir (Ubuntu Xenial):
status: Incomplete → In Progress
importance: Undecided → High
assignee: nobody → Alan Griffiths (alan-griffiths)
Changed in mir (Ubuntu):
status: In Progress → Fix Released

Added Zesty and Yakkety as they need to have at least the version in Xenial.

For Zesty this is a bugfix update, on Yakkety it has the same effect as on Xenial (of making some "early experience" downstreams a little less useful).

Changed in mir (Ubuntu):
status: Fix Released → In Progress
Michał Sawicz (saviq) on 2017-06-02
Changed in mir (Ubuntu Yakkety):
status: New → In Progress
Changed in mir (Ubuntu Zesty):
status: New → In Progress
Changed in mir (Ubuntu Yakkety):
importance: Undecided → High
Changed in mir (Ubuntu Zesty):
importance: Undecided → High
Changed in mir (Ubuntu Yakkety):
assignee: nobody → Alan Griffiths (alan-griffiths)
Changed in mir (Ubuntu Zesty):
assignee: nobody → Alan Griffiths (alan-griffiths)

Set back to verification-needed as we now have the binaries for all the supported releases

tags: added: verification-needed
removed: verification-failed
Chris Halse Rogers (raof) wrote :

Hello Alan, or anyone else affected,

Accepted mir into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+16.04.20170605-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mir (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in mir (Ubuntu Yakkety):
status: In Progress → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Alan, or anyone else affected,

Accepted mir into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+16.10.20170605-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris Halse Rogers (raof) wrote :

Hello Alan, or anyone else affected,

Accepted mir into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+17.04.20170605-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mir (Ubuntu Zesty):
status: In Progress → Fix Committed
Michał Sawicz (saviq) wrote :

Tested:
xenial: 0.26.3+16.04.20170605-0ubuntu1
yakkety: 0.26.3+16.10.20170605-0ubuntu1
zesty: 0.26.3+17.04.20170605-0ubuntu1

All is fine.

tags: added: verification-done
removed: verification-needed
tags: added: verification-done-xenial verification-done-yakkety verification-done-zesty
removed: verification-done

The verification of the Stable Release Update for mir has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+16.10.20170605-0ubuntu1

---------------
mir (0.26.3+16.10.20170605-0ubuntu1) yakkety; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Michał Sawicz <email address hidden> Mon, 05 Jun 2017 13:46:05 +0000

Changed in mir (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+16.04.20170605-0ubuntu1

---------------
mir (0.26.3+16.04.20170605-0ubuntu1) xenial; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Michał Sawicz <email address hidden> Mon, 05 Jun 2017 11:01:05 +0000

Changed in mir (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+17.04.20170605-0ubuntu1

---------------
mir (0.26.3+17.04.20170605-0ubuntu1) zesty; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Michał Sawicz <email address hidden> Mon, 05 Jun 2017 11:04:47 +0000

Changed in mir (Ubuntu Zesty):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) on 2017-08-24
Changed in mir (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers