Please transition to latest Boost

Bug #1675138 reported by Balint Reczey on 2017-03-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Mattia Rizzolo
0.26
Fix Released
High
Mattia Rizzolo
mir (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

There is an ongoing transition to Boost 1.62 and mir is one of the last affected packages:
http://people.canonical.com/~ubuntu-archive/transitions/html/boost1.62.html

Balint Reczey (rbalint) wrote :

fixed my email address in the patch

The attachment "debdiff performing the transition" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mattia Rizzolo (mapreri) wrote :

why can't mir depend on unversioned boost?

Balint Reczey (rbalint) wrote :

Those were added in #1633537

Balint Reczey (rbalint) wrote :

in LP:#1633537

Balint Reczey (rbalint) wrote :
Balint Reczey (rbalint) wrote :

Let me try once more: LP: #1633537

Mattia Rizzolo (mapreri) wrote :

ok, that doesn't explain why it can't be unversioned.

Then I noticed that it depends on the library package instead of the -dev package (i.e. it's not explicitly pulling in the package containing the relevant .so file), so it seems even more broken to me.

Really that should be 'libboost-filesystem-dev, libboost-system-dev' and nothing else, IMHO.
I'll prepare a bzr MR, given that the mir teams seems to be working with those, and I do not think the mir team would appreciate a direct upload.

Changed in mir (Ubuntu):
status: New → In Progress
assignee: nobody → Mattia Rizzolo (mapreri)
Changed in mir:
assignee: nobody → Mattia Rizzolo (mapreri)
milestone: none → 1.0.0
Changed in mir (Ubuntu):
importance: Undecided → High
Changed in mir:
importance: Undecided → Medium
status: New → In Progress
Changed in mir (Ubuntu):
status: In Progress → Triaged
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
importance: Medium → High
Mattia Rizzolo (mapreri) wrote :

Thank you for merging!

What is the expected time frame for the next upload to the archive, containing this change?

Daniel van Vugt (vanvugt) wrote :

That's on trunk right now so we're looking at next cycle: 1.0

If it's safe enough for zesty however we could try scheduling it for 0.26.3
which does not have a timeframe right now. We are working on releasing 0.26.2 at present.

Mattia Rizzolo (mapreri) wrote :

I'd really appreciate if it could be scheduled for 0.26.2, actually. It's a packaging-only change, making progress on a transition. I'm not involved in this boost transition myself, but I know I hate any kind of delay. Besides, to me it looks like mir is the last actionable package on the list before boost1.61 removal (if it was in my power I'd just remove the other 2).

Balint Reczey (rbalint) wrote :

@Mattia: From the linked bug it seems reverse build dependencies needed those libs listed. I haven't tried changing those to unversioned depends, because IMO at this stage a safe fix like this one is more appropriate.
The fix for both other transitioning packages are on their way, no need to remove them. :-)

@Daniel: I'm running ratt soon for reverse dependencies, but build an piuparts went fine and I consider this a safe fix.

Resolved on #ubuntu-mir...

<mapreri> if you are fine with people uploading the package directly to the archive we can work it out, i.e. I upload a -2 as soon at 0.26.2-1 is uploaded, but then your next upload done through whatever CI should contain it.
<alan_g> mapreri: that would work for me
<mapreri> I have no idea how bileto (or whatever kind of CI/landing system) you are using work
<mapreri> oh, great
<mapreri> so, what would be the timing for 0.26.2 to land? :)
<alan_g> mapreri: out of my hands, first QA need to approve and then someone needs to push to archive. But I'd guess the next day or two.
<mapreri> that works just fine
<mapreri> I'll arrange the -2 upload, will you please merge it in 0.26.3 in the meantime?
<alan_g> AFAIK 0.26.3 doesn't exist (and likely won't). But I'll take care of it in that contingency.

tags: added: packaging

Mir 0.26.2 has passed QA and should be landing soon (as soon as I can find someone to publish it).

Changed in mir (Ubuntu):
status: Triaged → Fix Committed
Changed in mir (Ubuntu):
status: Fix Committed → Triaged
assignee: Mattia Rizzolo (mapreri) → nobody
Daniel van Vugt (vanvugt) wrote :

Ignore comment #16 as it's not relevant to this bug. The fix for this bug is NOT in Mir 0.26 or Ubuntu branches.

Mattia Rizzolo (mapreri) wrote :

FWIW, the fix for this bug in the -2 upload, waiting in the unapproved queue, until somebody from the release team approves it… (and it's been there for nearly 3 days already…).

Changed in mir (Ubuntu):
status: Triaged → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Cool. That was the plan. I just didn't know where it was.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.2+17.04.20170322.1-0ubuntu2

---------------
mir (0.26.2+17.04.20170322.1-0ubuntu2) zesty; urgency=medium

  [ Mattia Rizzolo ]
  * Patch the code to use unversioned runtime boost libraries (LP: #1675138).

 -- Gianfranco Costamagna <email address hidden> Fri, 24 Mar 2017 22:58:36 +0100

Changed in mir (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Only problem now is that zesty contains different code to what's in lp:mir/ubuntu. We may need to deal with minor conflicts at the next Mir release.

Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.26 at revision 4051, scheduled for release in Mir 0.26.3 (if that gets released at all)

Hello Balint, or anyone else affected,

Accepted mir into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+16.04.20170510-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mir (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed

Fixed in xenial-proposed, verified in 0.26.3+16.04.20170510-0ubuntu1.

Balint Reczey (rbalint) wrote :

The package does not actually transition to Boost 1.62 in Xenial because this Boost version is not present there, but mirtest-dev properly depends on unversioned Boost development libraries.

tags: added: verification-done
removed: verification-needed

Hello Balint, or anyone else affected,

Accepted mir into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+16.04.20170605-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Changed in mir (Ubuntu Yakkety):
status: New → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Balint, or anyone else affected,

Accepted mir into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+16.10.20170605-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris Halse Rogers (raof) wrote :

Hello Balint, or anyone else affected,

Accepted mir into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mir/0.26.3+17.04.20170605-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mir (Ubuntu Zesty):
status: New → Fix Committed

Tested:
xenial: 0.26.3+16.04.20170605-0ubuntu1
yakkety: 0.26.3+16.10.20170605-0ubuntu1
zesty: 0.26.3+17.04.20170605-0ubuntu1

All is fine.

tags: added: verification-done
removed: verification-needed
summary: - Please transition to Boost 1.62
+ Please transition to latest Boost
tags: added: verification-done-xenial verification-done-yakkety verification-done-zesty
removed: verification-done

The verification of the Stable Release Update for mir has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+16.10.20170605-0ubuntu1

---------------
mir (0.26.3+16.10.20170605-0ubuntu1) yakkety; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Michał Sawicz <email address hidden> Mon, 05 Jun 2017 13:46:05 +0000

Changed in mir (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+16.04.20170605-0ubuntu1

---------------
mir (0.26.3+16.04.20170605-0ubuntu1) xenial; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Michał Sawicz <email address hidden> Mon, 05 Jun 2017 11:01:05 +0000

Changed in mir (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.3+17.04.20170605-0ubuntu1

---------------
mir (0.26.3+17.04.20170605-0ubuntu1) zesty; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.3 (https://launchpad.net/mir/+milestone/0.26.3)
    - Enhancements:
      . Make deprecations optional (and default to off for builds on 16.04 LTS)
      . Added support for building on Ubuntu 17.10 artful.
    - Bugs fixed:
      . Mir needs to be updated to 0.26 in 16.04LTS (LP: #1685186)
      . unity-system-compositor crashed with SIGSEGV in
        libinput_device_config_accel_is_available() from
        libinput_device_config_accel_set_speed() from
        mir::input::evdev::LibInputDevice::apply_settings() (LP: #1672955)
      . Please transition to Boost 1.62 (LP: #1675138)
      . Mir sending key repeat events continually to nested shell after VT
        switch (causes Unity8 lockup for a while) (LP: #1675357)
      . mir_demo_standalone_render_overlays fails to link (LP: #1677239)

 -- Michał Sawicz <email address hidden> Mon, 05 Jun 2017 11:04:47 +0000

Changed in mir (Ubuntu Zesty):
status: Fix Committed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers