Touchpad scrolling should be enabled by default in Unity8

Bug #1604032 reported by kevin gunn on 2016-07-18
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Michał Sawicz
Mir
Invalid
Undecided
Unassigned
gsettings-ubuntu-touch-schemas (Ubuntu)
Undecided
Lukáš Tinkl
mir (Ubuntu)
Undecided
Unassigned
qtmir (Ubuntu)
High
Unassigned
ubuntu-ui-toolkit (Ubuntu)
High
Unassigned
unity8 (Ubuntu)
High
Unassigned

Bug Description

this used to work,
on a unity8-desktop-session, launch browser
on touchpad scroll up/down
expect webpage to scroll, but currently there is no reaction

the only way to get a webpage to scroll is to grab the page with a mousebutton down and hold it.

Related branches

kevin gunn (kgunn72) on 2016-07-18
Changed in canonical-devices-system-image:
importance: Undecided → Critical
Changed in mir (Ubuntu):
importance: Undecided → Critical
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Critical
kevin gunn (kgunn72) on 2016-07-18
Changed in qtmir (Ubuntu):
importance: Undecided → Critical
summary: - scrolling broken on unity8 desktop (regression)
+ Touchpad scrolling broken on unity8 desktop (regression)
tags: added: regression

Confirmed (using Apple Magic Trackpad) that two-finger scrolling is non-responsive in webbrowser-app and System Settings. But I have also verified that two-finger scrolling still works in Xmir and native GTK apps. So the regression is specific to Qt.

Changed in mir:
status: New → Invalid
Changed in mir (Ubuntu):
status: New → Invalid
summary: - Touchpad scrolling broken on unity8 desktop (regression)
+ [regression] Touchpad scrolling broken in Qt apps

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtmir (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Confirmed also there's a touchpad scrolling regression in Unity8/QtMir. Apps that can scroll wityh the touchpad fine in Mir's demo servers can't do so in Unity8.

Changed in unity8 (Ubuntu):
status: New → Confirmed
summary: - [regression] Touchpad scrolling broken in Qt apps
+ [regression] Touchpad scrolling broken in Qt apps and Unity8

Although... touchpad scroll sensitivity is really bad even where it works in the Mir demo servers.

Maybe Mir regressed the scroll sensitivity and Qt can't deal with the reduced precision or inconsistent events...

Changed in mir:
status: Invalid → New
Changed in mir (Ubuntu):
status: Invalid → New
Daniel van Vugt (vanvugt) wrote :

I was wrong. Clients are getting correct scrolling information using two fingers, as seen by:

MIR_CLIENT_INPUT_RECEIVER_REPORT=log

Changed in mir:
status: New → Invalid
Changed in mir (Ubuntu):
status: New → Invalid
Changed in qtmir (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
Changed in unity8 (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
Changed in qtmir (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
assignee: Daniel d'Andrada (dandrader) → nobody
Changed in unity8 (Ubuntu):
assignee: Daniel d'Andrada (dandrader) → nobody
Daniel d'Andrada (dandrader) wrote :

1 - Open System Settings
2 - Click on "Mouse & Touchpad"
3 - Check the "Scroll with two fingers" box

It then works

Changed in qtmir (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: New → Invalid
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Invalid
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Michał Sawicz (saviq) wrote :

I've put the overarching task to Opinion as we might want to change the default values for these settings.

Changed in canonical-devices-system-image:
status: Invalid → Opinion
Daniel van Vugt (vanvugt) wrote :

The bug will get lost if we leave it as Invalid or Opinion.

Yes we do need to change the defaults, because presently laptop owners can't scroll at all :)

Changed in unity8 (Ubuntu):
status: Invalid → New
Changed in qtmir (Ubuntu):
status: Invalid → New
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Invalid → New
Changed in canonical-devices-system-image:
status: Opinion → New
Changed in qtmir (Ubuntu):
importance: Critical → High
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Critical → High
Changed in unity8 (Ubuntu):
importance: Undecided → High
Changed in mir (Ubuntu):
importance: Critical → Undecided
kevin gunn (kgunn72) on 2016-07-21
tags: added: unity8-desktop
summary: - [regression] Touchpad scrolling broken in Qt apps and Unity8
+ [regression] Touchpad scrolling should be enabled by default in Unity8
summary: - [regression] Touchpad scrolling should be enabled by default in Unity8
+ Touchpad scrolling should be enabled by default in Unity8
Changed in canonical-devices-system-image:
status: New → Confirmed
assignee: nobody → Michał Sawicz (saviq)
importance: Critical → High
Daniel d'Andrada (dandrader) wrote :

@vanvugt

Can we at least choose the right packages/projects?

I'm pretty sure ubuntu-ui-toolkit has nothing to do with it whatsoever.

Don't know if qtmir or unity8 would be the place for setting the default config of this libinput(?) stuff...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Invalid
Daniel van Vugt (vanvugt) wrote :

Sorry, I don't know everything about the Unity8 architecture and sometimes make mistakes in assigning bugs.

Changed in qtmir (Ubuntu):
status: New → Invalid
Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
Changed in unity8 (Ubuntu):
status: New → Invalid
Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
status: New → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
milestone: none → 13
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsettings-ubuntu-touch-schemas - 0.0.7+16.10.20160730-0ubuntu1

---------------
gsettings-ubuntu-touch-schemas (0.0.7+16.10.20160730-0ubuntu1) yakkety; urgency=medium

  * Enable TouchpadTwoFingerScroll and TouchpadTapToClick by default
    (LP: #1603183, #1604032)

 -- Lukáš Tinkl <email address hidden> Sat, 30 Jul 2016 21:17:59 +0000

Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers