Mir-on-X11 breaks mir_proving_server resize logic

Bug #1575192 reported by Alan Griffiths on 2016-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Low
Cemil Azizoglu
mir (Ubuntu)
Undecided
Unassigned

Bug Description

$ mir_proving_server&
$ mir_demo_client_egltriangle

Alt+drag with middle mouse button

Expect: client is resized
Actual: Nothing happens

A bit of investigation shows that the mouse-button-down event isn't being received. (The movement event is received.)

(The problem doesn't occur on other platforms.)

Related branches

summary: - Mir-on-X breaks mir_proving_server resize logic
+ Mir-on-X11 breaks mir_proving_server resize logic
Cemil Azizoglu (cemil-azizoglu) wrote :

This works for me.

Can you put a printf in this function to see what button is being pressed in your mouse?
http://bazaar.launchpad.net/~mir-team/mir/development-branch/view/head:/src/platforms/mesa/server/x11/input/input_device.cpp#L37

Daniel van Vugt (vanvugt) wrote :

Haven't tested yet, but bug 1575765 has reminded me this probably should not be expected to work.

Without a pointer grab, Compiz will be intercepting the Alt+drag. Indeed, the click and drag should never reach the Mir server.

Cemil Azizoglu (cemil-azizoglu) wrote :

Hmm I'm not sure why it works for me then. Perhaps the middle button on my mouse is nonstandard.

Cemil Azizoglu (cemil-azizoglu) wrote :

With https://code.launchpad.net/~cemil-azizoglu/mir/fix-1575765/+merge/293267, we should have pointer grabbing. Let's see what you get with that.

Alan Griffiths (alan-griffiths) wrote :

The middle button is 2 (correctly mapped to mir_pointer_button_tertiary).

Alan Griffiths (alan-griffiths) wrote :

OK, it (sort of) makes sense that compiz takes the Alt-middle down event but passes on the drag. And that explains everything except it working for Cemil. (Is he using Unity7?)

Changed in mir:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Cemil Azizoglu (cemil-azizoglu)
milestone: none → 0.23.0
status: Confirmed → In Progress
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.23.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.23.0+16.10.20160602.1-0ubuntu1

---------------
mir (0.23.0+16.10.20160602.1-0ubuntu1) yakkety; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.23.0 (https://launchpad.net/mir/+milestone/0.23.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 40
      . mircommon ABI bumped at 6
      . mirplatform ABI unchanged at 11
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 9
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 5
    - Enhancements:
      . Enable internal usage of more flexible graphics buffer submission,
        precursing client API additions.
    - Bug fixes:
      . Potential NBS performance loss after resize (LP: #1579076)
      . Performance loss with NBS and overlays on (LP: #1578159)
      . Mir crashes with useless backtrace when mg::Platform methods throw
        (LP: #1553549)
      . Virtual output is not removed when screencast client disappears
        (LP: #1573572)
      . Can't VT switch from mir_demo_server (any more) (LP: #1576260)
      . mir_demo_server(_minimal): Window movement/resizing stops responding
        when the cursor leaves the surface, and can lead to windows 1px wide
        and unrecoverable. (LP: #1447886)
      . Virtual display output configuration is set to LVDS (LP: #1573782)
      . Mir-on-X11 doesn't pass Alt+primary button drag to Mir (LP: #1575765)
      . Mir-on-X11 breaks mir_proving_server resize logic (LP: #1575192)
      . Resizing can crash mir_demo_server (LP: #1575211)
      . [regression] Cursor stops at phantom edge on M10 and N7 (LP: #1580774)
      . [regression] MIR_CLIENT_PERF_REPORT is showing bogus render times and
        buffer lag (LP: #1581368)
      . Test failures in ClientLogging.reports_performance due to the above
        fix. (LP: #1583970, LP: #1584603, LP: #1584605)
      . Do not throw when creating some objects under HWC 1.5 (LP: #1583086)
      . Correct black frame issue under Xmir (LP: #1584784)

  [ Tarmac, Kevin DuBois <email address hidden>, Daniel van Vugt <email address hidden>, Andreas Pokorny <email address hidden>, Alberto Aguirre ]
  * 0.23.0 Mir release

 -- Kevin DuBois <email address hidden> Thu, 02 Jun 2016 13:18:03 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers