[regression] mir-client-platform-mesa-dev pkg-config file dropped

Bug #1509005 reported by Matthias Klose on 2015-10-22
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Chris Halse Rogers
mesa (Ubuntu)
High
Unassigned
Wily
High
Unassigned
mir (Ubuntu)
Medium
Unassigned
Wily
Medium
Unassigned
xorg-server (Ubuntu)
High
Unassigned
Wily
High
Unassigned

Bug Description

the mir-client-platform-mesa-dev pkg-config file was dropped in wily, leading to build errors for such optional packages like mesa and xorg-server.

Even if you have a feature freeze exception, you shouldn't break existing API's after feature freeze.

Related branches

Daniel van Vugt (vanvugt) wrote :

I ran into this problem too.

It's annoying, however when I investigated I found the new .pc file name (same as the old one but without "-dev") is more correct and more like that of other projects...

https://git.launchpad.net/~xmir-team/xorg-server/+git/xmir/commit/?id=f0a0fa747226a6a012c4fc79c1d61463d76ff1d2

I don't think ~mir-team is going to, or has any desire to change it back.

Changed in mir:
status: New → Won't Fix
Changed in mir (Ubuntu):
status: Confirmed → Won't Fix
Daniel van Vugt (vanvugt) wrote :

I'm not endorsing late changes of any sort. Just trying to be realistic in the face of breakages that have already been released...

Chris Halse Rogers (raof) wrote :

We can't WontFix this in the distro. We broke feature freeze and broke unrelated software.

We can SRU in https://code.launchpad.net/~raof/mir/reinstate-old-pc-file/+merge/275487

Changed in mir:
status: Won't Fix → In Progress
assignee: nobody → Chris Halse Rogers (raof)
Daniel van Vugt (vanvugt) wrote :

Unfortunately changing it back will break those projects that already support Mir 0.17.0. Xmir and possibly much more.

Daniel van Vugt (vanvugt) wrote :

What we could do is have both file names side by side.

Daniel van Vugt (vanvugt) wrote :

BTW, the issue originated here:

------------------------------------------------------------
revno: 2965 [merge]
author: Robert Ancell <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Fri 2015-09-25 17:28:59 +0000
message:
  Rename mir-client-platform-mesa-dev pkgconfig file to more standard mir-client-platform-mesa.

  Approved by PS Jenkins bot, Alan Griffiths, Chris Halse Rogers.
------------------------------------------------------------

Changed in mir:
milestone: none → 0.18.0
Changed in mir:
importance: Undecided → Medium
tags: added: regression
summary: - mir-client-platform-mesa-dev pkg-config file dropped
+ [regression] mir-client-platform-mesa-dev pkg-config file dropped
Alexandros Frantzis (afrantzis) wrote :

Would it be acceptable to update the xorg and mesa packages to use the new pkgconfig file name instead of changing Mir (which is what we should have done much earlier)?

Changed in mir (Ubuntu):
status: Won't Fix → Triaged

On 23.10.2015 09:51, Alexandros Frantzis wrote:
> Would it be acceptable to update the xorg and mesa packages to use the
> new pkgconfig file name instead of changing Mir (which is what we should
> have done much earlier)?

in this case, please can you make sure that other reverse build dependencies are
changed too? Of course you should check them. both main and universe, I only
saw this while doing a late test rebuild of main only to test other things.

no longer affects: mir
no longer affects: mir/0.17
Changed in mir:
milestone: none → 0.17.1
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Chris Halse Rogers (raof)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu Wily):
status: New → Confirmed
Changed in mesa (Ubuntu):
status: New → Confirmed
Changed in mir (Ubuntu Wily):
status: New → Confirmed
Changed in xorg-server (Ubuntu Wily):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.17 at revision 3010, scheduled for release in Mir 0.17.1

Changed in mir:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 11.0.4-1ubuntu1

---------------
mesa (11.0.4-1ubuntu1) xenial; urgency=medium

  [ Timo Aaltonen ]
  * Merge from Debian.
  * patches: Dropped patches included in this release, fix Mir patch
    FTBFS. (LP: #1509005)

  [ Christopher James Halse Rogers ]
  * patches: Fix Mir patch harder.

mesa (11.0.4-1) unstable; urgency=medium

  [ Andreas Boll ]
  * New upstream release.
  * Cherry-pick commit 70e91d6 (i965: Remove early release of DRI2
    miptree) from upstream (Closes: #769518).
  * control: Add libclc-amdgcn to mesa-opencl-icd depends.

 -- Timo Aaltonen <email address hidden> Wed, 28 Oct 2015 07:58:56 +0200

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

xserver fixed in xenial by 1.17.2-1ubuntu10

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released

Hello Matthias, or anyone else affected,

Accepted xorg-server into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.17.2-1ubuntu9.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Wily):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Changed in xorg-server (Ubuntu Wily):
importance: Undecided → High
Changed in mesa (Ubuntu):
importance: Undecided → High
Changed in mesa (Ubuntu Wily):
importance: Undecided → High
tags: added: regression-release wily
removed: regression
Changed in mesa (Ubuntu Wily):
milestone: none → wily-updates
Changed in mir (Ubuntu):
milestone: wily-updates → none
Changed in xorg-server (Ubuntu Wily):
milestone: none → wily-updates
tags: added: ftbfs
Changed in mir (Ubuntu):
importance: Critical → Medium
Changed in mir (Ubuntu Wily):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :
Download full text (152.7 KiB)

This bug was fixed in the package mir - 0.17.1+16.04.20151105.1-0ubuntu1

---------------
mir (0.17.1+16.04.20151105.1-0ubuntu1) xenial; urgency=medium

  [ Alberto Aguirre ]
  * New upstream release 0.17.1 (https://launchpad.net/mir/+milestone/0.17.1)
    - No ABI changes. Bug fix release only.
    - Bugs fixed:
      . compositing never stops when external monitor is connected
        (LP: #1499039)
      . half screen on external monitor (LP: #1511538)
      . Nested servers don't apply their display configuration at startup
        (LP: #1492269)
      . libmircookie1 package does not list libnettle as dependency
        (LP: #1513225)
      . unity-system-compositor crash, no interaction on windowed mode
        (LP: #1511095)
      . mir_connection_get_egl_pixel_format() crashes (LP: #1510218)
      . [regression] mir-client-platform-mesa-dev pkg-config file dropped
        (LP: #1509005)

  [ CI Train Bot ]
  * New rebuild forced.

mir (0.17.0+15.10.20151008.2-0ubuntu1) wily; urgency=medium

  [ Alexandros Frantzis ]
  * New upstream release 0.17.0 (https://launchpad.net/mir/+milestone/0.17.0)
    - ABI summary: Only servers and graphics drivers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 35
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI bumped to 11
      . Mirprotobuf ABI bumped to 3
      . Mirplatformgraphics ABI bumped to 6
      . Mirclientplatform ABI unchanged at 3
    - Enhancements:
      . Introduce libmircookie, a simple mechanism for a group of cooperating
        processes to hand out and verify difficult-to-forge timestamps to
        untrusted 3rd parties.
      . More refactorings to support renderers other than GL.
      . Add MirBlob to the client API - a tool for serializing and
        deserializing data.
      . Introduce a libinput based input platform, not yet used by default.
      . Provide a mechanism for the shell to send events on surface
        construction.
      . Provide mir::shell::DisplayConfigurationController allowing shells
        to correctly change the display configuration, notifying clients
        as appropriate.
      . New DSO versioning guide.
      . Send events pertaining to the output a surface is currently on (dpi,
        form factor, scale) to clients.
    - Bug fixes:
      . [enhancement] XMir specific documentation should live in its own
        subsection (LP: #1200114)
      . Nested servers need cursor support (LP: #1289072)
      . Mir cursor is missing/invisible until the client sets it multiple
        times (LP: #1308133)
      . [regression] Fullscreen software surfaces (like Xmir -sw) can crash
        the Mir server (LP: #1493721)
      . [usc] Mir gives up and shuts down due to input with multimonitor qtmir
        (std::exception::what: Failure sending input event) (LP: #1496069)
      . Mouse cursor disappears upon entering the surface area of a nested
        client (LP: #1496849)
      . [android] input is not dispatched when attaching an external monitor
        (LP: #1498045)
      . [android] input coordinates are scaled incorrectly when an external
        display is connected (LP: #1498540)
      . [andro...

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.17.2-1ubuntu9.1

---------------
xorg-server (2:1.17.2-1ubuntu9.1) wily; urgency=medium

  * debian/patches:
    - linux-Do-not-call-FatalError-from-xf86CloseConsole.patch: Fix crashers
      often occuring on shutdown (LP: #1237904)
    - xmir.patch: Fix typo causing FTBFS (LP: #1509005)

 -- Tim Lunn <email address hidden> Mon, 26 Oct 2015 12:24:30 +1100

Changed in xorg-server (Ubuntu Wily):
status: Fix Committed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
information type: Public → Public Security
information type: Public Security → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers