[regression] ServerShutdownWithThreadException.server_releases_resources_on_abnormal_input_thread_termination failure

Bug #1481034 reported by Alberto Aguirre on 2015-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alberto Aguirre
mir (Ubuntu)
Undecided
Unassigned

Bug Description

ServerShutdownWithThreadException.server_releases_resources_on_abnormal_input_thread_termination is failing intermittently after r2804

7: [ RUN ] ServerShutdownWithThreadException.server_releases_resources_on_abnormal_input_thread_termination
7: [1438614320.861995] mirplatform: Found graphics driver: dummy
7: [1438614320.862010] mirplatform: Found graphics driver: android
7: [1438614320.862083] mirplatform: Found graphics driver: mesa-kms
7: [1438614320.862894] mirserver: Mir version 0.15.0
7: terminate called after throwing an instance of 'std::future_error'
7: what(): std::future_error: Promise already satisfied
7: /«BUILDDIR»/mir-0.15.0+15.10.20150803/tools/detect_fd_leaks.bash: line 75: 759 Aborted (core dumped) $@ 2>&1
7: 760 Done | detect_fd_leaks
7/9 Test #7: mir_integration_tests .............***Failed 1.08 sec

Related branches

Changed in mir:
status: New → In Progress
assignee: nobody → Alberto Aguirre (albaguirre)
milestone: none → 0.15.0
Changed in mir:
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

Separated tasks. Because the number of tasks should follow the number of unique branches/series a fix is needed in.

Changed in mir:
milestone: 0.15.0 → 0.16.0
summary: + [regression]
ServerShutdownWithThreadException.server_releases_resources_on_abnormal_input_thread_termination
failure
tags: added: regression
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.16.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:mir/0.15 at revision 2808, scheduled for release in Mir milestone 0.15.0

no longer affects: mir/0.15
Changed in mir:
milestone: 0.16.0 → 0.15.0
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers